Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7378
  • Last Modified:

AudioEndPointBuilder has too much Disk I/O Activity after Startup

I have Vista Home Premium. After each startup the hard drive light shows a lot of activity for several minutes. After adding "I/O READ" and "I/O Other" columns to the Task Manager Processes view I see that svchost.exe is responsible for disk activity. This in turn points to the new AudioEndpointBuilder service which must run to support Windows Audio service.

It appears from the I/O count that the AudioEndpointBuilder service is doing something with every file on my hard drive (perhaps building a database or possibly searching for files associated with audio).

I cannot disable AudioEndpointBuilder without also disabling Windows Audio. If I "End Processs" the scvhost.exe instance that is associated with AudioEndpointBuilder it will stop the Disk activity for a short period of time but then something restarts it again.

I really dislike having any service that hammers on my hard drive like this after each startup. Can you confirm that other Vista Home Premium PCs have increasing "I/O reads" & "I/O others" when viewed in Task Manager for the svchost associated with AudioEndpointBuilder and propose a way to put a stop to this type of I/O activity without stopping Windows Audio?
0
jdwarren
Asked:
jdwarren
  • 3
1 Solution
 
wwwallyCommented:
Hello jdwarren,
Can't say a had the same problem but i did had a lot of I/O on my disks.
After installing the following two patches, the system was more stable and much faster.
http://bink.nu/Article10707.bink
good luck,
Walter
0
 
jdwarrenAuthor Commented:
Thanks. But-
Turns out Windows Task manager mislead me as it was not AudioEndpointBuilder after all. Turning off the SuperFetch service puts a halt to this I/O performance issue at startup. Now that I understand it - this simply comes down to another personal Vista tweak preference. The preference being are 1) you willing to let the OS take a little longer when you first open an application? or 2) do you want to let your hard drive get hammered for several minutes every time you startup (possibly along with your CPU)?  My personal preference is now to disable SuperFetch.

I will accept what I just wrote above as the solution to anyone who verifies it is true on another Vista computer and submits a similar comment (or if proven wrong I will consider any other proposed solutions  as well).
0
 
jdwarrenAuthor Commented:
OK. The Microsoft performance upgrade pointed at in the link provided by Walter was released on 8/7/2007 and includes a fix to "Poor memory management performance occurs". See

http://support.microsoft.com/kb/938979

Since this is a very recent release and maybe not available yet via windows automatic updating, I went ahead and installed it.

One more comment - Since the problem I experienced could be eliminated by either turning off the audio services (inluding AudioEndpointBuilder) or the SuperFetch it occurs to me that there is likely some unknown conflict that  between these services as they are starting up (especially with dual CPUs). To further reduce this possibility I am now starting the SuperFetch service (Automatic, Delayed) instead of disabling it.

My I/O issue on this computer is now resolved.
0
 
jdwarrenAuthor Commented:
Thought it was resolved but it turns out that Superfetch when started (Automatic, Delayed) was delayed long enough to make me think everything was OK but excessive Disk I/O issue always will come back eventually.

Watching Task Manager I see that things are being cached into memory until all Free memory is entirely soaked up. The more memory you have ---> the longer it takes. In my case I have a total 2 GB of memory and it takes several minutes of hard drive activity to cache everything into the remaining 1.4 GB of free memory after starting up. A lot of new inexpensive computers with Vista are only configured with 1 GB of memory and in this case only about 0.4 GB of free memory  is available for caching and probably does not take as long  and goes mostly unnoticed by the user.

If you have lots of memory (2-4 GB) then disabling Superfetch will be only way to prevent excessive hard drive activity after startup. This therefore becomes a personal preference Vista Tweak.
0
 
Computer101Commented:
PAQed with points refunded (250)

Computer101
EE Admin
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now