• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 367
  • Last Modified:

Unable to manage/modify accounts in Windows Vista

I am currently working on a Brand New Acer laptop for  a client that came pre-installed with Windows Vista Home Premium. The client has requested that we do two relatively simple things 1)Install Microsoft Office from the CD he provided. 2)Change the username of his account.

We expected this to be a quick in/out process, thanks to Microsoft, we were wrong.

First, the CD drive wasn't registering in windows properly (though it worked fine outside of Windows). The technician found that the upper and lower filters for the drive and to be reinstalled inside Windows. Once that was done the CD drive seemed to function fine and the software was able to be installed.

Now, however when we go into "User Accounts" and click "Change Your Account Name" it takes us to a screen to type in the new account name (though it doesn't show the the user account's picture, it just shows a blank square above where the name is to be typed in). Once we type in the new account name and then click "Change Name" it takes us back to the "User Accounts" screen, with no change whatsoever on the user account. Furthermore, if we simply go into "Manage Another Account" and brings us to a screen titled "Choose an Account you'd like to change", which then has a completely empty list (no users WHATSOEVER are listed on this page). If we click the "Create a New Account" button on this screen and then try to add a new account, upon submitting the new account name and setting it to either an administrator or standard user (doesn't matter which we choose) we're taken right back to that blank list titled "Choose an Account you'd like to change".

The user account we're logged in as, to our knowledge, is the only user account on the computer and it is an "Administrator" (says so on the main "User Accounts" screen).

Two other interesting things to keep in mind:
1)At the User Accounts screen, several buttons have a little security shield next to them ("Change Your Account Name", "Change Your Account Type", "Manage Another Account", "Turn User Account Control On or Off"), and none of those items work. However, the first three items ("Change your Password","Remove Your Password", and "Change Your Picture") all seem to work fine (and none of those three have little shields by them).

I have no clue why this PC is doing this, but I have to say its pretty frustrating not to be able to do something a simple as create a new user.

To Quote ITWire "Vista: They took five years for this?"
0
gopcinc
Asked:
gopcinc
1 Solution
 
final4fever10Commented:
Sounds like you have your hands full with this PC.
I would try clicking on start and right-click on computer...

Then click on "manage". Under "System Tools" open up "Local Users and Groups".
There is a "User" folder. If you open this up all of your users should show up and if you right-click on any user you should be able to change the username.
If you right-click on the User folder you can add a user here as well!
Hopefully this works to resolve your user issue.
0
 
zephyr_hex (Megan)DeveloperCommented:
fyi
the "little shield thing" means that those items require Admin privs to modify.  by default, Vista does not run all processes in admin mode, even on an admin account.  this is a security feature.  when you want to run something that requires admin prives, you will get a prompt that says the requested action requires admin privs and the screen actually dims down...  once you click OK, the action is preformed and then you go back to non-admin mode.

so... it sounds to me like something is blocking that process
turn off all security software... spyware blockers, antivirus, windows defender ...  so you are sure those apps aren't interfering...

you can verify whether or not there are any other accounts by looking in C->Users.  all user profiles should be listed there.  be sure to enable the viewing of hidden folders.

have you tried booting into safe mode?  i haven't tried creating an account in vista in safe mode, but i don't see why it would be a disabled feature in safe mode.

finally...
if this is a new laptop and has these issues, have you considered flattening it out and doing a clean OS install?  if you do this, make sure you have all hardware drivers on-hand first (especially the NIC driver).
0
 
gopcincAuthor Commented:
I checked under c:\Users and found only the user account that already existed ("lynn"). This is a brand new laptop, so reloading may be an option, just was hoping for a quicker fix. I also noticed that there are A LOT of folders in the C:\Users directory that I normally see under a user's folder(I.E. Desktop, Contacts, Cookies). I am not extremely familiar with Windows Vista, so maybe this is normal, but I know that in Windows XP those folders normally only existed under the user's profile folder, not in the main "Users" folder (formerly Documents & Settings). Also, "Local Users and Groups" option, which is supposed to be under system tools is not present on this computer for some reason.

As far as the commands that require administrative priveleges, we do get a prompt confirming that we want to run them.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now