Importing a .pst into a public folder, I can see all the contents, other users only see "Deleted Items" folder.

Posted on 2007-08-10
Last Modified: 2013-11-05

Part of my terminated employee procedure is to take that employees mailbox and make it available as a public folder, for history sake of the current employees who need to look back to see when this user sent emails/etc.

What I have done is created a .pst file for each of the terminated users, containing everything (inbox, sent, deleted, personal folder, contacts, etc)  

I create a public folder on the Exchange server and assign it that person's name.  In Outlook, I highlight that person's folder, and use Outlook's Import and Export option.

Everything goes smoothly and I have no problems seeing that users mailbox and everything in it.  However, when other users are looking at the public folder, all they see is the "Deleted Items" folder.

What am I doing wrong?  Is it permissions based or maybe because the .pst's are on my computer (in a network shared folder).

Question by:ksteffke
    LVL 9

    Accepted Solution

    It will be a permissions issue.  Take a look at the groups/users that have access to the .pst file and also to the terminated users mailbox itself.  Chances are you may need to add permissions to either the .pst or mailbox for the Users or Domain Users security group.  Compare the security on the Deleted Items folder and the other folders to find your difference.
    LVL 18

    Assisted Solution

    I think this would be a permissions issue of the public folder.
    Since you exported the data to the public folder, the permissions issue is there, not locally where the data was exported from.

    Permission to a subfolder will not work unless all higher level folders have the correct permissions also.
    LVL 1

    Author Comment

    It did have to do with permissions, more precisely "Client Permissions" on each of the sub-folders.  Unfortunately the client permissions don't propagate down and I would have to set the client permissions for each sub-directory in the public folder.  I can't select multiple items and change the permissions within Exchange, so it looks like it is going to be a long and tedious process for each folder, unless you guys have further ideas?
    LVL 1

    Author Comment

    PFDAVAdmin did the trick of propagating permissions down each level, so adding users to the root folder, assigning the correct permissions (some were set to folder not visible), and then passing them down solved it.  

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    Suggested Solutions

    Granting full access permission allows users to access mailboxes present in their database. By giving full access permission one can open and read the content of any mailbox but cannot send emails from that mailbox.
    Create high volume marketing opportunities using email signatures with these top 10 DOs and DON'Ts of email signature marketing.
    This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now