Unable to scan to email large documents in Exchange 2007

Howdy,

I just did an upgrade of a SBS 2000 network with Exchange 2000 to Exchange 2007 and 2003 servers.  We have a 2003 Server that runs GFI MailEssentials which downloads our email using its POP3 connector.  Once downloaded it sends it to the Exchange 2007 server.  We have a network copier that we are having issues with scanning to email large documents (I believe around 10mb+) to user's email.  This obviously was not the case before.  I have checked the transport servers on Exchange and as far as I can tell I have set all to 250mb.  I also have increased user mailboxes and messages sizes. In Exchange all users have their internal email address and external address (external set as default).   Is there possibly something I am missing?  I am fairly new to Exchange 2007 so I am still learning.  

This is the output of my transport servers list:
Name                                    : RMD-EXCHANGE
AntispamAgentsEnabled                   : False
ConnectivityLogEnabled                  : False
ConnectivityLogMaxAge                   : 30.00:00:00
ConnectivityLogMaxDirectorySize         : 250MB
ConnectivityLogMaxFileSize              : 10MB
ConnectivityLogPath                     : E:\Program Files\Exchange 2007\Transp
                                          ortRoles\Logs\Connectivity
DelayNotificationTimeout                : 04:00:00
ExternalDelayDsnEnabled                 : True
ExternalDNSAdapterEnabled               : True
ExternalDNSAdapterGuid                  : 00000000-0000-0000-0000-000000000000
ExternalDNSProtocolOption               : Any
ExternalDNSServers                      : {}
ExternalIPAddress                       :
ExternalDsnDefaultLanguage              : en-US
ExternalDsnLanguageDetectionEnabled     : True
ExternalDsnMaxMessageAttachSize         : 250MB
ExternalDsnReportingAuthority           : rmd.local
ExternalDsnSendHtml                     : True
ExternalPostmasterAddress               :
InternalDelayDsnEnabled                 : True
InternalDNSAdapterEnabled               : False
InternalDNSAdapterGuid                  : 00000000-0000-0000-0000-000000000000
InternalDNSProtocolOption               : Any
InternalDNSServers                      : {172.19.0.4}
InternalDsnDefaultLanguage              : en-US
InternalDsnLanguageDetectionEnabled     : True
InternalDsnMaxMessageAttachSize         : 250MB
InternalDsnReportingAuthority           : rmd-exchange.rmd.local
InternalDsnSendHtml                     : True
MaxConcurrentMailboxDeliveries          : 7
MaxConcurrentMailboxSubmissions         : 20
MaxConnectionRatePerMinute              : 1200
MaxOutboundConnections                  : 1000
MaxPerDomainOutboundConnections         : 20
MessageExpirationTimeout                : 2.00:00:00
MessageRetryInterval                    : 00:01:00
MessageTrackingLogEnabled               : True
MessageTrackingLogMaxAge                : 30.00:00:00
MessageTrackingLogMaxDirectorySize      : 250MB
MessageTrackingLogMaxFileSize           : 10MB
MessageTrackingLogPath                  : E:\Program Files\Exchange 2007\Transp
                                          ortRoles\Logs\MessageTracking
MessageTrackingLogSubjectLoggingEnabled : True
OutboundConnectionFailureRetryInterval  : 00:10:00
IntraOrgConnectorProtocolLoggingLevel   : None
PickupDirectoryMaxHeaderSize            : 64KB
PickupDirectoryMaxMessagesPerMinute     : 100
PickupDirectoryMaxRecipientsPerMessage  : 100
PickupDirectoryPath                     : E:\Program Files\Exchange 2007\Transp
                                          ortRoles\Pickup
PipelineTracingEnabled                  : False
ContentConversionTracingEnabled         : False
PipelineTracingPath                     : E:\Program Files\Exchange 2007\Transp
                                          ortRoles\Logs\PipelineTracing
PipelineTracingSenderAddress            :
PoisonMessageDetectionEnabled           : True
PoisonThreshold                         : 2
QueueMaxIdleTime                        : 00:03:00
ReceiveProtocolLogMaxAge                : 30.00:00:00
ReceiveProtocolLogMaxDirectorySize      : 250MB
ReceiveProtocolLogMaxFileSize           : 10MB
ReceiveProtocolLogPath                  : E:\Program Files\Exchange 2007\Transp
                                          ortRoles\Logs\ProtocolLog\SmtpReceive
RecipientValidationCacheEnabled         : False
ReplayDirectoryPath                     : E:\Program Files\Exchange 2007\Transp
                                          ortRoles\Replay
RootDropDirectoryPath                   :
RoutingTableLogMaxAge                   : 7.00:00:00
RoutingTableLogMaxDirectorySize         : 50MB
RoutingTableLogPath                     : E:\Program Files\Exchange 2007\Transp
                                          ortRoles\Logs\Routing
SendProtocolLogMaxAge                   : 30.00:00:00
SendProtocolLogMaxDirectorySize         : 250MB
SendProtocolLogMaxFileSize              : 10MB
SendProtocolLogPath                     : E:\Program Files\Exchange 2007\Transp
                                          ortRoles\Logs\ProtocolLog\SmtpSend
TransientFailureRetryCount              : 6
TransientFailureRetryInterval           : 00:05:00
AntispamUpdatesEnabled                  : False
IsValid                                 : True
OriginatingServer                       : rmd-db.rmd.local
ExchangeVersion                         : 0.1 (8.0.535.0)
DistinguishedName                       : CN=RMD-EXCHANGE,CN=Servers,CN=Exchang
                                          e Administrative Group (FYDIBOHF23SPD
                                          LT),CN=Administrative Groups,CN=First
                                           Organization,CN=Microsoft Exchange,C
                                          N=Services,CN=Configuration,DC=rmd,DC
                                          =local
Identity                                : RMD-EXCHANGE
Guid                                    : 7a18ab48-2ccc-4b43-a247-1a5ce9b817a9
ObjectCategory                          : rmd.local/Configuration/Schema/ms-Exc
                                          h-Exchange-Server
ObjectClass                             : {top, server, msExchExchangeServer}
WhenChanged                             : 8/2/2007 4:43:47 PM
WhenCreated                             : 6/19/2007 3:10:42 PM

Thanks!
Alan
aiscomAsked:
Who is Participating?
 
Zenith63Connect With a Mentor Commented:
This seems to be a bit of an issue with Exchange 2007, I've come across it in some shape or form on every 2007 site I've setup.  The problem seems to be there are numerous places where you can set limits, and limits don't inherit or override as you'd expect.

This is what I wrote down before when trying to solve this exact problem you're having with an A0 scanner, it did work in the end.


Run
get-receiveconnector | select identity,maxmessagesize
to get the current maximum message sizes for each Receive Connector.

Then run for example
set-receiveconnector "Connector Name" -maxmessagesize 50MB

Also run
get-sendconnector | select identity,maxmessagesize
then the following to set it
Set-SendConnector "Default SMTP Connector" -maxmessagesize 100MB


You may also need to use something like the commands below to override the "unlimited" setting because the unlimited setting may get overridden by inheritance from something higher.  These commands set it to 100MB.
Set-TransportConfig -MaxSendSize 104857600
Set-TransportConfig -MaxReceiveSize 104857600

Unfortunately you may also alternatively need to do it at the mailbox level as well (I did in the case of the A0 scanner).  Use the following command to get the sizes for all mailboxes.
Get-Mailbox | select identity,maxsendsize
Get-Mailbox | select identity,maxreceivesize

Then use the following example to set the size to 100MB
Set-Mailbox -identity "username" -maxsendsize 104857600
Set-Mailbox -identity "username" -maxreceivesize 104857600
(replace username with the user's username and run for every user)



Hope that's of some use.  I'm keeping my fingers crossed for improved GUI control of these settings with SP1.
0
 
Zenith63Commented:
I guess this sorted it out for you?  Which commands did you have to use in the end?
0
 
aiscomAuthor Commented:
Yes, it worked out great.

I believe it was the get and send connectors I had to update if I remember correctly.

Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.