Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Problem with Token-Ring interface on Cisco 2612 Router -  Interface down, line protocol down.

Posted on 2007-08-10
7
Medium Priority
?
840 Views
Last Modified: 2012-08-13
I have a Cisco 2612 router which died, an IBM MAU which also died, and I got a used replacement of both.   The router was basically used to connect a token ring subnet w/ our AS/400 on it,  to our ethernet segment.    

The physical connectivity is:

AS/400(tokenring) ------ IBM MAU ------ (TR-port-> 2612 Router <--Eth0 port) ------ Ethernet segment

This set up used to work before the original router died.   Now I can't seem to get the Token-ring segment working.    My token ring interface  (TokenRing0/0) just sits on this status:
      TokenRing0/0 down, Line protocol down.  
If I connect the AS/400 to the MAU as well, then the status says :
     TokenRing0/0 reset, Line protocol down.  

Here is an output of my status right now, with only the Router connected to the MAU:

bal-int-router#show int TokenRing0/0
TokenRing0/0 is down, line protocol is down
  Hardware is HAWKEYE, address is 0050.edc1.6f84 (bia 0050.edc1.6f84)
  Internet address is 192.168.90.1/24
  MTU 4464 bytes, BW 16000 Kbit, DLY 630 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation SNAP, loopback not set
  Keepalive set (10 sec)
  ARP type: SNAP, ARP Timeout 04:00:00
  Ring speed: 16 Mbps
  Duplex: half
  Mode: Classic token ring station
  Full duplex capable
  Ethernet Transit OUI: 0x000000
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 17 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 transitions
bal-int-router#



I have absolutely no idea how to make the device be UP, UP....    



Here is my running config:

bal-int-router#show running
Building configuration...

Current configuration : 855 bytes
!
version 12.2
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname bal-int-router
!
logging queue-limit 100
enable secret --- ----
enable password --------
!
memory-size iomem 10
ip subnet-zero
!
!
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Tunnel0
 no ip address
!
interface Ethernet0/0
 ip address 192.168.1.3 255.255.255.0
 half-duplex
 no cdp enable
!
interface TokenRing0/0
 ip address 192.168.90.1 255.255.255.0
 ring-speed 16
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
snmp-server community blkro! RO
snmp-server enable traps tty
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password gotham100
 login
!
end

bal-int-router#


Any help is greatly appreciated...



0
Comment
Question by:xenetar
  • 4
  • 3
7 Comments
 
LVL 11

Accepted Solution

by:
grsteed earned 2000 total points
ID: 19676011
I don't know much about Token Ring but this article has some good information.

http://www.cisco.com/en/US/products/hw/modules/ps2643/products_tech_note09186a0080093dc2.shtml

Usually down/down indicates that isn't receive the proper signals in the interface. If the line doesn't com up, the protocol will never come up.

Does the MAU have link indicators on it? Also do you see anything in the logs when you try to bring it up??

On the cisco do a

conf t
int  TokenRing0/0
shut
no shut
<cntl>Z  (exit)

and then do a

sh log

See if this tells you anything.

Cheers,
Gary
0
 
LVL 1

Author Comment

by:xenetar
ID: 19679067
I did as you suggested but it doesn't really show me the log, just a summary of logs...:

The old mau had link lights.. this one does not...  :(


bal-int-router#sh log
Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes
 0 overruns)
    Console logging: level debugging, 15 messages logged
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: disabled
    Logging Exception size (4096 bytes)
    Trap logging: level informational, 18 message lines logged
bal-int-router#



Also, can I just have this router connected to the MAU and nothing else and still get a link-state of up or do you need two systems to establish a ring?

0
 
LVL 11

Expert Comment

by:grsteed
ID: 19679543
The reason you aren't seeing any thing else in the log is because of this line.

Buffer logging: disabled

Go into "conf t" and enter "logging buffered" to turn that on.

This link suggests that the MAU may be a problem.
http://www.cisco.com/univercd/cc/td/doc/cisintwk/itg_v1/tr1906.htm#wp1020648

It does mention that the MAU may need to be initialized.  

Cheers,
Gary
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 1

Author Comment

by:xenetar
ID: 19680332
Thanks for the log hint...  The TR media link is excellent...  I'll be checking out that stuff for sure.    meanwhile here is the log output:

bal-int-router#sh log
Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes,
 0 overruns)
    Console logging: level debugging, 1185 messages logged
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 3 messages logged
    Logging Exception size (4096 bytes)
    Trap logging: level informational, 1188 message lines logged

Log Buffer (4096 bytes):

1d09h: %LINK-5-CHANGED: Interface TokenRing0/0, changed state to administrativel
y down
1d09h: %LINK-5-CHANGED: Interface TokenRing0/0, changed state to initializing
1d09h: %SYS-5-CONFIG_I: Configured from console by vty0 (192.168.1.108)
1d09h: %TR-3-OPENFAIL: Unit 0, open failed: registration, function failure
1d09h: %LINK-3-UPDOWN: Interface TokenRing0/0, changed state to down
bal-int-router#
0
 
LVL 1

Author Comment

by:xenetar
ID: 19680379
After switching the interface back to half-duplex, doing a shut, a clear interface tokenring0/0 and then doing a no-shut, i'm now getting a lobe-test error... thats better, at least i'm getting somewhere now....

1d10h: %LINK-3-UPDOWN: Interface TokenRing0/0, changed state to down
1d10h: %LINK-5-CHANGED: Interface TokenRing0/0, changed state to administrativel
y down
1d10h: %SYS-5-CONFIG_I: Configured from console by vty0 (192.168.1.108)
1d10h: %SYS-5-CONFIG_I: Configured from console by vty0 (192.168.1.108)
1d10h: %LINK-5-CHANGED: Interface TokenRing0/0, changed state to initializing
1d10h: %TR-3-OPENFAIL: Unit 0, open failed: lobe media test, function failure
1d10h: %LINK-3-UPDOWN: Interface TokenRing0/0, changed state to down
bal-int-router#

Perhaps I shall try another cable/rj-45 adapter block to see if that helps?  
0
 
LVL 1

Author Comment

by:xenetar
ID: 19685494
Its working!  

I switched back to the old mau, with another connector, and using some of the commands in that link, I was able to get it insert into the ring and go UP, UP..  

Excellent.  Thank you for your efforts, GRSTEED....
0
 
LVL 11

Expert Comment

by:grsteed
ID: 19686705
Great!!  Glad to hear!!!

Gary
0

Featured Post

Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question