OWA - Bad Request (Invalid Hostname) / Owaauth.dll

Hello All, I have the following problem with one of my exchange 2k3 SP2 front end servers.

This new FE, owa-ex01, server can talk to every single server except for one BE, prob-ex01, (of course the only one I really need it to connect to.)  Set for SSL Cert (owa.domain.com) and Form Auth.

My main FE, webmail-ex01, server is running fine.  It will connect to every single BE server, even the above "problem" one.  Set for SSL Cert (webmail.domain.com) and Form Auth.

The new FE server has been added in to support our (uhhhgggg Entourage Mac clients)  The FE server is local to them so that they do not need to traverse wan to find the main FE server.

When I try and access any account on this specific server, prob-ex01, FROM the new FE server, owa-ex01, I get the following errors:
IE - Address Bar: https://owa.domain.com/exchweb/bin/auth/owaauth.dll
Page Cannot be found  HTTP 400 - Bad Request

Firefox or IE with friendly Errors off - Bad Request (Invalid Hostname)

I've tried going though and reseting directory permissions
Deleteing and having the 6 IIS directories recreated
Made sure the IUSR_ and IWAM_ accounts have proper passwords

All servers are running MS Server 2003 SP1 and Exchange 2003 Sp2.
LVL 1
CrazyStandAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
Invalid hostname normally means a bad host header.
If you are using SSL then you cannot use host headers. If you have configured host headers then remove them. Make sure that you have done that on both the backend and the frontend server.

Make sure that any SSL certificate and any setting for require SSL has been removed from the backend server. All SSL type activities should be done by the frontend server only.

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CrazyStandAuthor Commented:
Spot on!  Thank you so much.  3 Clicks and I'm back up and running.

SSL has be configured on the Backend.
Host headers had been set on the FE and BE server.

That was killing me!  500 points to you.
lseemanCommented:
I have the same issue, but it works internally and NOT externally using the same FQDN....?
SembeeCommented:
lseeman - this is an old question. Unlike a forum it is not possible to "bump" questions back up the list. The only people who will see your post are those that have already participated. Instead you should post your question as a new question in the Exchange Server Zone which will allow other experts the chance to see the question and respond.

Simon
Exchange Server Zone Advisor.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.