?
Solved

Remove configure your server wizard when users log onto terminal server

Posted on 2007-08-10
14
Medium Priority
?
1,410 Views
Last Modified: 2013-11-21
When my users log into my terminal server (2003 R2) they are getting the configure your server wizard.  Now I know they can click dont show this at startup but how can I disable this except for administrators?
0
Comment
Question by:ryansoto
14 Comments
 
LVL 70

Expert Comment

by:KCTS
ID: 19674186
You should create a profile which does not include the wizard and copy it to the default profile.

Set up a dummy user account, log on using this account and set up the desktop, menus shortcuts, screen savers, map drives etc and all the other stuff that you want to standardize for new users. When all is to your liking, log off from the dummy account.. You can then copy the profile you have just created so that it becomes the default for all new users. To do this you need to log on as an administrator, You will first need to go to the Control Panel, and in Administrative tools, Folder Options, on the View Option make sure that the option to Show Hidden Files and Folders is selected. It is also a good idea to make sure that the Hide Extensions for known file types is NOT selected so you can identify files more easily later on. Then exit the control panel. Right click on My Computer and select Properties, Advanced, and click on SETTINGS under User profiles. Select the dummy profile and then COPY TO another user option. Copy the dummy profile to C:\Documents and Settings\Default User making sure that you change the 'Permitted to use' option to 'Everyone' so that the new users will have the necessary permissions on the profile. Confirm the action replacing the existing default profile when prompted.
0
 
LVL 4

Expert Comment

by:starmonkey
ID: 19674312
On my terminal server only administrators see this window at startup.
I'd make sure your TS users aren't administrators, or I fear for the health of your TS
0
 
LVL 24

Author Comment

by:ryansoto
ID: 19674316
I made sure they arent admins and this is a new server (about 3 months old)
Server runs great just this pop up.  
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 4

Expert Comment

by:starmonkey
ID: 19674323
I think there is a GPO,
give me a sec...
0
 
LVL 4

Accepted Solution

by:
starmonkey earned 2000 total points
ID: 19674336
I thnk I foundit:
navigate the the ou containing the TSs and create or edit a GPO here.

There is a GPO at computer config, admin templates, system, do not display manage your server at login
0
 
LVL 24

Author Comment

by:ryansoto
ID: 19696178
OK maybe this is my overall issue -
My users are in a group called Local Admin
It is a global security group and is a member of no other groups.
Is this why they are getting the config server page?  I know I remove this window with the GPO starmonkey provided but an overall why is this happening is what I am looking for.
0
 
LVL 24

Author Comment

by:ryansoto
ID: 19696206
Update - I enable this GPO stated by starmonkey and it does not pop up the window to confi your server.
Now if I remove a user from this local admin account they can not log into terminal server.  It says the user may not be a part of the remote desktop group....They are in that group.
My assumption is there is another GPO telling the system to allow members of the local admin group to log in.  Any thoughts?
0
 
LVL 24

Author Comment

by:ryansoto
ID: 19696238
Update - The 'local admin' group is a member of the administrators group on that terminal server (local group)

I guess the question now is how can I get these users out of the local admin group locally on my terminal server but not hinder their ability to work?

0
 
LVL 2

Expert Comment

by:mlnetcor
ID: 19704835
Make the user part of the local Remote Desktop Users Group.  You may have to give them more permissions but most of the time that is sufficient.
0
 
LVL 24

Author Comment

by:ryansoto
ID: 19708430
All the users are part of the remote desktop group but the remote desktop group is not a part of the local admin group on that terminal server.  
So when I make that change people are not able to log into the TS
0
 
LVL 4

Expert Comment

by:starmonkey
ID: 19756111
Thanks for the points!

I took a different approach:  open the terminal services configuration\connections as admin from cont pan
go to connections in left pane, right click RDP-Tcp in right pane, go to properties
go to permissions tab, you can add and AD group and assign whatever different grou ppermissions you need here.

I added "domina users" and assigned User and guest access permissions
0
 
LVL 24

Author Comment

by:ryansoto
ID: 19756123
So doing it that way only show it to the user groups specified?
0
 
LVL 24

Author Comment

by:ryansoto
ID: 19756280
OK I did as you did and added the needed group to the rdp permissions and they can log in as nothing different happened!  I removed that remote group from the local admin group and they could still log in, perfect!!!!!!!  Thank you, what a great help.
0
 
LVL 24

Author Comment

by:ryansoto
ID: 19756558
When I remove the 'remote users groups' from the local admin group on the TS they are not able to save items to their desktop or in their 'my docs' folder.....
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
Sometimes a user will call me frantically, explaining that something has gone wrong and they have tried everything (read - they have messed it up more and now need someone to clean up) and it still does no good, can I help them?!  Usually the standa…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.
Suggested Courses

750 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question