Visual Studio 2003 Debugging on Windows server 2003 64bit question

I need some help with an issue we are having with a new server we purchased, and with its new software installed.

the setup is the following:

Dell Server (web server)
Windows server 2003 standard 64bit
ASP.NET 1.1
Remote debugging software is installed from the visual studio 2003 discs.

Workstation
XP SP2 32 bit
Visual studio 2003

Requirements
I want to be able to create and debug web applications on the webserver.

Problem
I can create websites fine, i can compile them with no issues either.
I cant debug them on the server. i receive the following error when i try and debug
message:
---------------------------
Microsoft Development Environment
---------------------------
Error while trying to run project: Unable to start debugging on the web
server. Not implemented

Click Help for more information.
---------------------------
OK Help
---------------------------

there are no other messages in windows event log either.

There is this message in the webserver logs though :
2007-08-09 23:55:39 W3SVC1 10.10.20.231 DEBUG /test/WebForm1.aspx - 80 -
10.10.20.194 Microsoft-Visual-Studio.NET/7.10.3077 401 5 0
2007-08-09 23:55:40 W3SVC1 10.10.20.231 DEBUG /test/WebForm1.aspx - 80
mydomain\darren 10.10.20.194 Microsoft-Visual-Studio.NET/7.10.3077 500 0 0
2007-08-09 23:55:40 W3SVC1 10.10.20.231 DEBUG /test/WebForm1.aspx - 80
mydomain\darren 10.10.20.194 Microsoft-Visual-Studio.NET/7.10.3077 500 0 0


Can anyone help me out? Could this be a issue with 32bit v 64bit?
oneworkingdazAsked:
Who is Participating?
 
hongjunConnect With a Mentor Commented:
I correct myself.
There shouldnt have a problem with configuration manager for asp.net.
Perhaps you may wish to install 32 bit.
0
 
hongjunCommented:
0
 
oneworkingdazAuthor Commented:
thank you for the quick response,  however the error i receive is not listed on that page.

other notes though about my installation.,
* front page extensions are installed
* the user is in the administrators and the debuggers group
* iis6 is running under the aspnet user account and setup in the machine.config
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
hongjunCommented:
Find machine.config file and then change the username to the one you are using.

<processModel enable="true" timeout="Infinite" idleTimeout="Infinite" shutdownTimeout="0:00:05" requestLimit="Infinite" requestQueueLimit="5000" restartQueueLimit="10" memoryLimit="60" webGarden="false" cpuMask="0xffffffff" userName="DOMAIN\USER" password="PASSSWORD" logLevel="Errors" clientConnectedCheck="0:00:05" comAuthenticationLevel="Connect" comImpersonationLevel="Impersonate" responseRestartDeadlockInterval="00:09:00" responseDeadlockInterval="00:03:00" maxWorkerThreads="25" maxIoThreads="25"/>


hongjun
0
 
hongjunCommented:
If not, you can try reinstalling asp.net by running below in Visual Sutdio Command Prompt
    aspnet_regiis -i
0
 
hongjunCommented:
Check in IIS if your virtual folder is configured to run NET 1.1...it may be set for 2.0.

hongjun
0
 
oneworkingdazAuthor Commented:

I have changed the processModel and no change.
I have run  aspnet_regiis -i  and no change
I have also checked make sure it is confirugred to run 1.1 and not 2.0, ( there is no option for 2 btw) so i take it it is setup for 1.1..

Could it be a issue with .net 1.1 running on 32bit and windows being 64 bit? as to get everything installed was a real pain because al the web doco is written for windows server 2003 32bit and not 64 bit
0
 
oneworkingdazAuthor Commented:
I do have 32 bit version as well with our subscription, so wondering should i just restart the installation but use windows server 2003 32 bit.

???
0
 
hongjunCommented:
Should you have installed 64bit, you can actually still choose to run your .net in 32 bit. In Configuration manager, choose x86 instead of x64/Any CPU.

hongjun
0
 
hongjunCommented:
If all fails, try installing 32 bit
0
 
oneworkingdazAuthor Commented:
I will wait to try a few more things... then go to 32bit
0
 
oneworkingdazAuthor Commented:
this is silly now..
I have resinstalled with 32 bit and the SAME ERROR!!!!!
0
 
oneworkingdazAuthor Commented:
Worked it out...
the issue was caused by running the windows security configuration wizard.

as soon as i rolledback the changes it worked
0
 
hongjunConnect With a Mentor Commented:
Great you got it sorted out.
You can choose to close this question either by accepting a comment here or request for a PAQ and refund of points.

hongjun
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.