Trouble extracting large downloaded files, especially Data2.Cab

Posted on 2007-08-11
Last Modified: 2013-12-01
This is a strange issue but maybe somebody has some advice.  My friend constantly has issues on his Windows XP SP2 machine with extracting large downloaded demos / betas etc of games.  They always seem to fail on files though!  He has tried reformatting etc but it never seems to help.  I'm wondering if there is something corrupted on his XP CD related to Zip extraction.  

Does anyone have any suggestions on possible troubleshooting or ways to fix this?  We've tried having him download the files from several different websites (Fileplanet, Gamespot, IGN etc) but either way he gets it it does the same thing which means it really shouldn't be his network connection corrupting it somehow - and why always in the same spot on the file?

He has also tried different internet connections, even downloading it from work, burning to DVD then bringing home to his machine to extract and it still fails.

Do you think installing a product like WinZIP 11 will help replace the corrupted ZIp extraction or has anyone else heard of other solutions to this issue?

Question by:ironwill96
    LVL 62

    Expert Comment

    by:☠ MASQ ☠
    Depends what you are trying to extract.  That would probalby help us direct you better.

    The extension  .cab is just a file suffix.  It doesn't mean the file has been compressed using the Microsfot Cabinet File standard.

    There are a couple of large game files where the file is deliberataley encrypted as part of the copy protection.
    LVL 2

    Author Comment

    It is for example World in Conflict Beta, Neverwinter Nights 2 Patching etc.. Happens with lots of different games.  I'm just trying to figure out why his computer has lots of issues with this stuff, yet mine does not?

    LVL 2

    Author Comment

    He does have Nforce motherboard, but the Nvidia Network Manager isn't installed so none of that crappy HW firewall so many report issues with.
    LVL 62

    Accepted Solution

    Could be his download that is corrupt rather than an inability to decompress.  What connection type does he have?

    To test, you both download the same files and then decompress them.  If it's the downloading process at fault then yours will unpack on both machines but your friend's won't work on either.

    Can be related to drive errors and RAM problems as well.  If his PC is OK then he needs to check with his ISP or look at a download manager.
    LVL 2

    Author Comment

    We finally got it working by decompressing using WinRAR with "keep broken files" checked.  The patcher for the game then seemed to fix whatever corruption there was.  Your suggestions are good though and we will try those out.  We have replaced the drive in an attempt to fix it before as well and that didn't seem to help.  I suspect it is the ram or the motherboard somehow involved.


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Article by: Rob
    Notes 8.5 Archiving Steps and Tips This article covers setting up a Notes archive, and helps understand some of the menu choices making setting up and maintaining a Notes archive file easier.
    I previously wrote an article addressing the use of UBCD4WIN and SARDU. All are great, but I have always been an advocate of SARDU. Recently it was suggested that I go back and take a look at Easy2Boot in comparison.
    The viewer will learn common shortcuts with easy ways to remember them. The viewer will then learn where to find all of the keyboard shortcuts, how to create/change them, and how to speed up their workflow.
    An overview on how to enroll an hourly employee into the employee database and how to give them access into the clock in terminal.

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now