Internet Connection Sharing Port Forwarding Issues

Posted on 2007-08-11
Last Modified: 2008-01-13
I have two computers, a Windows XP laptop with a verizon wireless card and a web server. I am trying to configure the laptop to run internet connection sharing and forward all requests from the internet on port 80 over to the webserver system.

Of course when I enable Internet Connection Sharing it tells me that it will have to change the IP address of the local network adapter to, which is fine considering the webserver is

However, whenever I attempt to access the public IP address I'm given by verizon it never seems to forward over to the web server.

I just installed Apache on the laptop to see if its not forwarding or if there is a problem with the page and with Apache installed on the laptop, the laptop's website comes up fine, even though I have Internet Connection sharing configured to forward all requests on port 80 over to

I know that the web server is running fine and is accessable on the web-server because I can access it via its local IP address ( It comes up immediately without an issue that way. There is NO access control, no firewall, no NOTHING on the webserver except a simple webserver (

Please HELP! I am onsite trying to set this up for someone, just like I have done half a dozen times. I've done the same thing with virtually the same steps (without any third party software) on about 5 or 6 other laptops and it worked previously. I don't know if I am skipping something or missing something or if there is something wrong with the system.

The Steps I am going through are:

1. Right click my Dial-Up Internet Connection, go to Properties.
2. Click Advanced at the top, put a check mark by "Allow other network users to connect through this computer's internet connection".
3. By Home Networking Connection I set it to "Local Area Connection" (the ethernet cable between my laptop and the server).
4. Also, for good measure I put a check mark by the two checkboxes after that (Establish dial-up connection..., Allow other network users...).
5. Click "Settings" in the bottom right corner,  Double-click "Web Server (HTTP)" in the list and set it to (IP Address of my server)
6. Click "Ok".
7. Click "Ok".
8. Click "Settings" in the top right corner of the screen by "Windows Firewall".
9. Set Windows Firewall to "On". UNCHECKED "Don't allow exceptions".
10. Clicked the "Exceptions" tab at the top of the window.
11. Click "Add Port", typed a generic name (i.e. "web" by name and typed 80 by Port Number).
12.  Put a checkmark by "TCP".
13. Click "Ok".
14. Click "Ok".
15. Click "Settings" in the top right corner of the screen by "Windows Firewall" again.
16. Click "Advanced" , under network connections scroll down and find "Local Area Connection". Highlight it and click "Settings".
17. Ensure that a port setting is setup for this connection for port 80 to forward to (Just like steps 11-13. Click Ok.
18. Scroll down in the network connections list and highlight "NationalAccess - BroadbandAccess" (My Internet Connection). Click Settings.
19. Ensure that a port is setup for this connection as well for port 80 to forward to (One again, just like steps 11-13). Click Ok.
20. Click "Ok".
21. Disconnected & Reconnected Dial-Up Connection.

If anyone has any ideas, please let me know :(
Question by:gopcinc
    LVL 7

    Expert Comment

    Turn OFF the Venturi Client.   In fact, removing it completely is often a good idea.  It's a compression and proxy server program - in other words, a 'Web Accelerator"

    That may be interfering with the routing ability.  

    I know I have set it up with my laptop before, but I keep Venturi client gone, since I have to use SSH, telnet, ftp, and a number of other protocols that aren't compatible with it.

    Once you've done that, try the connection again and post back.
    LVL 51

    Expert Comment

    I'm not a "Internet Connection Sharing" expert, but I assume that it works the other way around only, means you can share the connecton *from* your web server to the internet, but not from the internet *to* your web server.
    You need a router with NAT for that.
    If you use apache on your laptop with internet connection, then you either nee mod_proxy or mod_rewrite configured *and* your network settings need to be proper (routing, forwarding, etc.).
    Keep in mind that on the web server you need to listen on every Host: header, otherwise you need to configure mod_rewrite too to rewrite the HTTP header.
    LVL 7

    Expert Comment

    ah - ahoffmann is right.  Generally, port forwarding internally is iffy on windows systems.

    However- I'll stick to my last, and say that the Venturi client could be an issue - almost certainly is, as a matter of fact.  You'll find that if you get rid of it, you all of a sudden get a totally different IP address set.


    Author Comment

    There was no venturi client installed on the system. After further review, it looks like the previous system administrator had a hidden firewall buried in the system that was blocking my port forwarding. The issue has now been resolved.
    LVL 1

    Accepted Solution

    PAQed with points refunded (500)

    EE Admin

    Featured Post

    Better Security Awareness With Threat Intelligence

    See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

    Join & Write a Comment

    This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
    If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
    Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now