Failed to Query TCP/IP Settings of the Connection - tried every step I could find

Posted on 2007-08-11
Last Modified: 2010-05-18
Windows 2003 SBS network with 3 Win XP clients. Symantec AV v10 deployed to all clients. (the other two clients are perfectly fine btw). Server acting as router via two NICs, DSL modem going in/out of NIC 1 and NIC 2 going in/out to a Netgear gigabit switch.
One of the clients fails to connect to the network. This computer has two NICs also, one 10/100 and one PCI gigabit.

What Ive done:

Switched out patch cable trying both NICs and same problem.
No IP address/DNS/gateway etc. (not even Tried to repair the connection and getting Failed to Query TCP/IP Settings of the Connection.
Tried to manually renew via ipconfig and get this:
Windows IP Configuration
An Internal error occured: The request is not supported.
Please contact Microsoft Product Support Services for further help.
Additional information: Unable to query host name.

Thinking it may be Symantec, I uninstalled the client. No change. Researched and researched& performed the Winsockfix.exe and nothing changed. Booted into safe mode, deleted the Winsock and Winsock2 registry keys, rebooted and no change.

I tried reinstalling the TCP/IP protocol via C:\windows\inf and again, no change. I modified the nettcpip.inf file to allow to actually uninstall and did so. Reinstalled TCP/IP and no change.

Anybody have any other ideas other than reinstalling the OS?

Sorry, hope this makes sense as I'm writing this WAY too quickly. Thanks!
Question by:gallagherdesign
    LVL 77

    Expert Comment

    by:Rob Williams
    Have you tried disabling one network adapter? SBS will not allow you to join the domain with 2 enabled, however you should get an address. You can enable the second after joining the domain.

    I would disable one adapter, and then run at a command line, on the problematic machine:
      netsh  int  ip  reset  c:\reset.txt
    to reset the TCP/IP stack.

    Also, you say you changed the patch cable, but is the patch cable connected directly to the switch? If not, try bypassing all wiring with new. #1 cause of network failures is bad wiring.
    LVL 38

    Expert Comment

    by:Philip Elder
    Make sure that your static IPs are still bound to the internal NIC. If not, set them and verify that they are now there via IPConfig at the command prompt.

    Rerun the CEICW to reset the IP settings for both NICs.

    Make sure the drivers are set and the Device Manager has both NICs listed and OK.


    Author Comment


    Here's what that pages says, and what solved it:

    I just managed to fix this identical problem on a clients computer. What is causing it is the TCPIP.SYS file in C:\windows\system32\drivers is a fake that is nailed into place by some jiggering of the FAT database or something in the NTFS low level format. This forum and others helped me get past the blind alleys, so I'm returning the favor.

    To fix the problem, you have to replace TCPIP.SYS with a good copy. Reinstalling Windows will not allow you to replace it. Starting in Safe Mode Command Prompt won't give you the ability to rename or delete TCPIP.SYS. Starting Windows from the CD and using the Repair Console will also fail unless you follow this set of steps.

    1. Get a copy of TCPIP.SYS by searching "TCPIP.SYS" on your machine, looking in hidden files and folders. You'll get a bunch of hits. Right click the files and check the preferences to get the most recent version that has Revision data from Microsoft. The one in C:\windows\system32\drivers is not gonna have any file data associated with it, even though it is exactly the same size as the good file.

    2. Put the copy of TCPIP.SYS on the root of your C: drive. I had a problem when I made a folder for it, so I recommend just copying it directly to root.

    3. Restart your computer with a Windows XP CD (WIN2000 would also work, I think) and select the Repair console function. Log in as Administrator (better know your administrator password!).

    4.Navigate to C:\windows\system32\drivers. You will be able to see the TCPIP.SYS file there is you type in DIR, but you won't be able to delete or rename it.

    5. Type in "CHKDSK /P". This runs a disk check on your hard drive and fixes errors whether the System thinks you need it or not.

    6. Type "del TCPIP.SYS" and press Return.

    7. Type in "CHKDSK /P" and run the disk check again (yes, I tried to do do this without this step the first time and it didn't work).

    8. Type in "copy C:\TCPIP.SYS". You should get a message that this completed correctly.

    9. Type in "CHKDSK /P" one last time just to be sure (I didn't confirm that this was required, but why waste all the previous effort?)

    10. Type in "Exit" and let the computer restart. Your internet access should be restored, the Windows Firewall will work, and ipconfig should be able to config IP.

    Hope this helps. I spent two days chasing down this rotten bastich myself. Still don't know what caused it, since it was a client's computer, but I've seen it once or twice in the last three years. I'm thrilled that I finally found out how to fix it without reformatting the computer.

    -Worked like a charm
    LVL 77

    Expert Comment

    by:Rob Williams
    Good to hear gallagherdesign, and thank you for posting your findings.
    Surprised though that you had to "jump through all of those hoops" to do so. I wonder why you had such difficulty deleting or re-naming the file. Windows will try to automatically repair or replace the file if deleted, but with the repair console you can usually delete it.

    TCPIP.SYS has been added and changed a few times since XP SP2. Apparently some feel it limits internet performance and as a result there are lots of "tweaks" out there for it. I wonder if it had been tweaked which might have damaged it, and/or made it difficult to remove.
    Also, it is possible chkdsk repaired sectors with corrupt system files.
    Regardless good to hear it now works, just searching for why, always helps to know.

    LVL 1

    Accepted Solution

    PAQed with points refunded (250)

    EE Admin

    Expert Comment

    Brilliant ! - Easy fix, thanks.
    I was simply able to RENAME the tcpip.sys, and then copy one from another working XPP (also SP3) that I had previously put in the root of C:
    No need for chkdsk.
    For the record:
    My TCPv5 got screwed up by installing various different versions of Intel/HP/Compaq driver utilities to try and get the onboard network card going (when I think the v5 was missing or corrupt all along.)
    What tipped me off was adding a second nic, and seeing the same issue, TCPIP v6 was present but v5 had vanished!
    It HAD been working, but various Windows updates and using MS Security Essentials some how got it corrupted.
    That being said, I had done a parallel install of XP, due to an unbootable system. An old Evo 510SFF machine now happy again.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    Please see preceding article here: Figure 1 After Root Bridge has been elected, then what?..... Let's start by defining a Root Port in la…
    We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now