listener status not running in oracle 10g

Hi, I'm checking the listener status in Oracle 10g and it' saying no listener is running

$ srvctl status nodeapps -n addtrw
VIP is not running on node: addtrw
GSD is not running on node: addtrw
No listener is running on node: addtrw
ONS daemon is not running on node: addtrw
[oracle@addtrw.tt.my.com /home/oracle]
$

But when I check using lsnrctl I can see the status is up.. so which status should I refer to here?


LSNRCTL> status
Connecting to (ADDRESS=(PROTOCOL=tcp)(PORT=1521))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for Linux: Version 10.1.0.5.0 - Production
Start Date                11-AUG-2007 19:33:22
Uptime                    0 days 0 hr. 6 min. 24 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Listener Parameter File   /u01/app/oracle/product/10.1.0/db_1/network/admin/listener.ora
Listener Log File         /u01/app/oracle/product/10.1.0/db_1/network/log/listener.log
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=addtrw.tt.my.com)(PORT=1521)))
The listener supports no services
The command completed successfully
LSNRCTL>
motioneyeAsked:
Who is Participating?
 
anand_2000vCommented:
are you using ASM  ( in that case the LISTENERS Will be created with hostname )
Check,
Status LISTENER_NODENAME

ex :

status LISTENER_CRMDB01  - Local listener node 1 -- Check Parameter local_listener - node 1
and  
 LISTENERS_CRMDB            - Remote listener common for both the nodes - Check parameter remote_listener

Its seems like your vip process are not running,
YOu have to start it like

srvctl start nodeapps -n nodename (both the nodes )

the go to $ORA_CRS_HOME/bin
you will find crs_stat executable.

Execute crs_stat -t  you will be able to find the status of all the CRS deamoms and vip
0
 
TolomirAdministratorCommented:
Isn't that rather a RAC?

Using srvctl to Manage your 10g RAC Database
http://orafaq.com/node/70

Seems to me like you RAC database is not started.

---

Or do you have just a normal database (w/o RAC) and used the tool srvctl to check?

Still, the listener status is too short I'm missing the database(s) entries here.

have you tried:

sqlplus> startup;

is the ORACLE_SID propery set?
 

Tolomir
0
 
anand_2000vCommented:
I think that tolomir has correctly identified that your db is not up or is not registered with the listener.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.