• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5336
  • Last Modified:

SBS 2003 Remote Web Workplace - Certificate Warning

Hi. I have a user who connects to our SBS 2003 using Remote Web Workplace. However when he connects he get the following warning message:-

There is a problem with this website's security certificate.
The security certificate presented by this website was issued for a different website's address.
Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server. We recommend that you close this webpage and do not continue to this website.

If he clicks on continue he can proceed and view his email, send emails, etc. How do I get rid of this message? Should I be doing something with certificates to make this procedure more secure.
Thanks...Jim
0
jimmycan
Asked:
jimmycan
  • 2
  • 2
1 Solution
 
jason-millerCommented:
Hi Jim,

Have the user add the certificate to their certificate store, and the warning should go away.

Click on Continue to go to the RWW site.
In the top navigation page of IE 7, click on the certificate error, and choose View Certificate.
Press Install Certificate.
At the Certificate Import wizard, press next.
Allow the wizard to place the cert automatically, press next.
Press Finish.
Acknowledge the certificate and authorize installation after reviewing to ensure this is the cert from your SBS, and press Yes.
You'll get notified that installation was successful.  Press OK.
Press OK at the View Certificate window to return to your RWW page.

Revisit the site to check that you're no longer prompted with a certificate warning.

Hope that helps,

Jason
0
 
jimmycanAuthor Commented:
Thanks Jason.

I tried that but I am still getting the warning message.

I also tried the option of copying it to a file and importing into IE7 - Internet Options - Content - Certificates - Advanced - Import. The import works and the certificate appears as mail.mydomain.com within trusted root certification authorities, issued by mail.mydomain.com  and with an expiration date of 06/09/2011 etc, but it still gives the warning when I log intp RWW.

I also tried it on a second remote PC and the same thing happens.
0
 
jason-millerCommented:
Does the published URL that your user is browsing to match with the Certificate URL?
Is this a self-signed certificate created with the SBS Configure Email and Internet Connection Wizard?

For example. if the certificate was created for 'server.company.com' and the URL you are visiting is 'https://mail.company.com', you'll see an error (as the two aren't the same).  

It may also help to re-run the Certificate import wizard by putting the cert into the Trusted Root Certification Authorities folder.  (http://blogs.technet.com/sbs/archive/2007/04/10/installing-a-self-signed-certificate-as-a-trusted-root-ca-in-windows-vista.aspx)

Cheers,

Jason
0
 
jimmycanAuthor Commented:
Hi Jason. Yes. That worked. Putting https://mail.mydomain.com worked propertly. Thankyou very much for all your time and effort...Jim
0
 
commwiseCommented:
I made the mistake of letting the wizard pick the store location automatically instead of selecting "Trusted Root Certification Authorities".  Once I did that no more warnings came up for that site.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now