• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3937
  • Last Modified:

SBS2003 & Vista - Roaming Profiles

Hi All,

I'm having some trouble thats getting a little frustrating now.

I have a brand new network running SBS 2003, with 2 Windows Vista Ultimate workstations.
On the server, I have created a share C:\Profiles\ and within active directory set the profile path to \\server\profiles\%username%

First I tried to login as a user, but got an error message (see below). I went back to the server, and saw it haddn't created the profile folder, so manually created it. I gave the folder additional security permissions (User = Full Control, System = Full Control).

Now even with the folder created, I still get the following error message when logging in:

Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile.
Changes to the profile will not be copied to the server when you log off.
This error may be caused by network problems or insufficient security rights.

DETAIL - Access is denied.

But I can't understand why - I've given it all the permissions it needs, or at least think I have.

Does anyone have any ideas? Many Thanks,

Pete
0
PeterHing
Asked:
PeterHing
  • 3
  • 2
  • 2
  • +2
2 Solutions
 
turbo12Commented:
FIRST, concerning Small Business Server, there are many users group which contain Microsoft Certified Partners.  They are usually happy to help with any and all concerns.  The Austin (Texas) group's discussion site is at: http://tech.groups.yahoo.com/group/aus-sbs/

NEXT: Here are some Microsoft articles that may help. Don't be confused when they reference Windows Server 2003, they still apply to SBS 2003.

*Shared Folders: http://support.microsoft.com/kb/324267/en-us
*Prevent Roaming: http://support.microsoft.com/kb/814592/en-us (NOTE: work this one backwards)




0
 
budchawlaCommented:
Have a look at this article which should solve your problem - it details what NTFS & share-level permissions to set on the parent folder of your profile folder...
http://technet2.microsoft.com/windowsserver/en/library/20b15453-f7c9-4cf0-9131-78924af776551033.mspx?mfr=true
0
 
soldiaCommented:
Set full control permission to the everyone group on the" Profiles" folder. This should allow your user account access.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Olaf De CeusterCommented:
You need the set permissions at Security level AND Share level.
Olaf
0
 
budchawlaCommented:
I wouldn't give "everyone" full control to the folder... in fact I don't use the everyone group at all when setting permissions, but use the Authenticated Users group instead - this is a lot more secure. However, in this case, just use the security group that will need access to the profiles under that path... and as Olaf & I mentioned above, you need to set both share-level permissions AND NTFS permissions...
0
 
PeterHingAuthor Commented:
Hi All,

Sorry for the delay in getting back to your all. Points now increased to 500, as this is doing my head in! :(

I had this random feeling it wasn't the permissions that were giving me greif, so I started again.
I created a folder C:\Profile$ and gave 'EVERYONE' full control.

Now, in AD, i set the profile path to \\server\profile$\%username% - All going well so far. I then logon as the user, and get a little balloon pop up:
"Windows cannot find the local profile and is logging you on with a temporary profile. Changes you make to this profile will be lost when you log off"
- the event viewer just tells me exactly the same

I look on the server and see a folder called USERNAME.V2 (username being the user's logon id) has been created - I've googled it, and can't find anything regarding profile.V2. I thought i'd be smart and change AD to say \\server\profile$\%username%.V2 - but the windows does the same but creating USERNAME.V2.V2

Vista Ultimate & SBS 2003

Can anyone help?

Many Thanks, Pete
0
 
turbo12Commented:
Question: Is your Vista 64bit?  If so, there is a HotFix in this KB article: http://support.microsoft.com/kb/917903/en-us
It refers to the problems you'll likely encounter with Vista 64bit (any flavor) and SBS 2003 running ISA 2004.

Creating a username.V2 directory in your profiles location and assigning appropriate permissions might work, but I'd check out the KB article to see if it applies to your situation. This has worked on Samba with Vista 64bit.
0
 
budchawlaCommented:
Did you follow the steps exactly as outlined in the technet article I posted above?
0
 
PeterHingAuthor Commented:
Hi All,

I found my problem. With a bit more intensive Google searching, and jumping from forum to forum, someone mentioned exactly the same problems as me. Loads of people mentioned permissions, but he too had set Full Control to Everyone on every folder.

It appears Vista was referencing old information in the registry. If you delete the profile from C:\Users\ you also need to remove a registry key from:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\

Without this key, the machine then thinks it's a new user, and re-creates the profile on the workstation.

I'm going to split the points between turbo12 & budchawla as the permissions references have now helped me since resolving the other issue.

Many Thanks,

Pete
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now