Exchange 2003 OMA configuration with IIS 5.0

Can not access Exchange 2003 OMA
w7krAsked:
Who is Participating?
 
LeeDerbyshireCommented:
Oh, I see.  I missed the IIS5 bit of your question.  For now, I would see if making sure that SSL is not required on Exchange fixes the problem.  If it does, you will need to use the Metaedit utility to clone the Exchange VDir.
0
 
czcdctCommented:
It shouldn't need any real configuration.
It's pretty much there by default. Check the settings here: http://www.petri.co.il/configure_oma.htm and see how you get on.

If you're having trouble with it then come back and say but also say if you've done a DCPROMO after installing IIS or before (or after) Exchange. That's pretty important.
0
 
w7krAuthor Commented:
Thanks for the response. I should give a bit more information:

I have not run dcpromo after install.
I do not have a fron end exchange server in place.
OMA is configured and I agree it is pretty much set up after Exchange install.
I am getting the error : "A System error has occured while processing your request. Please try again. If the problem persists, please contact your system admistrator"

I have followed the recomended fix from Microsoft KB article which shows creating a second virtual directory called "exhange-oma" and adding a registry entry to redirect to that virtual directory.  I suspect the fix is aimed at IIS version 6 because some of the selections that they are suggestions do not coincide with what is available in IIS 5.0 which is what I have. (Windows 2000 Advanced server with Exchange 2003)

Sorry for the long explanation but hope that explains my situation a bit more.

Thanks!


0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
czcdctCommented:
And what .net framework are you on?
0
 
w7krAuthor Commented:
Now that you mention it - It looks like I have a very old version - v1.1.4322   ??

0
 
czcdctCommented:
Well, it doesn't have to be up to date version, this is Exchange 2003 on Windows 2000; hardly up to date :-)

So, make sure you're doing this over HTTP at the moment rather than HTTPS. Make sure that the OMA (or your replacement) is doing HTTP (not ticked to enforce SSL)

And then get into the application logs and see what's going on.
You'll want to make sure the account you're accessing it can do so and can do so over "unsupported" devices (it's a tickbox in ESM - Global Settings - Mobile devices)
0
 
w7krAuthor Commented:
Unsupported devices is checked. Security is set to "Windows Integrate" and "Basic Authentication".  Require SSL is turned off for the OMA virtual directory.

I still get the same error message. Quick question: Is there a dedicated log for OMA? Or do I just use the general Exchange log?

By the way, Exchange and OWA have always worked pefectly.


0
 
czcdctCommented:
There's no such thing as an "exchange" or an "OMA" logon. It's your Active Directory credentials. Period. Finito. End Of.
Haven't you got /anything/ logged in the App Event Log or anywhere else at all? You're so completely light on diagnostics here,
0
 
w7krAuthor Commented:
Currently I have the OMA virtual directory set for "Basic Authentication" and am using HTTP. The user used for logon, has domain admin privledges.

I am getting Event ID 1805:

Request from user "                   "l resulted in the Microsoft(R) Exchange back-end server "           " returning an HTTP error with status code 403

Response:
Server: Microsoft-IIS/5.0
Date: Sun, 12 Aug 2007 22:03:27 GMT
Connection: close
Content-Length: 3779
Content-Type: text/html

0
 
LeeDerbyshireCommented:
The 403 status code may be because you have required SSL on your Exchange Virtual Directory in IIS Manager.  If you have, then you will need to un-require it, then do this, then re-require it again:

http://support.microsoft.com/kb/817379
0
 
w7krAuthor Commented:
Thanks for the response. I have tried to follow the method 2 on that KB article but get hung up on the save configuration to a file part. Right clicking and selecting "all tasks" just gives me the selection "permission wizard" and then with the creating a new virtual directory from a file which I don't have. This KB article must be designed for Windows 2003 and the newer version of IIS??
0
 
w7krAuthor Commented:
Thanks, I will give this a try and post the results.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.