Can't get mailto: to work properly with scandinavian characters in Outlook and Opera Mail

http://www.bitl.no/mail.html

When opening the mailto links the scandinavian characters will show up mangled in Outlook and Opera but correctly in Thunderbird.

If I change the encoding in firefox to ISO-8859-1 then Outlook will be correct but Opera still mangles it.

Settings on the server (Fedora Core 5):
LANG=nb_NO.UTF-8

/etc/sysconfig/i18n
LANG="nb_NO.UTF-8"
SUPPORTED="nb_NO.ISO-8859-1:en_US.ISO-8859-1:en_US.UTF-8:en_US:en:nb_NO.UTF-8:nb_NO:no"
SYSFONT="latarcyrheb-sun16"

/etc/httpd/conf/httpd.conf:
AddDefaultCharset UTF-8

Any tips?
johnnybalubaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yuzhCommented:
If you are using Web based mail, you should set:

AddDefaultCharset  off

in your httpd.conf, then restart apache.

To make it display Language other than the deafult Language for your OS correctly.
0
johnnybalubaAuthor Commented:

I'm not using web based mail, but creating web pages with mailto:-links. I'm trying to standarize on UTF8 but it seems that Outlook has got some problems with that.

I can set defaultcharset off and use the meta tag in the html header to use ISO-8859-1 but that is not really the solution I'm after. However if that's the only way I'll have to go for that.
0
RedKelvinCommented:
Hi there,
It may be the sending, not the receiving that is the problemo, take a look at this
http://www.bcs-mt.org.uk/wiggd.htm

RedK
0
johnnybalubaAuthor Commented:
Well, the problem occurs already when creating the email, ie just after clicking on the mailto-link. æøå becomes æøå.

However setting AddDefaultCharset off and then setting charset=ISO-8859-1 in the html header fixes it. It feels like a step backwards though but it's the only way to get Outlook to behave it seems. Can't get Opera Mail to work no matter what I do. Kind of odd since it is a norwegian based company.
0
Computer101Commented:
PAQed with points refunded (500)

Computer101
EE Admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.