I'm getting a Windows - Delayed Write Failed message at the lower left of the taskbar when trying to write to server.

Hi Experts,
  I work for a dental office with 9 windows XP workstations and 1 2003 Server. These workstations have scanners/cameras hooked up to them so they can take an xray of a patient and save if in there file which is stored at the server level. Well everything was working great , but yesterday about 3 of the workstations started getting this error messag when they took an xray and wanted to save it on the server or when they scanned a document and wanted to save it to the same location on the server. Here is the exact message that they are getting. A pop up on the lower right of the taskbar comes up and reads:
Windows - Delayed Write Failed
Windows was unable to save all the data for the file \\server\dentrix\dximage\images\4567.vns.
The DATA has been lost. This error maybe caused by a failure of your computer hardware or network
connection. Please try to save this file elsewhere.

Then I looked at even viewer is here are the details:
Date: 8/12/2007            Source: MRxSmb
Type: Warning              Event ID: 50
Description:
(Delayed Write Failed) Windows was unable to save all the data for the file \Device\LanmanRedirector.
The DATA has been lost. This error maybe caused by a failure of your computer hardware or network
connection. Please try to save this file elsewhere.

I clicked on this link http://support.microsoft.com/kb/321733/en-us and it gives me this workaround, which I haven't done because it's not very detailed as it doesn't tell me what to modify in uder parameters.

WORKAROUND
Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To work around this problem, turn off SMB signing on the server: 1. Start Registry Editor.
2. Locate, and then click the enablesecuritysignature value under the following key in the registry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Lanmanserver\Parameters
3. On the Edit menu, click Modify.
4. In the Value data: box, type 0, and then click OK.
5. Quit Registry Editor.
6. Stop and then restart the server service, or restart the computer.

Any help or suggestions will be greatly appriciate it, I think its server related because it's only affecting some of the computers not all.


frankbustosAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
and235100Connect With a Mentor Commented:
The best bet is to troubleshoot any potential hardware problems first.

If it is easy to do - can you try changing a network card, and a network cable in an affected computer?

The winsockxpfix will only resolved internet connectivity issues.

I was talking about unchecking the Internet Protocol (TCP/IP), rebooting, then re-checking it - not really using netsh...
0
 
and235100Commented:
These errors are usually down to either - network conditions/hardware failure(s), or disk caching/bad sector errors.

Firstly - to rule out disk problems - run chkdsk /R on the hard disk(s) that you are attempting to copy the files to.

The network conditions covers a wide scope - you can firstly try changing network cables and/or network interface cards. Then - you can pursue TCP/IP stack issues, if necessary.
0
 
and235100Commented:
One other thing to check - if you are using NTFS security on your computer hard drives - check the security on these - and make sure you have the appropriate permissions.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
frankbustosAuthor Commented:
Hello 235100, i'm doing checking the hard drive for errors now. I'ts a 200GB HDD so it might take a while. I'm heading to the movies with my family now but I will be back to this office to continue. I'll give you an update in about 3hrs. Thanks for your quick response!
0
 
frankbustosAuthor Commented:
and235100, the chkdsk finished and one of the workstations out of the 3 that was having a problem is now acting fine. The other two are still timing out...strange. So, I am mirroring the hard disk into a new and bigger SATA drive. Once that is done I will give you an update. Also, I know you mentioned to pursue tcp/ip stack issues but were you referring to the server or workstations as well? I know there is a utility called winsock I might run that after I finish mirroring the drive.
0
 
frankbustosAuthor Commented:
Hell and235100,

   I replaced the network cards on these two pcs, actually i decided to replace it on all three and that seemed to solved the problem. It's super fast now and no more write delay errors are coming up. I'm just wondering now what caused these network cards to go bad and can they act like that?
0
 
frankbustosAuthor Commented:
replacing the network cards seemed to have solved the problems.

Thanks,
Frank
0
 
and235100Commented:
This could be down to all sorts of things - dodgy power being fed to the components, either from a failing power supply - or a severely fluctuating AC supply - or just simple hardware failures - always go for godd quality, well known makes of nic - Intel are one of the best - and are recognised in industry.

Connecting your pc(s) to a ups may be overkill - but check for poor quality PoE devices (if you use PoE) - and make sure that the power you are using is of a clean, good quality.

Glad I could provide some assistance. Thank you.
0
 
Feroz AhmedSenior Network EngineerCommented:
Hi,
Check for your system LanCard whether you are able to access Network and on Server check for the permissions on that particular file ask your system administrator to check whether your Administrator might have changed Grant Permissions and check for Routing and Remote Access Services and start the services and goto cmd and type gpupdate.exe.it will update process instead of restarting syste.
0
All Courses

From novice to tech pro — start learning today.