• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2075
  • Last Modified:

Report Builder Permissions Error

Error: (this occurs when I "Run Report" on the menu bar of report builder)
The permissions granted to user 'DOMAIN\Username' are insufficient for performing this operation. (rsAccessDenied)

Problem:
I receive this error on my ClickOnce Report builder on any username other than DOMAIN\Administrator when I "Run Report".
I can build the report, I can save the report to the reportserver and run it from there just fine but when I attempt to preview through "Run Report" on a local box I receive the error above.  This is a new install and has now been installed 3 x's each on clean machines with the same results.  What permissions would I need to create yet to complete this install.
0
rhservan
Asked:
rhservan
  • 12
  • 9
1 Solution
 
davecorunCommented:
Add your users to the SQLServer2005ReportServerUser group on the server.  You need to ensure people have access to the report server first.

You can also try browsing to the /Reports directory off of the report server to verfiy you can connect to the web interface.
0
 
rhservanAuthor Commented:
Thanks,  I have been there done that.
I can access the reports from the reportserver
I can access the /Reports reports manager  interface.
I can run the Ad Hoc Report builder on the desktop and select a field. (This is not the Report Designer tool)
I cant perfom "Run Report" in the AD hoc client.  It errors with the permissions problem as stated above.
This is baffling.  Everything else works great accept for this piece.
0
 
davecorunCommented:
Are you refering to the Report Builder that comes with SSRS, or a seperate one you developed?

Are you using Windows Authentication?  Are you logged in as the user (in the domain) that is also added to the ReportServerUser group?  Is the report server a member of the domain?

Just trying to clear out the easy stuff first, before we really dig in.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
rhservanAuthor Commented:
1. Using Windows Authentication
2. Logged in as ReportServerUser member.
3. Report Server is also the domain controller and the server shows as such under the domain controller folder.
0
 
davecorunCommented:
Ok, so it's definitely a Report Builder issue, and not a configuration issue then.

When you publish these reports, are you setting the correct permissions on the Report Server site?  (http://.../Reports).

I think the default is only the person who created the report can see it.  You have to share it out for others to run the report.

Also, have you verified that the user that are getting denied also have access to the SQL Server and the backend data?  They need to be a member of a group that has access, or be explicitly granted access.
0
 
davecorunCommented:
Sorry we're going back and forth on this.  The Reporting Services errors can be quite generic (rsAccessDenied), so you really need to narrow down all of the common things first.
0
 
rhservanAuthor Commented:
I am referring to the ad hoc report builder tool which is a ClickOnce application for an end user to build a report without having to build TSQL.  Basically you just click and drag fields into a table. It is run from the report server\report builder directory under the SQL instance directory under program files. This is not the designer tool under BI.  Although you build the project model with the designer.
0
 
davecorunCommented:
I'm with you 100% that you're running the Report Builder application.  We just needed to verify the rest of the configuration on the server first.
0
 
rhservanAuthor Commented:
You add user to the report manager and give them report builder rights.  This is what allows them to run this tool.  A butoon for report builder will appear on the report manager when that user is logged in and accesses the report manager site.
0
 
rhservanAuthor Commented:
Then  the user can click on the report builder button and it runs a short install into a temp directory on the requesting computer and opens with a list of project models to choose from.  Once you select the model you will have fields to choose from and drag to the default table on the form.  Then you perform the "run report" and you are supposed to get a preview but this is where it fails with the permissions issue.  Again, I can save the report to the report server from here and then go to the report sever and view but I cannot get it to run the report locally from the client.
0
 
davecorunCommented:
Are you using the same credentials when you view the report on the report server site?

I've used the Report Builder on a few projects with clients, and it's always been a simple permissions issue with the user accounts in question.  Whether its a group policy setting, sql server permissions, report server user group, or something else.  Almost always permissions.
0
 
rhservanAuthor Commented:
How would the rights in SQL have to look in order for this to work for my user
0
 
rhservanAuthor Commented:
Yes I am using the same credentials when viewing from the report server
0
 
rhservanAuthor Commented:
I have to call it a night, early day in the morining.  Please post any thoughts or solutions. Thanks for your support. I will continue communications on this matter tomorrow.
0
 
rhservanAuthor Commented:
This is still an open problem please continue to solicit a solution.
0
 
davecorunCommented:
In SQL ensure that the group(s) the user belongs to has access to the database, and any data that the report relies on.  For instance, if it references a view, the user must have access to that view.

You can also right-click most objects in SQL Server and choose "Effective Permissions" to verify that the users in question have access to the data.
0
 
rhservanAuthor Commented:
THIS IS THE CORRECT ANSWER WHICH HAS RESOLVED THE PROBLEM.  
1. You must login as an Administrator in the domain. (Administrator is the only user which sees "site settings" on the initial installation on the report manager page.)
2. Go to report manager
3. Click on Site Settings
4. Add users to the "system user" under configure site settings.
(You can also add user to System Administrator here.)
Once this is completed the users assigned to the system user will be able to run the ad hoc reports uninhibited.
0
 
davecorunCommented:
Woah, but you're also giving a typical user full control here, instead of the preferred finer grain permissions they probably should have.
0
 
rhservanAuthor Commented:
When managing the report server as an Administrator you have the full rights over report manager.  No users are added under the Site Settings by default accept for the Administrator.  There are two accounts available here 1. System Administrator or 2. System User.  Each of these user have granularity assignem for security discretion.  So, the System User has very limited access but has the ability to run reports under the "ad hoc" report builder tool.  Without this configuration all of the other folder & SQL role permissions won't matter.  Been there done that.  I stick by the above solution on the foundation that the System User does not have extreme permissions unless they are grabularly given in the Site Settings configuration feature.
0
 
rhservanAuthor Commented:
The environment is:
1. Winodws 2003 Server
2. SQL Server 2005 SP2
3. Reporting Services 2005
4. .NET 3.0

And planning on Sharepoint integration with reporting services which the above configuration is the minimum requirements.

I am not sure that my concern applies to any previous versions of SQL Server or Reporting services.
0
 
davecorunCommented:
Will you be closing this question?

http://www.experts-exchange.com/help.jsp#hi55
0
 
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 12
  • 9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now