troubleshooting Question

Cisco 1801 ADSL Router - No connection to the internet

Avatar of ccfcfc
ccfcfcFlag for United Kingdom of Great Britain and Northern Ireland asked on
Routers
7 Comments1 Solution2120 ViewsLast Modified:
I have a Cisco 1801 router that I am conencting to my ADSL line. I cannot get out of the box, whatever settings I try.

The ADSL connection seems to be ok, as I can see the traffic count in and out increasing, but I cannot get to anything on the internet.

My cleaned up config is as follows. The devices I'm trying to access the internet from are on VLAN1 on the 88.88.0.0/255.255.0.0 network.

I'd appreciate it if someone can point out where I'm going wrong.

TIA




Current configuration : 5707 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxxxxxxxxx
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 xxxxxxxxxx
enable password xxxxxxxxxx
!
no aaa new-model
!
resource policy
!
!
!

ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 88.88.88.88
!
ip dhcp pool sdm-pool
   import all
   network 10.10.10.0 255.255.255.248
   default-router 10.10.10.1
   lease 0 2
!
!
no ip domain lookup
ip domain name yourdomain.com
!
!
crypto pki trustpoint TP-self-signed-xxxxxxxxxx
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-xxxxxxxxxx
 revocation-check none
 rsakeypair TP-self-signed-xxxxxxxxxx
!
!
crypto pki certificate chain TP-self-signed-xxxxxxxxxx
 certificate self-signed 01
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx
  quit
username xxxxxxxxxx privilege 15 secret 5 xxxxxxxxxx
username xxxxxxxxxx privilege 15 secret 5 xxxxxxxxxx
!
!
!
!
!
!
interface FastEthernet0
 no ip address
 speed 100
 full-duplex
 vlan-id dot1q 10
  exit-vlan-config
 !
 vlan-id dot1q 1
  exit-vlan-config
 !
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet1
switchport mode trunk
 duplex full
 speed 100
 vlan-id dot1q 1
  description inside
  exit-vlan-config
 !
!
interface FastEthernet2
 vlan-id dot1q 1
  exit-vlan-config
 !
!
interface FastEthernet3
 vlan-id dot1q 1
  exit-vlan-config
 !
!
interface FastEthernet4
 vlan-id dot1q 1
  exit-vlan-config
 exit-vlan-config
 !
!
interface FastEthernet5
 vlan-id dot1q 1
  exit-vlan-config
 !
!
interface FastEthernet6
 vlan-id dot1q 1
  exit-vlan-config
 !
!
interface FastEthernet7
 vlan-id dot1q 1
  exit-vlan-config
 !
!
interface FastEthernet8
 vlan-id dot1q 1
  exit-vlan-config
 !
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto
!
interface Virtual-PPP1
 no ip address
 no cdp enable
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$
 ip address 88.88.88.88 255.255.0.0
 ip access-group 101 in
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
!
!
interface Dialer1
 description internet dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap pap
 ppp chap hostname xxxx@xxxx.xxxx.xxxx
 ppp chap password 0 xxxxxxxxxx
 ppp pap sent-username xxxx@xxxx.xxxx.xxxx password 0 xxxxxxxxxx
 ppp ipcp dns request
 ppp ipcp wins request
!
interface Dialer2
 no ip address
 shutdown
 no cdp enable
 no cdp enable
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 100 interface Dialer1 overload
!
ip access-list extended nat-to-dialer1-int
!
access-list 100 permit ip 88.88.0.0 0.0.255.255 any
access-list 101 permit ip any any log
access-list 101 permit icmp 88.88.0.0 0.0.255.255 any
access-list 101 permit tcp 88.88.0.0 0.0.255.255 any
access-list 101 permit udp 88.88.0.0 0.0.255.255 any
dialer-list 1 protocol ip permit
no cdp run
!
!
!

dialer-list 1 protocol ip permit
no cdp run
!
!
!
route-map pat-map permit 1
 match ip address nat-to-dialer1-int
!
!
!
!
control-plane
!
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "cisco"
with the password "cisco". The default username and password have a privilege le
vel of 15.

Please change these publicly known initial credentials using SDM or the IOS CLI.

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want to use
.

For more information about SDM please follow the instructions in the QUICK START

GUIDE for your router or go to http://www.cisco.com/go/sdm
-----------------------------------------------------------------------
^C
!
line con 0
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
!
webvpn context Default_context
 ssl authenticate verify all
 !
 no inservice
!
end
ASKER CERTIFIED SOLUTION
Les Moore
Systems Architect
Join our community to see this answer!
Unlock 1 Answer and 7 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 7 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros