We help IT Professionals succeed at work.

OWA HTTP Error 404 Access Problem

2,753 Views
Last Modified: 2012-08-13
I have Server 2003 and Exchange 2003.  If I try to access OWA using http://mail.domain.com/exchange from outside this network I get a "Page cannot be found HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)" Error.  I get the same error if I am inside of this network by entering the private IP address/exchange.  But if I am inside the network and enter 127.0.0.1/exchange it works fine.  What am I missing???
Comment
Watch Question

Dave StringfellowIT manager

Commented:
check the exchange folder in IIS permissions, make sure it hasnt got any deny options on the security settings, and alos make sure IIS is using all available IP address

Author

Commented:
If I right click on "exchange" under "Default Web Site" I get no response.  If I do the same on "ExchWeb" I can view the security settings and there are none set to deny.  How do you "make sure IIS is using all available IP addresses"?  I have been comparing the IIS settings on this system to others that are working and I can not find any differences.  THX
You should probably right click on the "Default Website," go to directory Security, and click "Edit" next to IP address and Domain name restrictions.  Make sure the connections are allowed for a local address range above and beyond 127.0.0.1 (localhost).  Then you'll also need to NAT/Port forward outside traffic to that box if you want to get at it from the Internet.  You may need to open port 80 as well.  If you want to use https, you'll need to forward port 443 for SSL and you'll need to install a certificate on that box - self signed will work fine for most purposes.  Hope this helps.

Author

Commented:
Here's what I've figured out.  In addition to exchange web access I also have a website running locally.  The hierarchy of the IIS folder structure is: \\Server\Web Sites\Default Web Site\ExchWeb.  There is also a folder called companyweb under \\server\web sites\.  This folder lists the files of the web site.  The same files are listed under \\server\web sites\default web site.  If I stop the web site companyweb Outlook Web Access works fine.  As you can tell I'm not extremely knowlegeable about IIS.  What is the proper hierarchy for these folders?
Expert of the Year 2007
Expert of the Year 2006

Commented:
You are using SBS. You should have explained that in the original posting.
With SBS you don't change anything manually - everything should be done using the wizards. You need to run the internet and email wizard (or whatever it is called) and ensure that you have chosen the right options for public access.

Simon.
I disagree with the statement "you don't change anything manually."  I have configured Small Biz Servers and have changed lots of things manually - including fixing OWA in several cases.  The IIS management console works fine, IIS is just preconfigured in a way to create a stock (useless) "company web" application, among other things.  I do agree, though, that there are wizards for a lot of things, most of which can be found in Server Manager, which can be found in start/all programs/administrative tools/server management.  There is an option for configuring your Internal Website in the Server Manager.  That may help - but as I said, I've made most configurational changed in Small Biz using traditional Windows management tools.

Also the "heirarchy" you describe sounds fine.  The clue about OWA working when the company web app is a good one.  Just a guess, but can you configure company web to use the servers internal IP address, and configure the Default Website to use All Available?   Right click/choose properties on company web and then Default Website to do this.
Expert of the Year 2007
Expert of the Year 2006

Commented:
tmateosian1 - if you have made manual changes then you have got away with them. That is not how you should be doing things with SBS. It takes time for someone who knows how to configure everything manually to learn that things should be done the SBS way, but once you do you will find that everything works exactly as it should. SBS should be treated as an appliance and the tools that Microsoft have provided for management used whenever possible.

What I also tend to find is that making the changes manually is fine, but when someone comes along and starts to use the server as it was designed - ie using the wizards - everything then goes very wrong.

Simon.

Author

Commented:
Sembee,
They USED to have SBS.  This is now a Server 2003/Exchange 2003 Standard installation.  
 

Author

Commented:
tmateosian1:,
Changing the IP address has no effect.  As long as the companyweb is started I can not get to web mail.  With companyweb stopped webmail works perfectly.
Sorry the IP change didn't work.  I'm sure the solution is pretty simple.  I will think about it some more and get back to you tomorrow.
Expert of the Year 2007
Expert of the Year 2006
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Thanks to all.
As a final result for and for future reference - the resolution to this iisue was initially stopping and finally deleting the companyweb folder.

Commented:
Not correct, your problem may be is that the companyweb run under 80 port, when you install exchange and create another Web site for OWA, which runs over 80 either, that the problem. When you have deleted the companyweb, the 80 port is now free to be used by OWA and default web site
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.