Link to home
Start Free TrialLog in
Avatar of ericinmia
ericinmia

asked on

Simple Cisco configuration problem routing between stores

I have basic knowledge of Cisco CLI, but I can't get this to work.
We are trying to connect two stores on separate subnets (10.0.x.x/255.255.0.0) and (10.1.x.x/255.255.0.0)
The lan side IP's should be 10.0.0.254 and 10.1.0.254 respectively. The Firewall's IP is 10.0.0.1
I am using two Cisco 3560 switches for this, but can't seem to get them to talk to eachother... I have a network cable attached from fa 0/1 to fa 0/1.
The purpose of these switches is to act as routers, segregate the networks, and cut out the broadcast traffic between locations... alongside the QOS for the VOIP sessions.

Here are the running configurations, please help me... I'm lost as to what I can do!

Main Store (10.0.x.x)

Building configuration...

Current configuration : 1150 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FWHNMWAN
!
enable secret 5
!
no aaa new-model
clock timezone UTC -5
clock summer-time UTC recurring 1 Sun Apr 2:00 last Sun Oct 2:00
system mtu routing 1500
ip subnet-zero
!
!
mls qos
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 description Routed link to Coconut Grove
 no switchport
 ip address 172.16.1.1 255.255.255.252
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface GigabitEthernet0/1
!
interface Vlan1
 ip address 10.0.0.254 255.255.0.0
!
ip default-gateway 10.0.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
ip route 10.1.0.0 255.255.0.0 172.16.1.2
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
 password ###########
 login
 length 0
line vty 5 15
 password ###########
 login
 length 0
!
end

###########################################################
###########################################################
###########################################################

Here is the configuration for the other store (10.1.x.x)

Building configuration...

Current configuration : 1109 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FWHCGWAN
!
enable secret 5
!
no aaa new-model
clock timezone UTC -5
clock summer-time UTC recurring 1 Sun Apr 2:00 last Sun Oct 2:00
system mtu routing 1500
ip subnet-zero
!
!
mls qos
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 description Routed link to North Miami
 no switchport
 ip address 172.16.1.2 255.255.255.252
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface GigabitEthernet0/1
!
interface Vlan1
 ip address 10.1.0.254 255.0.0.0
!
ip default-gateway 172.16.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.1
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
 password ###########
 login
 length 0
line vty 5 15
 password ###########
 login
 length 0
!
end
SOLUTION
Avatar of adnanmig
adnanmig

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
is there an active physical connection ?

with wich cable are the 2 switches connected straight or crossover?

just want to check if layer 1 is ok :)
ASKER CERTIFIED SOLUTION
Avatar of Les Moore
Les Moore
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
yo, llyquid - haven't seen you around these parts in a really long time..

If you trunk the interfaces, wouldn't that propogate the broadcasts, at least within the vlan boundaries, and that would cross this link? By using routed interfaces, they have created broadcast boundaries which was one of the stated goals.
Avatar of llyquid
llyquid

Hi Irmoore...  i guess its been almost four years since ive posted...  I just noticed these two switches appear to be at different physical sites,  North Miami and Coconut Grove...   How are the connected,  Metro E?

Im sure he just needs to enable "ip routing on the switches"
Glad to see you back! Where you been?
I'm thinking metro E myself.....
Avatar of ericinmia

ASKER

Yes we will be utilizing a 10mb metro E.  I want to make sure that the branches still operate separately, no broadcasts, dhcp, etc.
Ok I am using a crossover cable between the two switches. On Fa 0/1 on both.
I removed the gateway's, and put in the IP routing command.
Plugging my laptop into either switch I can ping the local vlan address, and both wan address'
But I can't ping the local address on the other switch...
Occasionally a ping to the local vlan will say that the TTL expired in transit at the wan side of the switch that I was trying to ping.
Or it says Destination Host Unreachable

I am not sure what is wrong... I am about to pull my hair out.
Thank you all for any help you can give!
Here are the new configs...

*******************************
*******************************
North Miami Switch
*******************************

Building configuration...

Current configuration : 1133 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FWHNMWAN
!
enable secret 5
!
no aaa new-model
clock timezone UTC -5
clock summer-time UTC recurring 1 Sun Apr 2:00 last Sun Oct 2:00
system mtu routing 1500
ip subnet-zero
ip routing
!
!
mls qos
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 description Routed link to Coconut Grove
 no switchport
 ip address 172.16.1.1 255.255.255.252
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface GigabitEthernet0/1
!
interface Vlan1
 ip address 10.0.0.254 255.255.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
ip route 10.1.0.0 255.255.0.0 172.16.1.2
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
 password ############
 login
 length 0
line vty 5 15
 password ############
 login
 length 0
!
end


*******************************
*******************************
Coconut Grove Switch
*******************************


Building configuration...

Current configuration : 1092 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FWHCGWAN
!
enable secret 5
!
no aaa new-model
clock timezone UTC -5
clock summer-time UTC recurring 1 Sun Apr 2:00 last Sun Oct 2:00
system mtu routing 1500
ip subnet-zero
ip routing
!
!
mls qos
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 description Routed link to North Miami
 no switchport
 ip address 172.16.1.2 255.255.255.252
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface GigabitEthernet0/1
!
interface Vlan1
 ip address 10.1.0.254 255.255.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.1
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
 password ###########
 login
 length 0
line vty 5 15
 password ###########
 login
 length 0
!
end
What is result of show interface fast 0/1?
Do you see CRC errors count?
Try bouncing the interfaces - shut/no shut
Try rebooting both switches
3560 switch should have auto-mdx capability. Try using a standard patch cable between them instead of a crossover
Try a different crossover
I originally was using a standard patch cable thinking auto-mdx was fine, the crossover was a shot in the dark, but i'm back using the straight patch.
I have 'reload'ed the routers, hard power cycling, etc.  But to no avail.
There has to be a command, gateway, IP routing, or something that i'm missing or is wrong... I just don't know.
I have not tried 'bouncing the interfaces', not sure how to do that. (just shut them down, and then re enable?)

Once again, thank you all for the help!

######################################
This is on 10.0.0.254
######################################

FWHNMWAN#ping 172.16.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
FWHNMWAN#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
FWHNMWAN#show interface fa 0/1
FastEthernet0/1 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 001c.f917.49c1 (bia 001c.f917.49c1)
  Description: Routed link to Coconut Grove
  Internet address is 172.16.1.1/30
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:13, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     6138 packets input, 653633 bytes, 0 no buffer
     Received 707 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 698 multicast, 0 pause input
     0 input packets with dribble condition detected
     6131 packets output, 650118 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out



######################################
This is on 10.1.0.254
######################################

FWHCGWAN#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
FWHCGWAN#ping 172.16.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
FWHCGWAN#show interface fa 0/1
FastEthernet0/1 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 001c.f917.4bc1 (bia 001c.f917.4bc1)
  Description: Routed link to North Miami
  Internet address is 172.16.1.2/30
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     6083 packets input, 644371 bytes, 0 no buffer
     Received 693 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 689 multicast, 0 pause input
     0 input packets with dribble condition detected
     6086 packets output, 646885 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
Here are some more things that I thought may help...

FWHNMWAN#show IP arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.0.0.50               1   0001.4a24.ed1b  ARPA   Vlan1
Internet  172.16.1.1              -   001c.f917.49c1  ARPA   FastEthernet0/1
Internet  172.16.1.2              1   001c.f917.4bc1  ARPA   FastEthernet0/1
Internet  10.0.0.254              -   001c.f917.49c0  ARPA   Vlan1

FWHNMWAN#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.0.0.1 to network 0.0.0.0

     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/16 is subnetted, 2 subnets
C       10.0.0.0 is directly connected, Vlan1
S       10.1.0.0 [1/0] via 172.16.1.2
S*   0.0.0.0/0 [1/0] via 10.0.0.1


FWHNMWAN#show ip cef
Prefix               Next Hop             Interface
0.0.0.0/0            10.0.0.1             Vlan1
0.0.0.0/32           receive
10.0.0.0/16          attached             Vlan1
10.0.0.0/32          receive              Vlan1
10.0.0.50/32         attached             Vlan1
10.0.0.254/32        receive              Vlan1
10.0.255.255/32      receive              Vlan1
10.1.0.0/16          172.16.1.2           FastEthernet0/1
172.16.1.0/30        attached             FastEthernet0/1
172.16.1.0/32        receive              FastEthernet0/1
172.16.1.1/32        receive              FastEthernet0/1
172.16.1.2/32        attached             FastEthernet0/1
172.16.1.3/32        receive              FastEthernet0/1
224.0.0.0/4          drop
224.0.0.0/24         receive
255.255.255.255/32   receive

FWHNMWAN#show ip traffic
IP statistics:
  Rcvd:  1220 total, 1219 local destination
         0 format errors, 0 checksum errors, 0 bad hop count
         0 unknown protocol, 0 not a gateway
         0 security failures, 0 bad options, 0 with options
  Opts:  0 end, 0 nop, 0 basic security, 0 loose source route
         0 timestamp, 0 extended security, 0 record route
         0 stream ID, 0 strict source route, 0 alert, 0 cipso, 0 ump
         0 other
  Frags: 0 reassembled, 0 timeouts, 0 couldn't reassemble
         0 fragmented, 0 couldn't fragment
  Bcast: 14 received, 52 sent
  Mcast: 0 received, 0 sent
  Sent:  911 generated, 1334 forwarded
  Drop:  29 encapsulation failed, 0 unresolved, 0 no adjacency
         0 no route, 0 unicast RPF, 0 forced drop
         0 options denied, 0 source IP address zero

ICMP statistics:
  Rcvd: 0 format errors, 0 checksum errors, 20 redirects, 4 unreachable
        24 echo, 30 echo reply, 0 mask requests, 0 mask replies, 0 quench
        0 parameter, 0 timestamp, 0 info request, 0 other
        0 irdp solicitations, 0 irdp advertisements
  Sent: 10 redirects, 2 unreachable, 40 echo, 24 echo reply
        0 mask requests, 0 mask replies, 0 quench, 0 timestamp
        0 info reply, 0 time exceeded, 0 parameter problem
        0 irdp solicitations, 0 irdp advertisements

TCP statistics:
  Rcvd: 1128 total, 0 checksum errors, 0 no port
  Sent: 812 total

UDP statistics:
  Rcvd: 18 total, 0 checksum errors, 3 no port
  Sent: 30 total, 15 forwarded broadcasts

IP-EIGRP statistics:
  Rcvd: 0 total
  Sent: 0 total

ARP statistics:
  Rcvd: 2 requests, 2 replies, 0 reverse, 0 other
  Sent: 16 requests, 19 replies (1 proxy), 0 reverse
  Drop due to input queue full: 0
Everything looks fine.
Be sure that you actually have something plugged into at least one of the other ports on each switch, then from each router console, ping the vlan1 ip address of the other switch.
I still dont see the "ip routing" command in your switches...     Do a "sh ip route"   If nothing comes up then enter the first command...  

Have you verfied that the MetroE is working...  I know Bell...  I mean the NEW AT&T... never makes mistakes = )  If your using the Bell Metro Ring in SFL...  You can just plug one end into a normal switchport,  and then you can plug a laptop in at the other location and you should get a connection as if hooked up locally at the other site...
system mtu routing 1500
ip subnet-zero
ip routing  <====
!

It's there.
Man...  I ned to get some new glasses or turn down the Uber Resolution on my monitor....    

Lets see what the following shows:

1) show ip int brief
2) sh cdp ne detail
3) sh int status

These will help...  Did you follow Irmoore's recommendatino to make sure something was linked to a port on Vlan1 on each switch?
Thanks ya'll!

Becuase I was doing this in a test lab trying to make sure it worked prior to the 10mb metro-e was installed, I was only using one laptop and hadn't thought about the fact that the other vlan interface wouldn't be (active/pingable) without something attached to it.

So after we originally added the IP Routing commmand, and then found out I needed to attatch another laptop... it all worked!  Thanks Again, I really appreaciate it!
-Eric