troubleshooting Question

xp_cmdshell returns null

Avatar of LindbakRetail
LindbakRetail asked on
Microsoft SQL Server 2005
9 Comments1 Solution819 ViewsLast Modified:
xp_cmdshell returns null. I have turned on the security option for xp_cmdshell, so no error messages are thrown.
if i run:
exec master..xp_cmdshell 'blabla'
All i get is a recordset with one column and one row containing a null value.
It doesn't matter if i try to run a command text that should not work, like 'hello'. The result is still the same.
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 9 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 9 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros