We help IT Professionals succeed at work.

Office 2007 configures itself at every launch in Vista

5,113 Views
Last Modified: 2012-08-13
my Office 2007 configures itself at every launch in Vista.
that means every time i have mail it will do it.

error message
 "Please wait while Windows configures Microsoft Office Professional 2007"

please help!!
Comment
Watch Question

The most common cuase for this is that office is looking for a missing component. Generally if it is outlook it is looking for a plugin or language pack

Although drastic, the best option is to uninstall office, delete any temp installation files ( use windows cleanup wizard for best reults - start > applications > system tools > cleanup )
Restart your machine to remove any links or deletion files, then reinstall. If size is not an issue, select install all components during install process, that way office should always have the files it requires. ( do not select delete temp files, so that you can retain these files)

That should remove that issue. With more specific information, i can give a more realistic solution. Check teh office event logs

Regards, Alan

Commented:
Or at the minimum, make sur ethat you ahve access to the install source CD or install share.  Then it will grab the components automagically.  I do however agree with Sings suggestion of installing every component to prevent this.

Author

Commented:
Sorry but nothing helps.
i have tried to clean all using "cleanup", and tried to install office from CD with all the components on.
and even download a trial version from Microsoft to see if there was anything wrong with my version.
but its still the same.
and its with all the programs in the officepack.

i have noticed that my icons on my excelark or word dokuments is blank, i dont know why.

hope there is a solution to this problems.

Author

Commented:
another thing i have noticed is that every time i have uninstall office, and reinstall it again, all my mail and contact is still there, i dont have to restore all my mails, and that seems like it dosnt uninstall everything or what??

Commented:
I've had this problem before - carrying out the following helped me remove this issue

1) If you have the hard disk space, install every component that Office 2007 provides
2) If given the choice, leave the Office installation files on the hard disk
3) Install Office 2007 as an administrator - Sometimes, files need to be written and if you're not a user with administrative privileges then you can get this sort of problem.

I hope this helps :)
Jeff BrownGlobal Helpdesk Supervisor

Commented:
this is a problem with the windows installer  not  office actually.  they made a cleanup utility specifically to address this reinstall problem  its available below

http://support.microsoft.com/kb/290301

after running this utility on the affected program  you will need to re install that program a single time and it should solve your issue

Author

Commented:
sorry!
but the solutionwith the windows installer didnt help.

its still the same problem.
Is this only seen when you access outlook, or other office products. ( i.e word, excel, etc )

Alan
The issue is not with the installer, but most likely a component of office or third party, like antivirus.

Can you run the installer using the "right click, run as administrator option"

Author

Commented:
its with all the programs in the office pack.

i can actually open the program i want, but at the same time its start configures Microsoft Office Professional 2007.

and this is very annoying when it happens every time a mail comes in.

Author

Commented:
how can i totally (clean) uinstall office 2007, because everytime i tried to uninstall it. my mail database is still there the next time i have install the officepack. and that must mean that not everything is removed when uninstalling the officepack.

im really trying to avoid the last solution to start all over with a clean vista ultimate installation.
The configuration files are located in the following location.

C:\Users > user name > AppData > Local > Microsoft > OFFICE

and the outlook temp files are locacted here

C:\Users > user name > AppData > Local > Microsoft > Outlook

The following link my help. It is an MSI uninstaller, but i am not toally  sure what affect it will have on office 2007, although by principle it should still workl.

http://support.microsoft.com/kb/290301

Regards, Alan

Author

Commented:
well still no luck guys.
but im not alone with my problem, i have noticed a few others with the same issue but still no solution.
 

Author

Commented:
im getting a lot of these warnings in my event log under MSIInstaller:

Detection of product '{91120000-0012-0000-0000-0000000FF1CE}', feature 'ProductFiles', component '{6252B847-BADA-43D4-9252-E39767FA40A1}' failed.  The resource 'HKEY_CLASSES_ROOT\.pip\' does not exist.

or

Detection of product '{91120000-0012-0000-0000-0000000FF1CE}', feature 'ProductFiles' failed during request for component '{2A799F3E-9097-4883-A4DC-8F01023B4251}'

i dont know if that helps!
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
i just tried what you suggested, and its still almost the same, but now its only happens when entering Excel and Word, it has dissapered From Outlook and Powerpoint.

I have the standard Office 2007 and Vista Ultimate.

Would it be easiere just to make a clean vista installation again?

another think, i couldnt find the UserClass.dot.log. you talks about, only the UserClass.dat


Can you post the event id.

The full Event message that shows up in eevent viewer

Regards, Alan

Author

Commented:
well  i think i got the solution to the problem.
the think with the permissions in the registry did solve the Outlook problem, but not the rest of the programs.

but after uninstall and reinstall every application, the problem suddenly dissapered.
it must have been something to do with the permission
is it dsolaris that should have the credits for the solution??
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Commented:
BE CAREFUL!  I have the same problem but it only ocurred after SP1 was installed.  Im going to try some of these suggestions here and let you know the outcome!
has anyone had anymore luck with this?

I'm admin at a school, and out of 1000 machines, I have about 500 doing this.

The problem is, some machines are celerons, and take up to 10 minutes to do this "configure" thing.

I've tried the fixes above, and none have helped.
I think I have found a solution:

http://uksbsguy.com/blogs/doverton/archive/2007/07/21/how-to-get-rid-of-the-installer-configuration-dialog-when-running-office-2007-and-office-2003-on-the-same-system-for-vista-and-other-versions-of-windows.aspx


The fix to the problem is very simple as it turns out - simply run the following commands (by pressing the Windows Key+R or typing it into the Start/Run command box.  Use the line with Office\11.0 if you have Office 2003 installed and Office\12.0 if you have Office 2007 installed.  You can use both if you have both installed :
 
reg add HKCU\Software\Microsoft\Office\11.0\Word\Options /v NoReReg /t REG_DWORD /d 1
 
reg add HKCU\Software\Microsoft\Office\12.0\Word\Options /v NoReReg /t REG_DWORD /d 1
 
That is it.  Office 2007 might want to have one more spin round the block with it's configuration dialog box, but that should be it. 

Open in new window

Nope, this is no good to me.

It works on the current user, as its for HKCU, but I want it to work for all users.

I wish microsoft would make life a little easier for people like us.

Commented:
Would you be able to check if this corrects your issue on at leat one system?
If it does correct the issue, this is something that is easily scriptable and can be run via logon script, GPO or even remote execution.
Well, I found one more global solution, seems to be a bit rough but it works.

Simple rename this file:

C:\Program Files\Common Files\microsoft shared\OFFICE12\Office Setup Controller\setup.exe

to something like setup.old incase you need it again. No more problems, and everything seems to work 100%.

I would like to run that registry hack via logon script but thats gonig to take a little work. I might be able to rename that file above via altiris in one big sweep, and then it would be once only.

Microsoft really needs to address this problem.

Commented:
JonothanPace's post above using the reg add command worked like a charm for me!
The fix to the problem is very simple as it turns out - simply run the following commands (by pressing the Windows Key+R or typing it into the Start/Run command box.  Use the line with Office\11.0 if you have Office 2003 installed and Office\12.0 if you have Office 2007 installed.  You can use both if you have both installed :
 
reg add HKCU\Software\Microsoft\Office\11.0\Word\Options /v NoReReg /t REG_DWORD /d 1
 
reg add HKCU\Software\Microsoft\Office\12.0\Word\Options /v NoReReg /t REG_DWORD /d 1

Open in new window

Thank you guys!! I looked for a solution to this at the beginning of the year, and couldnt find any...been sticking to office on my desktop mainly now because of it. Just on a hunch, I checked again, and you just saved my laptop from me throwing it at the fireplace!
Kudos! The d word solution fixed it!

Commented:
I have this problem recently. However, no one can give me a solution. Above solution is not working to me. Does anyone have other idea?  Or Do I need to provide more info?
This is obviously a bug in Office 2007 and it seems to be affecting a large number of users. I have recently come across it on two brand new Dell machines running Vista Home Premium and Office 2007 H&S.

The problem indeed seemed to occur after installing Office 2007 SP1 and was not solved by installing SP2. There is no Oulook in the H&S edition so no problems related to that but the config screen comes up every time an Office programme is opened from a start menu shortcut or by clicking on a file.

I uninstalled Office 2007 and reinstalled without the service packs and everything ran fine again. As soon as I added the service packs the problem returned.

I find it hard to belive that Microsoft cannot fix this issue which is generally driving people nuts. There are many solution suggestions out there but no one solution works for everyone and in many cases none of the solutions seem to work.

The closest hint we seem to have is that the registered location of the Office components may be incorrect. This is born out by the fact that all components open just fine when run from the Office12 installation directory in the Programme Files folder. Indeed many have created shortcuts from here as a workaround. Unfortunately this does not solve the issue completely and the configuration dialogue still appears if any of the Office programmes are opened by clicking on a user file.

Logically this must mean that there is nothing wrong with the Office compnents themselves but something very wrong in the way they are registered.

It is time that Microsoft got to the bottom of this once and for all. They have enough geniuses to call upon and I am sure if they all put their heads together we could have a patch for the problem very soon.
One other thing. I have seen several suggestions that this problem occurs primarily on Dell machines.

Dell do supply all their machines with a pre-installed 30 day trial version of Office and there seems to be a feeling that this configuration may be at the route of the problem.

Are there any non-Dell and non-trial version users out there who have had the same problems?
Serching through some of the other articles on this in EE I have noticed that the one sure way to solve the issue is to do a clean reinstall of Vista. Even on a new machine. After that it would appear that the problem does not return.

This would appear to add weight to the suggestion that somehow the initial configuration of the system (again many references to Dell) is to blame.
The only way I managed to fix it was to do a clean install of Windows XP or Vista. I Had tried everything.

For me, this involveld re-imaging the entire school, and creating over 10 new images.

Well done microsoft.
I was fortunate enough to work on a new Dell laptop yesterday. The client required an install of Office H&S 2007 and had purchased this separately on a disk.

To test a theory, I did not even open the trial version on the machine but instead removed it and then followed Microsoft's instructions for the manual removal of Office. This did reveal quiet a few lurking files even after running the uninstall.

Once I had removed the trial from the machine I then installed the full version from the CD and upgraded it to SP2. Lo and behold it works perfectly with no sign of the dreaded config screen.

My feeling is that Dell and others should avoid putting the Office trial on to new machines and let customers decide for themselves if they want to try it or not.

The preinstalled trial does seem to play a role in this and it would be great if Microsoft would take the time to recreate the problem and then fix it.
Uninstalling Office, then manually deleting what was left over as shown in the KB article, then re-installing Office did the trick for me.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.