WSUS 3.0 - Why storage space (10042) errors with plenty of space available on drive

I've been successfully running WSUS 3.0 for months now on my SBS2K03 (R1) box.  Recently I started getting 10042 errors ("There is less than 200 MB of free disk space on the content drive...").  There was, in fact, at least 30 GB of free space when this began, so I'm wondering how this limit is being determined.  I was looking around in WSUSUTIL but other than the ability to set the low space alarm thresholds didn't see anything that would impact this.  It looks like some content that should have come down didn't as a result of my not keeping an eye on this, so it's more than an eyesore in the Event log.  The troubleshooting section for 3.0 on the MS WSUS web appears to describe the disk space warnings based on actually having that little amount of space left on your drive.  Obviously, their recommendation to move the content would be well taken in that situation.  

I ran the Cleanup routine the other night to blow away some stale content.  Also, I do have Exec Software's Undelete 5 running and had forgotten to exclude the WSUS content sub/folders.  I blew away WSUS deletes that had been captured and updated the Undelete exclusion list to omit WSUS.  That bought me about 8 gigs.  When I ran a health check with wsusutil it then generated a 10041 error (500 MB threshold alarm).  Well, I suppose on some level that's....progress?  At this point, available drive space is just shy of 40 GB.  I've got an available slot on the server for another drive and considered getting one and moving only the WSUS content to there, but again, the OS is telling me there's way more than 200/500 MB of space available on the drive in question, so why should I have to bother.  Any insights into what's going on here?  Is there some app-specific 'measurement' being used by WSUS to determine if it has adequate room for update content that may be getting fouled somehow?  

Thanks for reading...
pierc2Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zak_McKrackenCommented:
This is generally caused by someone using a USB memory stick / HDD on the server, and not dismounting it correctly.
pierc2Author Commented:
Thanks, Zak.

Interesting.  Can you provide further details or point me to documentation on this (my initial searches in the MS Technet and KB didn't turn up anything on this particular issue with WSUS).  

It was my understanding, in the post Win2K world, that USB storage devices could safely be ejected without involving the 'safely remove hardware' function as long as they were configured properly with caching turned off.  

Now, that said, my backup and archiving process is based on eSATA and USB connections with SATA and PATA drives respectively connecting to the system in CRU cartridges.  I use Acronis True Image in combination with this and compared to the tape b.s. I had to deal with in the past its speed, reliability and ease of use (i.e. virtual drive feature) have made the process really enjoyable (as enjoyable as moving data can be, that is).  The only snag that has kept this system from being 100% flawless has involved the interaction of the eSATA controller with the WS03 OS.  I have no control over caching so I do not have the option to 'safely remove the hardware' and must simply turn off and remove the drives when there is no activity.  Since the drives are idle, they instantly disappear from the drive inventory and there is never any corruption but of course an error is always generated in the log indicating improper removal.  I communicated with 2 controller manufacturers about this.  One company in particular, who makes excellent controllers and other stuff that I've used with the Mac, acknowledged this problem in conjunction with WS03 and indicated they were having problems with MS giving them the necessary info to deal with it.  The other company, who offers a more 'generic' controller, responded that there was no way around it and to simply ensure the disk was idle before removing it.  So, granted, this is not the ideal, log-tidy scenario for removal but in every other aspect it has been working great (and I expected to find a solution down the road).

Obviously, I mention my eSATA glitch because of your comment about incorrect device removal.  However, its hard for me to believe there is a 1-to-1 relationship here given how this problem arose.  I was using SUS (2.0) fine&upgraded to v3&corrected the issue of not seeing some computers (because they were configured from an image)&and everything had been working fine for some time despite multiple insertions/removals of both USB and SATA drives before these storage space errors started appearing.  Also, WSUS content is stored on a RAID 1 mirror connected to an Adaptec zero-channel RAID card (in a SuperMicro SuperServer) and is completely separate from the eSATA controller and drives associated with the backup.

Hmmm&that last sentence made me realize something that should have been obvious but which I hadnt considered&that maybe something about how the arrays controller is writing the data is interacting with WSUS in such a way as to make it think there is less storage available than there is?  Sound possible?  I think Im going to move the WSUS content to a dedicated drive connected to the mobos built-in controller and see what happens.  

Once again, no success in the brevity department on my end.  Any other thoughts, including further illumination on the drive removal aspect, are appreciated.  Ill endeavor to use short and sweet bullets next time.
pierc2Author Commented:
Okay.  This goes in dumb oversight file, folks.  I had disk quotas set on the drive on which I'm storing the content.  I set it way back when.  Since this is the only SBS system I deal with and I do many other things I had forgotten about it.  Anyway, I'll watch the logs but at this point I feel I can safey assume this was the cause.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Zak_McKrackenCommented:
Ouch - Quota's are fun like that.  And whilst the USB drive won't cause this issue, it can cause low disk space errors in event logs / alerts.  Sorry - I must have completely missed the "WSUS" part :(
pierc2Author Commented:
No problem.  To be expected with all that description you had to wade through.  On the upside, just means I learned something else from the experience.  Thanks for the tip.

Anyone from EE monitoring this?  You can officially close it out.  Thanks.
Computer101Commented:
Closed, 500 points refunded.
Computer101
EE Admin
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.