Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 19690
  • Last Modified:

Remote desktop not working after a reboot on Windows 2003 Server

Has anyone seen this?  I have several Windows 2003 Server machines with remote desktop enabled on them.  After a windows update and a reboot remote desktop will no longer connect.  Another reboot and everything starts working.  This is bad for the developers working from home that need to reboot a server and then they can't get back in.  Any ideas?  Widnows 2003 with SP2
0
ewest111
Asked:
ewest111
1 Solution
 
zephyr_hex (Megan)DeveloperCommented:
do the servers have static ip addresses?
sometimes windows updates re-enable the windows firewall.  you might want to verify the firewall services is disabled.
have you checked Event Viewer to see if there are related errors?
0
 
ewest111Author Commented:
yes they all have static ip's.  If the firewall was being re-enabled by the update, why would another reboot allow remote desktop connections to start working again?
0
 
messen1975Commented:
I've had this problem for ages and I've tried everything that I can think of to get it to not function.

To put it simply we've made a "Rule" in the office that no one is allowed to reboot a server unless there is  someone here to manually reboot if RDP fails to start back up.

0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
ewest111Author Commented:
I'm quite sure that's not the answer the apps folks want to hear.  I was thinking about remote boot power strips to be able to reboot again remotely but those are so expensive.
0
 
messen1975Commented:
Your right -- A work around solution that I've thought of but haven't implemented:

Create a Scheduled Task that Reboots the Server.

RDP to Another Local Server that has share access with the Non-Responding Server and run the Reboot App.  

If you need source code I think I have some around here somewhere for C#.
0
 
ewest111Author Commented:
yeah I would appreciate that.
0
 
messen1975Commented:
This isn't exactly what you need -- but this is the logoff function that I use to log off users that leave work without logging off their PC's.


System.Diagnostics.Process.Start("shutdown -f -s -t 0");
   
0
 
BPiotrowskiCommented:
I was looking for a solution for quite a long time - here it is:
http://www.smallbizserver.net/Default.aspx?tabid=53&forumid=53&postid=58690&view=topic

Solution: Problem is not ISA Server it is the Terminal Services configuration on the ISA Server.
1. Open Terminal services configuration.
2. Hightlight Connections.
3. Right hand Pane right click default connection and select properties.
4. Select the network adapter Tab.
5. Make sure that Network Adapter that is selected is the Internal NIC.  It should not be configured to listen on all adapters.
6. Change and click on apply and OK
 
Close terminal Services manager and test RDP.

I had the same exact problem - I had to manually select the proper internal network card (one of two) - rebooted again using remote desktop - and issue resolved. Good luck.
0
 
MarketingDriveCommented:
Well, I tried the above solution (TS configuration) and now I can't get into the server with either RDC or VNC. VNC was working fine before this change.

Any reason why this would have started up all of a sudden across our network? This never happened before until about 2 weeks ago and it's affected at least 3 of our servers.
0
 
corptechCommented:
You can also do a remote shutdown from another server on the network.

shutdown /r /m \\computername /t 0
0
 
rg-xCommented:
We have experienced that doing Windows updates and rebooting from a non-console RDP session can result in RDP not working upon reboot.  If you use a console session it seems to work reliably.


fwiw
0
 
WPSLNetopsCommented:
I have the same problem.
If I reboot the server using RDP session, after that RDP does not work, but when I reboot the server SECOND time using shutdown command (I run it from the SQL session), the RDP starts work&
It is really pain in the ass&.
This server is not running ISA. It is just Database server.

Please advice.
0
 
Bergy10Commented:
I found one other solution which people may wish to try.
Control Panel - Add/remove programs- Add/remove Windows components.
Find the Internet Explorer Enhanced Security Configuration.
Click Details and untick the For Administrator Groups
Reboot
0
 
Symbian69Commented:
Thanks BPiotrowski!

I recently updated our Windows 2003 with latest patches and our Citrix PS 4.5 intermittently failed RDC after the scheduled reboot.

Terminal services configuration's Network Adapter was set to all NIC so I changed it to use the internal NIC and seem to have fixed the problem.

It's probably one of security patch that triggered this since I never had any issue prior to recent MS updates.

Thanks again for sharing!

Tom
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now