[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1207
  • Last Modified:

linux (redhat SE 4.0) eth0 connection goes to sleep.

Here is the environment - Redhat linux enterprise server 4.0 on a Dell power edge 2900 for web app.

I setup two net devices - eth0 & eth1 on separate vlan for multi-homing using ip_forward.  One goes to the outside internet while the other goes to the internal LAN.

Problem - Frequently it appears that eth0 goes to sleep (or dormant) and can not ping it from the network.  This is true even from the switch that its connected.   After the connection has gone to sleep, I can successfully ping from the server to the network.  Once I have pinged from the server to the network, I am able to ping from the network.  It has the behavior of going to sleep or powering off.  The other device, eth1, works fine, and stays up all the time as it should.  The problem is just with eth0.  Is there a power management feature in linux for net devices?

Thanks,
starfish2
0
starfish2
Asked:
starfish2
  • 3
  • 2
1 Solution
 
TintinCommented:
Run

ethtool eth0

and see what


Supports Wake on:
Wake on:

are set to.


0
 
starfish2Author Commented:
Thanks.

Both eth0 and eth1 are set to

        Supports Wake-on: d
        Wake-on: d
0
 
TintinCommented:
OK, so that means wake-on is disabled.

The next time eth0 goes to "sleep", do a:

ifconfig eth0

mii-tool -v eth0

arp -vn

and post the output.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
starfish2Author Commented:
Here is the output while eth0 goes to sleep on the linux server, and can not ping 10.1.2.15 (eth0) from the network.  As soon as I ping from the linux server to another ip on the network, such as 10.1.2.5 which pings ok, I can ping eth0 from the network.

At the bottom is the same output, but with eth0 awake and ping-able from the network.

Thanks for your input.


************ output when eth0 is asleep from the network *************************

[root@www sbin]# ./ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:18:8B:3E:94:B2  
          inet addr:10.1.2.15  Bcast:10.1.255.255  Mask:255.255.0.0
          inet6 addr: fe80::218:8bff:fe3e:94b2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:157761 errors:0 dropped:0 overruns:0 frame:0
          TX packets:86659 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:14128482 (13.4 MiB)  TX bytes:52588605 (50.1 MiB)
          Interrupt:169 Memory:da000000-da011100

[root@www sbin]# ./mii-tool -v eth0
eth0: negotiated 100baseTx-FD, link ok
  product info: vendor 00:08:18, model 54 rev 5
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD

[root@www sbin]# ./arp -vn
Address                  HWtype  HWaddress           Flags Mask            Iface
10.1.1.1                 ether   00:04:EA:68:EF:00   C                     eth0
10.10.20.118             ether   00:03:47:87:A5:06   C                     eth1
10.10.2.22               ether   00:03:BA:2C:B6:34   C                     eth1
Entries: 3      Skipped: 0      Found: 3



*************   same output when eth0 is awake and ping-able from network ********************

[root@www sbin]# ./ifconfig eth0                                                                            
eth0      Link encap:Ethernet  HWaddr 00:18:8B:3E:94:B2  
          inet addr:10.1.2.15  Bcast:10.1.255.255  Mask:255.255.0.0
          inet6 addr: fe80::218:8bff:fe3e:94b2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:159821 errors:0 dropped:0 overruns:0 frame:0
          TX packets:90269 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:14319235 (13.6 MiB)  TX bytes:54514940 (51.9 MiB)
          Interrupt:169 Memory:da000000-da011100

[root@www sbin]# ./mii-tool -v eth0                                                                    
eth0: negotiated 100baseTx-FD, link ok
  product info: vendor 00:08:18, model 54 rev 5
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD

[root@www sbin]# ./arp -vn                                                                                
Address                  HWtype  HWaddress           Flags Mask            Iface
10.10.1.1                ether   00:04:EA:68:EF:00   C                     eth1
10.1.1.1                 ether   00:04:EA:68:EF:00   C                     eth0
10.10.20.118             ether   00:03:47:87:A5:06   C                     eth1
10.1.2.5                 ether   00:06:5B:F0:C4:08   C                     eth0


0
 
TintinCommented:
Presumably 10.1.1.1 is your default gateway?

I can't see anything obvious to me that would be causing the problem.  The only other thing I can think of is to see what traffic (if any) eth0 can see when it goes to sleep.  Try running

tcpdump -i eth0
0
 
adevillaineCommented:
I'm having the same problem here, there was any solution for the problem exposed by starfish2?
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now