email to browser linkage

I have a client's machine on my bench which will not open a browser with a link from email (Firefox and Tbird),  I have checked target addresses, file associations and  registry settings (all at default ) that I know of.  I have reinstalled both Firefox and Thunderbird as well as removing and reinstalling IE7.  I'm currently at my wits end.  Can you give me a fresh idea or two?
TIA, Pliny
PlinyAsked:
Who is Participating?
 
war1Commented:
Pliny,

The link is in an email in Tbird.  You cannot open link to Firefox.  The problem seems to be in Tbird.

1. Make IE7 the default browser.  Will link open IE7?

2. If no joy, Launch T-bird and select Edit ->Preferences
Go to the far right and click Advanced then at the bottom of the window Advanced Configuration and click the button Config editor
In the about:config window that comes up put in network in the filter box
scroll down to protocol-handler.app
and make sure that ftp http and https are set for string and mozilla-firefox

3. If no joy, create a new Tbird profile
http://www.mozilla.org/support/thunderbird/profile
0
 
war1Commented:
Greetings Pliny !

You may need to register some dll files
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q281679&sd=tech
1. Quit all programs that are running.
2. Click Start, and then click Run.
3. Type regsvr32 urlmon.dll, and then click OK.
4. When you receive the "DllRegisterServer in urlmon.dll succeeded" message, click OK.

If this does not resolve the problem, repeat steps 2 through 4 for each of the following files (in step 3, replace Urlmon.dll with each of the file names below):

Shdocvw.dll
Actxprxy.dll
Oleaut32.dll
Mshtml.dll
Browseui.dll
Shell32.dll

Hope this helps, war1
0
 
PlinyAuthor Commented:
Sounds like a great idea war1.  I tried the first without success and then continued per your instruction.  All of the registrations went well except for "mshtml.dll".  The problem still exists.  Following is the message returned from the attempt to  register mshtml.dll:

Mshtml.dll was loaded, but the DllRegisterServer entry point was not found.                                         The file cannot be registered

Perhaps the answer to this might lead to the solution of the other problem?
Thank you,  Pliny
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Marc ZCommented:
I'm with war1 on thie one.  Sounds like an issue with the profile of Thunderbird.  Before you create a new profile, try running it in Thunderbirds Safe Mode  to see if it will work.
http://kb.mozillazine.org/Safe_mode

If it works there, you may be able to just reset defaults to overcome the issue.
0
 
PlinyAuthor Commented:
war1,
No joy - This is Tbird 2.0.0.6 (ff2.0.0.7) and there is no "preferences" in the edit menu .    
I have not yet tried the new profile but will soon.
-
mtz1of4,
Tbird still fails in safe mode

Thank you both
       
0
 
PlinyAuthor Commented:
war1 - Hi again
I found the process you suggested.  It is now under tools>options.  In the network portion of the list,
the only references to http et al, were  - protocol-handler.warn-external.ftp   ...http  ...https
They were all marked: default false  
I found the same values in a working machine

I set up another profile but can't test it until I get my client's password to complete the configuration
I'll stick to this until it's solved.  Thanks for your help, Pliny
0
 
war1Commented:
Pliny, let us know when you get a change to test the new profile.
0
 
PlinyAuthor Commented:
Still no joy - I successfully created a new profile which behaves the same way as the original.  Over the weekend I reloaded XP (repair), and after surviving the update problems, found the same results.  Summary: Windows reloaded - Firefox reloaded - Tbird reloaded - File associations re-evaluated - blah, blah, blah.   Somewhere along the line I have missed something because it still doesn't work.  When I click on the hyperlink(?) in the email, it changes color for the duration of the click, and nothing else happens.  I appreciate you staying with me on this.  Pliny
0
 
Marc ZCommented:
So a Repair of XP doesn't help?  Have you backed up all their important data?  

You may need that reinstall.

But before you do that,  Pliny, have you tried creating a new Windows Profile and testing it?
0
 
PlinyAuthor Commented:
I just now tried a new user profile, but got the same results.  Du you think that it is time for the final draconian step?
0
 
war1Commented:
Yes, it is time for reinstall.
0
 
Marc ZCommented:
I agree with war1.  If a New windows profile is exhibiting the same issue, it's a windows problem.  You've probably already done it by now, but a list of security programs installed wouldn't hurt, and maybe even a hijackthis log, if you haven't done the reinstall yet.  A reinstall would be the fastest fix but also do the most damage to the customer's settings.
0
 
PlinyAuthor Commented:
I have just discovered, while again perusing the Folder options, that URL:hyper text transfer protocol (with an extension of NONE (IE icon)  yields, with the advance button, a n action of "open" on a working machine.  On the subject machine there are no actions listed and when I click "new" a dialog opens asking me for action and application used to perform this action.  I don't know how to answer the application part.  I'm hoping this may be relevant(?)    TIA Pliny
0
 
Marc ZCommented:
Ah, so we don't have a default browser set, huh?

This is how  I confirm that Firefox is set as default here.

Open My Computer, select Tools->Folder Options->File Types.
Scroll through list to find these and make sure Firefox (or whatever browser you desire) is set as default:

     URL:HyperText Transfer Protocol
     URL:HyperText Transfer Protocol with Privacy
     URL:File Transfer Protocol
     HTML File
     HTM File (optional)

Note that you may find the URL file types above under extension "N/A" or "(NONE)".

You may need to hit the Advanced button and make sure DDE is unchecked, also.

For you direct above question, The Application Part should allow you to Browse to c:\program files\mozilla Firefox\firefox.exe
or c:\program files\internet explorer\iexplorer.exe

0
 
PlinyAuthor Commented:
Joy, joy, joy!  All is well with the world again.  When I reported that I had changed the default browser  (back and forth), I assumed (we all know what that means) that modifying the properties on the start menu would actually change the default.  I guess there has to be a default before it can be changed.  The mystery at this point is: how did the default get reset.  My client said that out of the clear blue sky it stopped working about a month ago(???)  It isn't the first, nor will it be the last unsolved mystery.

War1 and mtz1of4, thank you both for staying with me on this one. I can't decide how to divide the points so each of you will get 250.
Best regards,  Pliny
0
 
Marc ZCommented:
Glad it's working.  Thanks for the updates.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.