We help IT Professionals succeed at work.

IIS Restart on Exchange server flushes queue of old emails and NDR's?

1,310 Views
Last Modified: 2008-01-09
Hi,

I have just added a site to my IIS on the exchange server. As a result I had to restart the iis. This seemed to flush out a huge email queue of old emails and NDR's - 2 months worth and I am wondering where this would be. I dont think this is coincidence as just after I restarted IIS I had a number of calls from users alerting me to this fact. I often look at the queues in system manager  and there is sometimes one or two in there which I flush out but never this amount.

Do you know what queue this is? What are all the queues that I should actively monitor to make sure this does not happen again? Why are NDR's and emails (seems like only to certain companies) getting caught up and why is there no notification to this?

I really need to make sure this does not happen again.

Many Thanks,
Neil
Comment
Watch Question

Expert of the Year 2007
Expert of the Year 2006

Commented:
It is one of two things.

1. Either something that AV software has been storing and the reset has released the content.
2. The greylisting bug.
The greylisting bug only as a work around which is this registry setting:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Queueing]
"GlitchRetrySeconds"=dword:00000078

Simon.

Author

Commented:
Hi Sembee,

Thanks for the reply.

I do not have any AV running on the exchange server. The only two things which may be affecting it are:
1. Symbari Antigen
2. Lucid8 Digivault
I would probably say Antigen is the most likely culprit but I must admit I dont really know my way around this app.... All internally bound email is processed by mailprotector.net (an external spam and virus company) and then by Antigen. All outbound email which seems to be the cause only touched antigen on the way out........ does it have its own queue that I dont know about?

Digivault is just exchange realtime backup so dont think that will affect it in any way.

I also checked the greylisting reg entry but did not evern have Queueing under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC

Many Thanks,
Neil
Expert of the Year 2007
Expert of the Year 2006
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Sorry,
I have implemented the above as well as putting in a batch to restart the smtp service every evening at 6, I havent heard anything from the users yet but it is pretty difficult to determine if this has indeed fixed it. In any case I agree that all points go to Sembee!

Many Thanks
Forced accept.

Computer101
EE Admin
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.