SQLEXPRESS trusted connection issue

Well, here I am again with an SQL connection problem :) This time I can't connect SSMS to SQLEXPRESS using SQL Auth (instead of Windows auth, which works). I've set SQLEXPRESS to allow remote connections through TCP and N/Pipes, tried SA and even added a new sysadmin account mapped to a specific db. I always get "the user is not associated a trusted SQL Server" connection error. Appreciate any suggestions. Thanks in advance.
cwest1Asked:
Who is Participating?
 
fmonroyConnect With a Mentor Commented:
right click the server, properties, security... what's selected there?
0
 
fmonroyCommented:
Is the "SQL Server Browser" service at the server running?

Have you restarted the SQL Express service since you changed to mixed authentication?

Has the account you are using the enough privileges on server and database?
0
 
cwest1Author Commented:
yes, yes, and I would have thought the SA user had adequate perms. I'm unsure how to check though.
0
Simple Misconfiguration =Network Vulnerability

In this technical webinar, AlgoSec will present several examples of common misconfigurations; including a basic device change, business application connectivity changes, and data center migrations. Learn best practices to protect your business from attack.

 
fmonroyCommented:
oh, using SA, this user has full access as default, sometimes it's disabled, have you checked it?
0
 
cwest1Author Commented:
login is enabled for SA
0
 
fmonroyCommented:
check SA user mapping... at SA properties
0
 
cwest1Author Commented:
SA is mapped to master (and other dbs that are standard) as dbo
0
 
fmonroyCommented:
is it mapped to the default database you are connecting to?
0
 
cwest1Author Commented:
No. Create fails. Cannont use special principal SA. SQLEXPRESS isn't letting me map SA to new dbs.
0
 
fmonroyCommented:
Ok, create another user, give full access to it to test (at server and new db) then try to make a connection with the new user.
0
 
cwest1Author Commented:
I tried that before posting. Added user SA2, mapped to mydb as dbo, same error. One thing I just noticed when loking at SA properties, SQL Authentication is grayed out in the status window. That is, it can't be selected. I suspect that might be a registry setting, but I don't know where.
0
 
cwest1Author Commented:
Oh shxx. Mixed mode wasn't selected. Duh. I was assuming that allowing remote connections implied SQL Auth. It never occurred to me that you'd connect remotely with a windows account. Thanks for the guidance. Much appreciated.
0
 
fmonroyCommented:
You're welcome
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.