Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 601
  • Last Modified:

Internet connection - 2 networks connected bypoint to point T1

Network setup & Problem:

1.      192.168.1.? and 192.168.2.?  both using Linksys WRT54G routers out to internet. Originally completely independent networks.
2.      Networks now connected using a point to point T1
a.      Cisco 1841 Routers, IP addresses 192.168.?.239
3.      Configuration for first 1841 above, second identical except for actual network addresses and it is not set up to clock.
4.      On the 192.168.1.? network each PC is setup with a gateway address of 192.168.?.1 out to internet and static route 192.168.2.0 mask 255.255.255.0 192.168.1.239 to allow traffic though the T1 and the reverse on the second network.
5.      All works fine each PC can talk to all PCs on both network.
6.      From 192.168.1.0 network I can ping any device on the second network EXCEPT the router at 192.168.2.1. I can ping this router from any PC on the 192.168.2.0 network. Also this is the case in reverse from the 192.168.2.0 network. This does not make any sense to me!

Now I need to eliminate one of the Internet gateways to reduce costs and set up a single Internet connection at 192.168.2.1 which is accessible from the 192.168.1.0 network. I cant even start to do this since I cant talk to the router from the second network. It looks like there is a problem with the Cisco 1841 setup, but any suggestions will be appreciated.

1841 Router config

PtLakeView#show run                  
Building configuration...                        

Current configuration : 2244 bytes                                  
!
version 12.4            
service timestamps debug datetime msec                                      
service timestamps log datetime msec                                    
no service password-e                    
!
hostname PtLakeView                  
!
boot-start-marker                
boot-end-marker              
!
logging buffered 51200 warnings                              
!
no aaa new-model                
!
resource policy              
!
mmi polling-interval 60                      
no mmi auto-configure                    
no mmi pvc          
mmi snmp-timeout 180                    
ip subnet-zero              
ip cef      
!
!
no ip dhcp use vrf connected                            
!
!
ip domain name yourdomain.com                            
!
username cisco privilege 15 secret 5 $1$2ImQ$/EaEHh6uvDpvF.EzBUhgG/                                                                  
!
!
!
interface FastEthernet0/0                        
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$                                                    
 ip address 192.168.2.239 255.255.255.0                                      
 duplex auto            
 speed auto          
!
interface FastEthernet0/1                        
 no ip address              
 shutdown        
 duplex auto            
 speed auto          
!
interface Serial0/0/0                    
 ip address 10.10.20.2 255.255.255.248                                      
 service-module t1 clock source internal                                        
 service-module t1 timeslots 1-24                                
!
router rip          
 version 2          
 network 10.0.0.0                
 network 192.168.1.0                    
 network 192.168.2.0                    
!
ip classless            
ip route 0.0.0.0 0.0.0.0 10.10.20.1                                  
ip route 192.168.1.0 255.255.255.0 10.10.20.1                                            
!
ip http server              
ip http access-class 23                      
ip http authentication local                            
ip http timeout-policy idle 60 life 86400 requests 10000                                                        
!
access-list 23 permit 10.10.10.0 0.0.0.7                                        
!
control-plane            
!
banner login ^C              
-----------------------------------------------------------------------                                                                      
Cisco Router and Security Device Manager (SDM) is installed on this device.                                                                          
This feature requires the one-time use of the username "cisco"                                                              
with the password "cisco". The default username and password have a privilege le                                                                                
vel of 15.          

Please change these publicly known initial credentials using SDM or the IOS CLI.                                                                                

Here are the Cisco IOS commands.                                

username <myuser>  privilege 15 secret 0 <mypassword>                                                    
no username cisco                

Replace <myuser> and <mypassword> with the username and password you want to use
.

For more information about SDM please follow the instructions in the QUICK START

GUIDE for your router or go to http://www.cisco.com/go/sdm
-----------------------------------------------------------------------
^C
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
!
end

PtLakeView#

0
derekshall
Asked:
derekshall
  • 3
  • 2
1 Solution
 
avilovCommented:
what routes defined on the second router?

on the first one we have

ip route 0.0.0.0 0.0.0.0 10.10.20.1                                  
ip route 192.168.1.0 255.255.255.0 10.10.20.1              

that means that everything goes to the other end
0
 
derekshallAuthor Commented:
Hi,
The second router is the reverse of the first i.e.

ip route 0.0.0.0 0.0.0.0 10.10.10.1                                  
ip route 192.168.2.0 255.255.255.0 10.10.10.1          

and also the PCs have  the static route 192.168.1.0 mask 255.255.255.0 192.168.2.239.

My understanding is that this directs anything from network 1 through to network 2 and vice versa. Does that make sense?
0
 
avilovCommented:
you do not need the default router on PCs

you need change a little routes on routers tho

something like that

ip route 0.0.0.0 0.0.0.0 192.168.?.1
ip route 192.168.2.0 255.255.255.0 10.10.10.1

on the second one , and


ip route 0.0.0.0 0.0.0.0 192.168.?.1                                
ip route 192.168.1.0 255.255.255.0 10.10.20.1        
on the first one

that should cover all your routes.      

0
 
avilovCommented:
sorry I am tired a little. you need to set default gateway to the router interface ip in that subnet

for example

in the 192.168.2.0/24 subnet, you set the default gateway on PCs to 192.168.2.239
0
 
derekshallAuthor Commented:
Needed to setup specific routes in the Linksys router. Nobody, including Cisco, understands why!
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now