We help IT Professionals succeed at work.

IGRP does not show up in my Cisco 2600

warriorfan808
on
1,353 Views
Last Modified: 2008-01-09
Hey guys,

I'm working on an IGRP lab for my CCNA.  I set up IGRP on one of my routers and everything went fine, but the other didn't.  If you see below, I tried to make an autonomous system 101 and it gave me an error.  I later did a question mark to see if IGRP is available and it doesn't. There's the OSI version, but I wanted to use the Cisco version.

GAD(config)#router IGRP 101
                    ^
% Invalid input detected at '^' marker.

GAD(config)#router ?
  bgp       Border Gateway Protocol (BGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  rip       Routing Information Protocol (RIP)

GAD(config)#router
Comment
Watch Question

Commented:
what is the IOS version?

you probably have an image that doesn't have support for EIGRP
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
This is what I get
ROM: C2600 Software (C2600-IPBASE-M), Version 12.3(6e), RELEASE SOFTWARE (fc3)

GAD uptime is 26 minutes
System returned to ROM by reload
System image file is "flash:c2600-ipbase-mz.123-6e.bin"

Author

Commented:
would copying over the startup config on the router that does have IGRP into the other router work or will I need to do that with the IOS image using tftpdnlp?
Les MooreSystems Architect
CERTIFIED EXPERT
Top Expert 2008

Commented:
12.3 does not support IGRP. IGRP has been deprecated long time ago and is no longer supported. Use EIGRP with the same AS number and it works

R1
 router igrp 101

R2
 router eigrp 101

They work together.

Author

Commented:
I guess I just got lazy.  I ended up grabbing a router that had igrp on it.  Do you know where i can go to download an IOS that you know that has IGRP?  EIGRP works, but my lab asks me to run some debug commands.  I want to make sure that I'm following it precisely.

Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Instructor
CERTIFIED EXPERT
Top Expert 2015
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.