Mac OS X can't see Windows shared files on domain controller, pls help!

I have a Windows 2003 file server (and is a domain controller) that I'm having a hard time getting to from a Mac OS X laptop. I found a solution to loosen my Windows security which did allow the Mac to fiew the shared files, but I can't be lowering my security on my Windows server just so Mac's can view the files. What do I have to do on the Mac for it to work?

To help illustrate what's going on, this is what I did to the Windows server for it to work (which I then reversed it because it made me nervous):

"Windows Server 2003 Authentication
By deafult Windows Server 2003 will try to encrypt everything sent to and from it. With this enabled you will not be able to log in to the share from your Mac.

To fix this there are a couple of options.
Case 1, your server is nothing more than a regular file server. In this case open up regedit (Start > Run > "regedit" {return}), and navigate to HKEY_LOCAL_MACHINE \ System \ CurrentControlSet \ Services \ LanManServer \ Parameter \ RequireSecuritySignature, and set it's value to "0".

Case 2, your server is also a Domain Controller. In which case you need to open the DC's Security Policy (Administrative Tools > Domain Controller Security Policy). Navigate to Local Policies > Secuiry Options, and disable "Microsoft network server: Digitally sign communications (always)" & "Microsoft network server: Digitally sign communications (if client agrees)". Reboot your sever, and you should be good to go."
Who is Participating?
LauraEHunterMVPConnect With a Mentor Commented:
The steps you've described are what you need to do - depending on the revision of OSX they're running, you might also need to disable SMB signing.  

If lowering your security to allow Macintosh access isn't acceptable to you, then your Mac users are out of luck.  (I spent years in higher ed and had to lower that security setting on every AD network I administered because the Mac users were higher up the food chain than I was.  Drove me up a wall. If you can tell them 'No', I envy you for it.)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.