Link to home
Create AccountLog in
Avatar of foxbyte
foxbyteFlag for United States of America

asked on

Exchange 2003 additional email address doesn't arrive at external destination any more.

I added an additional email address to a user in AD on an Exchange 2003 server. Things went smoothly for a while, then the email (to gmail.com) stop arriving at the Google destination. I've received delivery receipts which stated that the email was delivered and it appears sent. But it never shows up in the person's google inbox. I can successfully send an email from our email server, directly to the recip @ gmail.com, but when that address is used in Exchange AD as a secondary email addy, it only arrives in our internal email and never makes it out to Gmail. No error messages, no failed delivery notifications. But it just doesn't seem to want to share addys in this persons account. I have my own email server, a DNS host and an ISP. As stated, it worked at one time for me. I can successfully send email to this person@gmail.com if I enter the addy manually. But the email never shows up in their external (gmail.com) only in our internal email. Any theories? Any suggestions?
Thanks!
Avatar of Sembee
Sembee
Flag of United Kingdom of Great Britain and Northern Ireland image

Does message tracking show the message being sent?
There is a good chance that Google are blocking the traffic as it will appear to be spoofed.

Simon.
Avatar of foxbyte

ASKER

Simon:
Yes. The message shows as having been delivered. I can even get a delivery receipt on it. But it never apprears in the recipients gmail when I'm trying to send via additional addy in AD email addresses properties. I can send email to the recipient if I manually typing in his gmail addy, however. What's bizarre is this: if Gmail is blocking it from my server as a spoof (and I've contacted my name host and ISP re: SPF and reverse DNS) why would it allow me to send it successfully one way and not the other?
Thanks, Simon. If anything comes to mind...I welcome it.
The reason that it is being blocked one way and not the other is because when you send the email directly you are not spoofing.

When the message is forwarded by Exchange, the headers stay almost intact. That can mean the message appears to be coming from another domain.

For example the sender is on Hotmail. Sends to your server, which then forwards it on. The message still appears to come from Hotmail, but not from one of Hotmail's servers.

Automatic forwarding from Exchange is becoming something that doesn't work for many people to many sites for just this reason.

Simon.
Avatar of foxbyte

ASKER

If I understand you correctly...and I do appreciate your attention on this,...there is no solution exactly. There's an unaddressed flaw in Exchange's auto forwarding? If so, then it's a matter of hoping that Microsoft comes up with a patch or an update to fix it beyond SP2?
ASKER CERTIFIED SOLUTION
Avatar of Sembee
Sembee
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account