Problems running eseutil /r

Hello,

I have corrupted databases.  I ran eseutil /d and it tells me to run a /r.  when I try running the /r I get the following error:
E:\EXCHSVR\BIN>eseutil /r e:\exchsvr\mdbdata\priv1.edb /l e:\exchsvr\mdbdata /s e:\exchsvr\mdbdata
Initiating RECOVERY mode...
    Logfile base name: e:\exchsvr\mdbdata\priv1.edb
            Log files: e:\exchsvr\mdbdata
         System files: e:\exchsvr\mdbdata

Operation terminated with error -1003 (JET_errInvalidParameter, Invalid API parameter) after 0.47 seconds.

I have tried it several different ways and I am unsure what the issue is.  Please help!!!
Kenneth_CrawfordAsked:
Who is Participating?
 
Veerappan SundaramConnect With a Mentor Senior Technical ConsultantCommented:
In the syntax you need to specify the log file
ESEUTIL /R E00 /Ld:\exchsrvr\logfiles

>>>> Veera.
0
 
Veerappan SundaramSenior Technical ConsultantCommented:
If you have a corrupted database, what is the error message you get when you try to mount the stores?
Else check in event logs for possible errors and the Hex code.
How about the Transaction Logs - are they in good condition?
Based on that only you need to decide the the level of corruption. Then proceed according to the corruption level.
If you have latest successful online full backup, then restore it to RSG and recover.
Else you can use eseutil /P which is not suggested.
Have a look at this link:  http://technet.microsoft.com/en-us/library/aa998075.aspx

>>>> Veera.
0
 
barrymulhollandCommented:
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.