?
Solved

Cisco VoIP QoS

Posted on 2007-09-30
8
Medium Priority
?
3,550 Views
Last Modified: 2011-04-24
Hi,

I have configured QoS on my Cisco 1721 for VoIP - the only problem is, it is only working for the outbound side of the call. So the person I call can hear me perfectly (QoS is working), but I cannot hear them very clearly when someone downloads something on the internet (QoS isn't working). I have enabled a "service-policy outbound VoIP-QoS" on the dialer, however I cannot seem to do it as "service-policy inbound VoIP-QoS" I get an error when I try to apply that. Does anyone have any ideas how to fix this?

Thanks

Mark
0
Comment
Question by:mark_06
  • 3
  • 3
  • 2
8 Comments
 
LVL 2

Expert Comment

by:netman42
ID: 19997915
Mark,
What size pipes are you using between sites and are you doing anything with your provider as far as prioritizing the voice traffic? Are you using Diff-Serv to mark the expedited voice traffic? Can you post a portion of the config so we can take a look at it?

Thanks,
Netman42
0
 
LVL 6

Author Comment

by:mark_06
ID: 20004674
Hi,
I am using 512k (sym) DSL pipes bonded, its the fastest we can get. I have asked the ISP to pritoritise the voice traffic, whether they have or not, or at least as of yet. I am marking all the rtp audio packets with"dscp ef" on its way out. I am also using nbar, to detect the packets.

Here is the relevant config:
!
class-map match-any VoIP
 match protocol rtp audio
!
!
policy-map VoIP-QoS
 class VoIP
  priority percent 70
  set dscp ef
 class class-default
  fair-queue
!
!
!
interface Dialer3
 bandwidth 512
 ip address negotiated
 no ip proxy-arp
 ip nbar protocol-discovery
 ip load-sharing per-packet
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 load-interval 30
 dialer pool 3
 dialer-group 3
 no cdp enable
 ppp authentication chap callin
 service-policy output VoIP-QoS
!
interface Dialer4
 bandwidth 512
 ip address negotiated
 no ip proxy-arp
 ip nbar protocol-discovery
 ip load-sharing per-packet
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 no ip mroute-cache
 load-interval 30
 dialer pool 4
 dialer-group 4
 no cdp enable
 ppp authentication chap callin
 service-policy output VoIP-QoS
0
 
LVL 2

Expert Comment

by:netman42
ID: 20005545
In my case, to ensure that I was marking traffic, I had to use a sniffer and capture the traffic from phone switch to phone switch to make sure that EF gets marked all the way through. Often times, I would find where I left out a switch port or something with no QOS configured. Does your phone switch initiate any way to mark packets as EF right out of the switch? If not, does your switch configs have qos applied to the ports where your phone equipment is? What is the size of the stream you are paying for with the ISP's CAR?

Thanks,
Netman42
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 12

Expert Comment

by:benhanson
ID: 20012511
This is generally referred to as One way voice, have you checked out Cisco's troubleshooting doc for this?

http://www.cisco.com/warp/public/788/AVVID/fix_1way_voice.html

A bit dense, I know . . .
0
 
LVL 12

Expert Comment

by:benhanson
ID: 20012514
Sorry, it's late and I misread your question.  Ignore that post!
0
 
LVL 12

Accepted Solution

by:
benhanson earned 1500 total points
ID: 20012518
Here is my canned cisco VOIP QOS config:

!
class-map match-all VOIP-Control
  match access-group 101
class-map match-all VOIP-RTP
  match access-group 100
!
!
policy-map QOS-to-T1
  class VOIP-RTP
   priority 600
  class VOIP-Control
   bandwidth 200
  class class-default
   fair-queue
!
!
!
! IIRC This policy map is to retag data after going over a link that was not guaranteed to maintain cos/tos bits.
!
policy-map L3-to-L2-VOIP
  class VOIP-RTP
   set cos 5
  class VOIP-Control
   set cos 3
!
interface FastEthernet0/0
 no ip address
 no ip mroute-cache
 speed auto
 full-duplex
 no cdp enable
!
interface FastEthernet0/0.1
 description Data_Subnet
 encapsulation dot1Q 1 native
 ip address 10.0.0.1 255.0.0.0
!
interface FastEthernet0/0.2
 description Voice_Subnet
 encapsulation dot1Q 2
 ip address 192.168.x.1 255.255.255.0
 service-policy output L3-to-L2-VOIP
 no ip mroute-cache
!
interface Serial0/0
 description HDSL T1
 ip unnumbered FastEthernet0/0.1
 service-policy output QOS-to-T1
 no ip mroute-cache
 no shutdown
 no cdp enable
!
!
access-list 100 permit ip any any precedence critical
access-list 100 permit ip any any dscp ef
access-list 101 permit tcp any any range 2000 2002
access-list 101 permit tcp any any eq 1720
access-list 101 permit tcp any any range 11000 11999
access-list 101 permit udp any any eq 2427
access-list 101 permit tcp any any eq 2428
!
!
!

0
 
LVL 6

Author Comment

by:mark_06
ID: 20046900
Hi,
Sorry for not posting - i am still waiting on the ISP to confirm the QoS on their side, they are being a real pain!
Is the way I am doing the QoS from my end ok? or should I do it a different way?
Thanks
Mark
0
 
LVL 6

Author Comment

by:mark_06
ID: 20046943
BTW - I am running asterisk as my VoIP System.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question