Some external emails cannot be opened (Exchange 2003)

Posted on 2007-09-30
Last Modified: 2008-01-09
After an Windows Upgrade on my Server 2003sp1/Exchange 2003sp2 I cannot open certain emails anymore. In the preview pane they come up as "this item contains active content that cannot be displayed in the preview pane". When I try to open it, I get "Can't open this item. Could not complete the operation. One or more parameter values are not valid."
I tried uninstalling all the installed updates, but no effect. I tried disabling the virus scanner (F-Secure), still no effect. Confirmed that the MSExchangeIS\VirusScan\Enable value is 0. Uninstalled the virus scanner completely. Still no effect. I did a "isinteg -fix -test alltests". It found some warnings, but the problem is still there.
To troubleshoot further, I created a new Storage Group with a new Mail Store and move one account to it. I can see the emails now, but the "From:" field is empty. When I press reply, the email address does show up. If I move the account back to the default Store, the emails are again impossible to open.
All the emails that are affected are from the outside (internet). They all have only an email address in the Internet header "From:" field ([From:]). Emails that have [From: "sender" <>] can be opened without a problem. Intelligent Message Filtering is turned off on the Default SMTP Virtual Server.

Does anyone have any idea what might be going on?
Question by:woutervw

    Author Comment

    I just tried to open one of the problem messages with MDBVU32, and it gives me this error:

    m_lpEntry->GetProps(): MAPI_E_INVALID_PARAMETER

    Accepted Solution

    I got the similar problem after a patch upgrade.  After I read the microsoft support article 934450, I uninstalled the hotfix 931832.  The problem was then solved.

    Author Comment

    I just installed the Hotfix yesterday evening before I read your reply. All emails are accessible again and mailflow has been restored.

    Author Comment

    I misread your reply. I actually had to apply KB934450 in order to get rid of the problem. I had tried uninstalling 931832 already with no result.

    Expert Comment

    In fact, I have also submitted request to Microsoft for the hotfix.  Do you get the hotfix KB934450?  Where can I get it?

    Author Comment

    I just requested it through and got it the next day.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
    Easy CSR creation in Exchange 2007,2010 and 2013
    In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
    This video discusses moving either the default database or any database to a new volume.

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now