We help IT Professionals succeed at work.

GIgaByte BIOS won't recognize RAID 0 array

punkindrublik
on
679 Views
Last Modified: 2013-11-14
I'm trying to install XP Pro onto a RAID 0 array but I can't get the BIOS to recognize it.
MB - GigaByte GA-81915P DUO A
RAID Controller - Silicon Images
RAID Driver - SiI RAID 5
Drives - 2x 80gig WD 800JD

I can enter the Sil RAID Utility and create an array, I just can't get the BIOS to recognize it. I can also see the array (160gig) in Disk Manager(when running xp on seperate drive) but am unable to format.

Help! Any info appreciated!!

Thanks

Brian
Comment
Watch Question

Commented:
The motherboard BIOS won't recognize the RAID drive. Have you installed F6 drivers during XP setup?

Author

Commented:
Yes I did. I even tried reinstalling them with the .exe file while running on another disk.
I'd like to use the PCI-x SiI controller. I was running RAID on this exact system before I decided to reinstall XP.
I even tried everything I could with the onboard RAID as well. No luck :(

Commented:
What about SiI controller BIOS -- is RAID array set and healthy?

Since I don't understand about .exe driver installation, explain how you attempted to install F6 driver and what happens. Driver should be about 5 or 6 files on a floppy disk.
Please explain how the motherboard BIOS doesn't recognize the RAID drive.  Does it not show the Silicon Image BIOS at all during the POST?  If not, maybe you chould check your motherboard BIOS's settings again -- usually there's a place to enable or disable the various onboard cards and/or their BIOSes.  There's also usually a place in the BIOS to enable/disable the RAID functionality of the primary controller, if it supports RAID.

If it shows the Silicon Image BIOS during the POST, but doesn't show the connected drives at that point, I'd say it sounds like the drives are not connected properly.  It should ALWAYS show the drives at this point, if you see the Silicon Image BIOS.

Assuming you know how to use the F6 driver disk correctly, I'd enter the Silicon Image RAID BIOS and check that a RAID array has been created, or recreate the array.  Perhaps that's your problem, and so Windows doesn't see any drives because there are no arrays created in the RAID BIOS.

If everything looks good up to that point, then the motherboard is seeing the RAID array fine.  Windows XP has the problem and you should check the drivers on the "F6 driver disk" that you are using again.  You have to create a floppy disk with the proper drivers beforehand, and press F6 during the first part of the setup (it will display a message at the bottom of the screen) to let XP know that you have a disk with special drivers on it.  Then, when prompted, insert the disk and select the proper driver off of the disk.  Sometimes this can be quite troublesome, as one floppy might have more than one driver on it, or you might not know which drivers XP is looking for, or you can't find the "F6 driver disk" when you do have the proper Windows drivers.  Note that Windows won't tell you if you load the wrong drivers -- you just have to wait until you get to the screen to select the hard drive, and there won't be any in the list.

By the way, while installing XP, disconnect any USB cardreaders you have, because if you don't, often your primary hard drive will be G: or some such thing, instead of C:

Author

Commented:
Thanks for the replies guys...

When I was booted on another drive, I was able to run the .exe file that installs the RAID drivers. I used the F6 install as well.
Now that my drives aren't being recognized at all windows, how can I do the F6 install without a 3rd drive??

I enabled "RAID" in Integrated Periferals when trying the onboard controller and tried it in both modes when trying to use the card.

I am able to get into the Sil RAID Utility at boot up and create the array no problem. When it contues, the Sil BIOS shows both drives and the array, but the drives/array aren't recognized by Windows.
I will try a different driver to see if that makes a difference. I've tried the only two I could find that were applicable since I didn't get an installation disk with the card.
I think that covered everything you asked.

The crazy thing is, this was all working perfectly until I tried the XP reinstall :(

Thanks again...

Brian

Author

Commented:
Oh, as to what happened when I did the F6, I just hit the button at the correct time, and when it was done loading files, it asked for the floppy, popped it in and setup continued.
But now that XP doesn't see a drive to start setup on, using F6 now is kinda tough. That's why I tried using the exe file when I was running XP on a 3rd drive.

Commented:
Were you prompted to select a driver during setup (screen with list of drivers -- usually 2 for SiI controllers, W2K and XP)?

Author

Commented:
Yes. I chose the XP version.

Commented:
What is model of SiI controller (or SiI chip on controller)?
> Oh, as to what happened when I did the F6, I just hit the button at the correct time, and when it was done loading files, it asked for the floppy, popped it in and setup continued.
> But now that XP doesn't see a drive to start setup on, using F6 now is kinda tough. That's why I tried using the exe file when I was running XP on a 3rd drive.

Okay, so you hit F6, it asked for the floppy, you put it in, and it continued...then it got to the screen where it shows a list of drives to install XP on.  Did it show a C: partition, or an unformatted drive?

If so, and if you picked that drive, it should have sucessfully installed Windows.  Or else I'm missing something.

If not, then you simply have the wrong F6 drivers.  Can't you reboot, and again install the XP setup by booting off the CDROM?  If it's not booting off the CDROM, go to your PC's BIOS and look for the boot options.  Put CDROM first and try again.

If you can get the model of the Sil controller, like Sil 3112 for example, I should be able to find you the proper link for the F6 drivers you need.
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Commented:
I had already suspected an incorrect driver which is why I asked for the SiI chip model earlier.

Commented:
Remove the Sil raid card and install sata drives on onboard raid see if bios and windows recognizes them?
I answered both the author's original question and his responses fully with diagnostic procedures to help pinpoint the exact location of his problem.  He has not posted since my last post, and I assume that my comments helped him solve his problem.  I believe I deserve the credit for this question.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.