• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5146
  • Last Modified:

Open With dialog appears instead of actually opening the drive

When I double-click on my removable drive the Open With dialog box is appearing instead of actually opening the drive. So to browse it I have to right-click and select Explore to see my files. How can I restore it as before? And this happens to any computer where I insert my flash drive.
0
greensword
Asked:
greensword
  • 4
  • 2
  • 2
1 Solution
 
m_tawfickCommented:
Have you messed with the folder actions ?
You may need to use regedit to fix your problem:
 (o) open HKEY_CLASSES_ROOT and navigate to Drive
 (o) click on [+] sign and then on value Shell
 (o) right click on String value [ab] (Default) on the right side of the window
 (o) modify Value data to none

The (default) value in the "HKEY_CLASSES_ROOT\Directory\shell" key
should be "none" and the (default) value in the "HKEY_CLASSES_ROOT\Folder\shell"
key should be "".  This should return you folders default action back to its original
state.

Hope this helps

0
 
m_tawfickCommented:
A similar problem is reported at MS site with a similar solution:
check http://support.microsoft.com/default.aspx?scid=kb;en-us;321186&Product=winxp
0
 
SheharyaarSaahilCommented:
happens with only removable drives or the local hard drives too?
if its this particular drive, then make sure that it doesn't contain any autorun.ini file in its root directory
otherwise, try running this reg file to fix the drive associations.....
http://www.dougknox.com/xp/fileassoc/xp_drive_association_fix.zip
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
greenswordAuthor Commented:
Hi guys,

I tried the all the solutions mentioned but none works. I have scanned it for virus and it's negative. The weird thing here is that it happens in all computer where I use this flash drive so I guess it's nothing to do with the registry.

@m_tawfick: I checked the registry and the values are what you indicated.

@Saahil: There is no autorun.ini in the drive and that reg gix is not working also

...any more ideas?
0
 
m_tawfickCommented:
This is a known problem on some flash memories, all you need is to save all your data to another hardisk and FORMAT your usb drive, then copy your data back, and your problem should be resolved.

Try it !
0
 
SheharyaarSaahilCommented:
did you turn on the Show Hidden Files while looking for the autorun.ini file?
0
 
m_tawfickCommented:
I know formating the usb drive works, it worked for other people.
Note that this will also fix the problem , if it is due to the mysterous (hidden) autorun.inf, that is Sheharyaar is talking about.
0
 
greenswordAuthor Commented:
Hi Guys,
I guess m_tawfick has the fastest and safest solution. I did back-up and formatting of the USB drive and now it is working as it was before.

Thanks to all of you.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 4
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now