We help IT Professionals succeed at work.

New podcast episode! Our very own Community Manager, Rob Jurd, gives his insight on the value of an online community. Listen Now!

x

4 Drive IDE Software RAID 5 NAS

chrisgrilli
chrisgrilli asked
on
2,032 Views
Last Modified: 2013-11-14
The unit stop responding about 5 days ago. The unit it a Dell PowerVault 715n NAS. The consist of 4 120 GB Western Digital IDE Drives configured in a software RAID 5. I ran the units internal Diagnostics and it passed all tests. The unit has no Video, CD ROM, Floppy so it's kinda hard to trouble shoot. I can however access the unit in a pre boot stage via serial using a null modem cable. I called Dell on Friday and spent a couple hours trying swapping the drives around with no success. Does any body know anything I can try on this unit? or away I can break the RAID so I can put the Drives in my external USB drive cage and read the data? Thank you for your help.
Comment
Watch Question

Commented:
Hi,

First, don't mess with the hardware yet, chances are the array is supported either by embedded Windows or some flavor of UNIX/LINUX.  You probably won't be able to find programmatic support to mount the drives as an array under a desktop OS.

Does this unit have a Web or Telnet based interface?  You want to get to this unit's management console via the network port if possible.

Try pointing a web browser to the unit IP address or try to telnet into it.

Regards,
- gurutc

Author

Commented:
I can't access the unit via an IP, the unit is not obtaining a IP from my Windows 2003 DHCP server. So telnets out also.

Commented:
OK,  

It looks like the network interface is where your issue is.  Is the unit under warranty?

Please don't think I'm stating the obvious, have you tried changing the network cable, port on the switch, etc?

Does the switch show a link light when  the unit's plugged in to the network?

Have you made changes to the Server hosting DHCP, the DHCP scope, added a new network switch, or hard-coded any IP addresses on network devices that may be interfering?

Try plugging the network cable from the device into another switch entirely, or plug it into a SOHO router that does DHCP and see if it gets an IP.

- gurutc
I'm looking at the PowerVault 715N specs, and it looks like it's running Windows 2000 internally.  If so, it should be simple to remove the drives and attach them, internally, to another PC running Windows 2000 or XP Pro.  I'd probably look for a cheap IDE controller add-on card lying around and connect the drives up to them.  (Or, connect them to a secondary onboard IDE controller, if you have one.)  That way, you could be sure the PC didn't try to boot from the RAID array, which wouldn't work anyway.  After Windows comes up, it should automatically detect the drives as being part of a software RAID array and configure them for you.

Note that if you connect them to a RAID IDE card, don't configure the RAID -- configure them as individual drives.  Being a software RAID driveset, Windows 2000/XP will configure the drives after the computer boots up.

Lastly, you should try to verify that your 715N NAS was running Windows 2000.  If it was running Linux, i've heard that simply booting up a Windows computer with Linux drives installed can mess up the drives somehow.  At least, that's what I heard for TiVo hard drives -- I know very little about Linux.

Hope this helps!
Oh, don't connect them via USB.  You wouldn't be able to read the drives unless at least 3 drives were connected at the same time for RAID5, or all 4 for RAID0 anyway.  I also don't know how 2000/XP would handle a software USB RAID driveset.  It would be much better to have Windows recognize all 4 drives during bootup via an internal controller.  You should probably also install the drivers for the controller before attaching the hard drives, so, again, Windows can detect all 4 at the same time during bootup.

Author

Commented:
I just tried to connect all 4 drives to a computer that had the primary and secondary IDE's open since the OS is running off of a SATA drive. Windows XP Pro found and installed all 4 drive, but it shows them in Computer Manager as a RAID 5 and it states them as a Dynamic Drive who status is failed.
That sounds good.  If it shows failed, then it thinks that one of the drives is out of sync with the rest.  But at least it shows them all as a RAID5 set, so we know that Windows is seeing them properly.  Can you tell if it shows all 4 of them as a single RAID5 set -- or, in other words, does it know that they all belong to one group?

If so, you should be able to force it online and/or tell it to rebuild/repair the RAID5 set.  This means that it will erase and rebuild the checksum data from the drives, and should keep all data in tact.  If you are extremely concerned about it overwriting or losing data, you might want to use drive imaging software to make a sector-by-sector backup of each of the drives before you do this process.  Or, disconnect one of the 4 drives, and windows should allow you to use the RAID5 set in a failed state, without rebuilding data.  This might be useful if you think the rebuilding process would damage the drives, but it probably won't really help you to keep the drives in an unmodified state.

I strongly suggest putting some fans around the drives to keep them cool during the rebuilding process.

Shane

Commented:
Hi,

Shane's last post is just what I was thinking.  You need to get Acronis or Ghost and to perform a sector-level imaging of each drive.  That way you can re-create the exact physical state of each drive in the event things go wrong!

As always, before doing anything, backup backup backup!

- gurutc

Author

Commented:
I got 4 idnetical IDE Western Digital drive and I tried both recommended softwares and they both don't work. Do you have any other sultions for backing up the drives to the new drives?

Thank you!
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
That's pretty funny becuase I'm runing Raid Reconstructor right now on the drives. I have all for drives hooked up to my winXPP and a fan pointing at the drives. Looks like it going to be a while.

As far as ghost when I tried a disk to disk image it stated it couldn't due to the fact that it was a dynamic drive with no volumes.

Thanks so much for all your help. I will keep you posted as I proceed.
- Chris

Commented:
Hi again,

Well I'm hoping all goes well!  

For future reference, to use Ghost, you'd hook up the drive to a system and boot from the Ghost CD or use a Ghost boot floppy.  Then you'd be in DOS mode, and the system would not know or care what the physical disk's file system or array status was, and at that point you can set the Ghost options to do a sector by sector image.

But, I'm feeling good about you getting your data back.

Good Luck,

- gurutc

Author

Commented:
Heres the solution:

I hooked up the four IDE drives to my Windows XP Pro machine using the primary and secondary IDE ports. Even thought XP could see them all, the drives all appeared Offline.

I found GetDataBack for NTFS & RAID Reconstructor by www.runtime.org. Great products but I didn't know the drives configuration and start sectors. I then purchased RAID Probe service also by Runtime which is a service which they have you run a RAID probe from RAID Recontructor and then upload them the results. They then send you back all the setting needed to recover your data in less than 24 hours. After they sent me the setting I ran GetDataBack and retrieved all my data back.

Thank you to gurutc & Shane32EE. You both gave me a better understanding of what was going on so that I could find the correct resources to fix my problem.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.