IIS Configuration for NLB

W2K3, IIS 6.0 - I cannot get the application in IIS to display using the Cluster IP
Configured 2 hosts for NLB each has 2 Nic's

Host A
Nic1 - 192.168.129.229
Cluster Nic2 - 192.168.128.128

Host B
Nic1 - 192.168.129.217
Cluster Nic2 - 192.168.128.129

Cluster IP - 10.120.128.130

IIS is configured with virtual directories so the site is under the default website along with other web services. The Default Website is setup for as IP addresses All Unassigned, when I try the cluster IP I don't get the page, if I hit the Nic 1 on each server it loads fine. When I change All Unassigned to the cluster IP I get page not found.

I am just not sure on how IIS needs to be configured to work with NLB.
HajinStudioGroupAsked:
Who is Participating?
 
Computer101Commented:
PAQed with points refunded (500)

Computer101
EE Admin
0
 
Dave_DietzCommented:
IIS doesn't know anything about load balancing.

If there is a problem getting to the site via the load balanced IP address there is a problem with the load balancing, not IIS.

One question - how are you load balancing?  Are you using WLBS or some other product or device?

If you are using WLBS you have a serious configuration issue if you have to have tha same IP address configured on each of the machine you are trying to load balance between.

Dave Dietz
0
 
HajinStudioGroupAuthor Commented:
I am using W2K3 NLB. I am not sure I follow - each host has the original Nic1 configured with a unique address, Nic 2 which I call the cluster Nic has a unique address so I am using 4 unique IP's.

Host A & B has public nic and private ( cluster) nic the 5th Nic is what I assigned to the Cluster in the configuration in the NLB Manager that is the only common IP which I though passed traffic to the private Nics on the host. So for clients I am trying to point to the cluster IP to connect.

I am a newbie in this space so all help greatly appreciated.
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
Dave_DietzCommented:
Can you run an 'ipconfig /all >outfile.txt' on each of the machines from a command prompt and post the results so we can see if the UIP cponfiguration is correct?

Dave Dietz
0
 
HajinStudioGroupAuthor Commented:
Below is the info off the servers, I changed the first 2 octets on the first post.
Host A

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : xxx
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-0C-29-53-03-D4
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IP Address. . . . . . . . . . . . : 10.120.129.217
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   Default Gateway . . . . . . . . . : 10.120.128.2
   DHCP Server . . . . . . . . . . . : 10.120.128.3
   DNS Servers . . . . . . . . . . . : 10.120.128.3
                                       10.120.128.11
   Primary WINS Server . . . . . . . : 10.120.128.3
   Secondary WINS Server . . . . . . : 10.120.128.6
   Lease Obtained. . . . . . . . . . : Sunday, September 30, 2007 5:29:24 AM
   Lease Expires . . . . . . . . . . : Wednesday, October 03, 2007 5:29:24 AM

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection #2

   Physical Address. . . . . . . . . : 02-BF-0A-78-80-82
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 10.120.128.130
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   IP Address. . . . . . . . . . . . : 10.120.128.129
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   Default Gateway . . . . . . . . . : 10.120.128.2
   DNS Servers . . . . . . . . . . . : 10.120.128.3
                                       10.120.128.6

Host B

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection 2

   Physical Address. . . . . . . . . : 02-BF-0A-78-80-82
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 10.120.128.130
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   IP Address. . . . . . . . . . . . : 10.120.128.128
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   Default Gateway . . . . . . . . . : 10.120.128.2
   DNS Servers . . . . . . . . . . . : 10.120.128.3
                                       10.120.128.6

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : xxx
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-0C-29-33-1B-74
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IP Address. . . . . . . . . . . . : 10.120.129.229
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   Default Gateway . . . . . . . . . : 10.120.128.2
   DHCP Server . . . . . . . . . . . : 10.120.128.3
   DNS Servers . . . . . . . . . . . : 10.120.128.3
                                       10.120.128.11
   Primary WINS Server . . . . . . . : 10.120.128.3
   Secondary WINS Server . . . . . . : 10.120.128.6
   Lease Obtained. . . . . . . . . . : Monday, October 01, 2007 12:39:11 PM
   Lease Expires . . . . . . . . . . : Thursday, October 04, 2007 12:39:11 PM
0
 
HajinStudioGroupAuthor Commented:
Going thru the config again I see I can't ping the private cluster IP on host b. I am postive I checked this when I set this up last week. The 1st NIC  replies fine and I can connect to it via RDP. Now it looks like I can't even ping out from host B. Looking at the route table the default routes have 2 lines:

Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0     10.120.128.2   10.120.129.229     10
          0.0.0.0          0.0.0.0     10.120.128.2   10.120.128.128     10

Unless this is something that NLB does, it seems that 10.120.129.229 (the non cluster IP) should have a metric of 1 not 10. Host A is configured with a 1 vs 10.

Tried to change the metric but not 100% sure how to do this yet.
0
 
HajinStudioGroupAuthor Commented:
For now I manllay made the gateway metric for the Cluster 11 so I can ping everywhere again, Now I can ping out and even to Host A's private cluster IP and the global cluster IP but from host A I still can't ping host B's private IP for some reason. App still won't load on the cluster IP.
0
 
HajinStudioGroupAuthor Commented:
Looks like Unicast/Multicast settings is it. It was setup to Unicast now Multicast. In this mode I can access the IIS app via the Cluster IP. I don't control this network so it will not be easy to have the client make changes like adding static arp addresses, but this appears to be my issue.

In addition I had to setup the default website where the app is setup to point to the cluster IP address in the IP setting vs. the All unassigned.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.