?
Solved

Exchange and DNS problem, email is not working.

Posted on 2007-10-01
12
Medium Priority
?
267 Views
Last Modified: 2010-03-06
Hi Experts,

Let me take a minute to describe my network.  I have two Windows 2003 servers, one is an Exchange 2003 server and the other is a Domain Controller.   All computers on the network are running behind my router/firewall in a private ip address range.  I only have one public ip address which is configured on my router along with my ISPs DNS servers.  

We have a public website that we pay someone else to host for us.  Thursday morning last week we changed web host providers.  I asked our new provider to create the following records:

Record FQDN                                       Record Type                  Record Value                    MX Pref
mail.domain.com                                        A                             199.x.x.x                            
 
domain.com                                             MX                             mail.domain.com                 10


These are the same records that our former web host provider hosted when the email worked.  Our web site is back up but our email is still not working.  From my home, if I open a web browser and type the ip address\exchange I am able to reach our email server through OWA.  

I know this is a DNS problem but how do I fix it?  If I do a nslookup for my mail server, mail.domain.com I get back:

Non-authoritative answer:
Name:    mail.domain.com


But if I do the same for the ip address the following is returned:

Name:    mail.domain.com
Address:  199.x.x.x

How do I fix this?

Thanks Dale






0
Comment
Question by:DaleFrazier
  • 4
  • 2
  • 2
  • +2
12 Comments
 
LVL 37

Assisted Solution

by:Jamie McKillop
Jamie McKillop earned 200 total points
ID: 19991179
When you did the NSLOOKUP, did you set type=mx?

If you did an nslookup with set type=mx and your MX record was not returned, the record is not setup properly and you will need to contact your DNS administrator to get it resolved.

JJ
0
 
LVL 58

Assisted Solution

by:tigermatt
tigermatt earned 400 total points
ID: 19991310
First of all, you need to make sure that the DNS record for your mail.domain.com has been created correctly. Can you access your server with mail.domain.com/exchange? The mail.domain.com should be an A record pointing to your external WAN IP address, as you say.

Now, your domain.com needs to have the MX records changed so that the only MX record is mail.domain.com. MX stands for Mail Exchanger. When someone sends a mail, the sender's server looks up the MX record for domain.com, sees it is mail.domain.com, and connects through to mail.domain.com on port 25.

As JJ has said above, you need to type set type=mx at the nslookup prompt to see the MX record on your domain. So, for example:

> set type=mx
> domain.com

That will give you a prompt like: (I looked up EE's MX records)

Non-authoritative answer:
experts-exchange.com    MX preference = 1, mail exchanger = mail.experts-exchange.com

mail.experts-exchange.com       internet address = 64.156.132.251

You need to have an MX record on domain.com pointing to mail.domain.com with any cost at all, although 1, 5 and 10 are the usual settings. Once that's done, you can confirm the changes via nslookup.

-tigermatt
0
 

Author Comment

by:DaleFrazier
ID: 19991465
There appears to be an mx record but I think the associated A record might be missing or wrong.  Also, is a non-authoritative answer a bad thing????





C:\Documents and Settings\Dale>nslookup
Default Server:  server.domain.local
Address:  192.168.1.x

> set type=mx
> domain.com
Server:  server.domain.local
Address:  192.168.1.x

DNS request timed out.
    timeout was 2 seconds.
Non-authoritative answer:
domain.com     MX preference = 10, mail exchanger = mail.domain.com
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 37

Assisted Solution

by:Jamie McKillop
Jamie McKillop earned 200 total points
ID: 19991487
I looks like your DNS zone may not have been properly transferred to your new host provider. I would recommend going to dnsstuff.com and running some reports to see if there is a problem with your domain.

JJ
0
 
LVL 6

Assisted Solution

by:rbkumaran
rbkumaran earned 400 total points
ID: 19991579
Along with dnsstuff tests,

Run a www.dnsreport.com for your domain as well. That will provide you with more insights on your NS/EMail status.
0
 

Author Comment

by:DaleFrazier
ID: 19991589
Could this be the problem,

WARNING: One or more of your MX records points to a CNAME. CNAMEs are prohibited in MX records, according to RFC974, RFC1034 3.6.2, RFC1912 2.4, and RFC2181 10.3. The problem MX record(s) are:
mail.domain.com.->199.x.x.x . domain.com.->Unknown [No A]
0
 
LVL 104

Assisted Solution

by:Sembee
Sembee earned 1000 total points
ID: 19991724
Yes a CNAME would be a problem.
You need to get the MX record changed. Currently it looks like you are trying to use a wildcard on the domain rather than a specific A record. You need to change that.

In the public DNS (NOT WINDOWS) you need to create a new record of type A, name mail with your external IP address.
That will make mail.domain.com

Simon.
0
 
LVL 58

Assisted Solution

by:tigermatt
tigermatt earned 400 total points
ID: 19991741
Yes, the CNAME would certainly be causing the problem, you'll need to get the MX record changed with your host so that it points to the external WAN IP address of your network as an A record, not a CNAME.

-tigermatt
0
 

Author Comment

by:DaleFrazier
ID: 19991777
You have to transfer a dns zone?  All I did was change the dns servers with my domain registrar.  Like I said the web site is up.  Also this info,

Your 1 MX record is:

10 mail.domain.com. [TTL=1800] IP=Unknown [CNAME]

0
 
LVL 104

Accepted Solution

by:
Sembee earned 1000 total points
ID: 19991815
I think the problem here is quite simple. Your new hosting company did not do what you asked. Phone them up and ask them to correct it.

Simon.
0
 
LVL 6

Assisted Solution

by:rbkumaran
rbkumaran earned 400 total points
ID: 19991827
If I'm right the
"mail" is a CNAME pointing to your default domain but there isn't an A record for the default domain??? Sorry if My assumption is wrong.

As tigermatt said, add a A record for MAIL and that should fix your problem (provided NS are correct)
0
 

Author Comment

by:DaleFrazier
ID: 19991892
I called my provider.  I agree it is the A record.  
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On September 18, Experts Exchange launched the first installment of the Help Bell, a new feature for Premium Members, Team Accounts, and Qualified Experts. The Help Bell will serve as an additional tool to help teams increase question visibility.
In this post, I will showcase the steps for how to create groups in Office 365. Office 365 groups allow for ease of flexibility and collaboration between staff members.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…
Suggested Courses

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question