Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

How to allow Internet traffic back through end user tunnels on Cisco ASA

Posted on 2007-10-01
10
Medium Priority
?
1,446 Views
Last Modified: 2008-01-09
Hello,

I'm installing a Cisco ASA 5510 and I'd like to disallow split tunneling (make all traffic go through the IPSec VPN tunnel when connected), but let traffic from the Internet get back to the clients from our network.  I'm having a tough time finding a procedure or sample config on Cisco's site or on here so far.  Could anyone offer some suggestions?  Here's my config:

show run
: Saved
:
ASA Version 7.2(3)
!
hostname firewall
domain-name lsisolutions.com
enable password [removed] encrypted
names
dns-guard
!
interface Ethernet0/0
 description Internet Interface
 speed 10
 duplex half
 nameif Outside
 security-level 0
 ip address 64.80.10.94 255.255.255.252
!
interface Ethernet0/1
 description Inside LAN Interface
 nameif Inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/2
description DMZ Interface for future use.
 shutdown
 nameif DMZ
 security-level 5
 ip address 10.0.0.1 255.255.255.0
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.101.1 255.255.255.0
 management-only
!
passwd [removed] encrypted
boot system disk0:/asa723-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
domain-name lsisolutions.com
access-list Inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list Outside-Inward extended permit tcp any interface Outside eq smtp
pager lines 24
logging enable
logging timestamp
logging list vpnUser level notifications class vpnc
logging list vpnIPSec level notifications class vpn
logging list sysMsgs level notifications class sys
logging list sessionInfo level notifications class session
logging list idsMsgs level notifications class ids
logging buffer-size 16384
logging buffered sessionInfo
logging trap debugging
logging asdm informational
logging host Inside 192.168.1.7
logging permit-hostdown
logging class auth trap emergencies
mtu Outside 1500
mtu Inside 1500
mtu DMZ 1500
mtu management 1500
ip local pool LSI-VPN-IP-POOL 192.168.2.1-192.168.2.254 mask 255.255.255.0
ip verify reverse-path interface Outside
ip verify reverse-path interface Inside
ip verify reverse-path interface DMZ
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (Outside) 1 interface
nat (Inside) 0 access-list Inside_nat0_outbound
nat (Inside) 1 0.0.0.0 0.0.0.0
nat (management) 0 access-list management_nat0_outbound
static (Inside,Outside) tcp interface smtp 192.168.1.6 smtp netmask 255.255.255.255
access-group Outside-Inward in interface Outside
route Outside 0.0.0.0 0.0.0.0 64.80.10.93 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa-server InternalAuth protocol radius
aaa-server InternalAuth host 192.168.1.7
 key [removed]
aaa authentication enable console LOCAL
aaa authentication serial console LOCAL
aaa authentication http console InternalAuth LOCAL
aaa authentication ssh console InternalAuth LOCAL
aaa authorization command LOCAL
aaa local authentication attempts max-fail 10
http server enable
http 192.168.1.0 255.255.255.0 Inside
http 192.168.101.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map Outside_dyn_map 40 set pfs
crypto dynamic-map Outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map Outside_map 65535 ipsec-isakmp dynamic Outside_dyn_map
crypto map Outside_map interface Outside
crypto ca trustpoint lsiadc01
 revocation-check crl none
 enrollment terminal
 subject-name CN=firewall.lsisolutions.com,O=lsisolutions.com,C=US,St=New York,L=Victor
 crl configure
crypto isakmp identity hostname
crypto isakmp enable Outside
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp disconnect-notify
telnet timeout 5
ssh scopy enable
ssh 192.168.1.0 255.255.255.0 Inside
ssh timeout 60
ssh version 2
console timeout 0
management-access Inside
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect http
!
service-policy global_policy global
ntp server 128.59.59.177 source Outside prefer
ntp server 66.250.45.2 source Outside
group-policy LSI-VPN1 internal
group-policy LSI-VPN1 attributes
 wins-server value 192.168.1.7
 dns-server value 192.168.1.7 192.168.1.6
 vpn-tunnel-protocol IPSec
 default-domain value lsisolutions.com
username tleroy password scPelfzzu4YpdnwV encrypted privilege 15
tunnel-group LSI-VPN1 type ipsec-ra
tunnel-group LSI-VPN1 general-attributes
 address-pool LSI-VPN-IP-POOL
 authentication-server-group InternalAuth
 default-group-policy LSI-VPN1
tunnel-group LSI-VPN1 ipsec-attributes
 pre-shared-key *
privilege cmd level 3 mode exec command perfmon
privilege cmd level 3 mode exec command ping
privilege cmd level 3 mode exec command who
privilege cmd level 3 mode exec command logging
privilege cmd level 3 mode exec command failover
privilege cmd level 3 mode exec command vpn-sessiondb
privilege show level 5 mode exec command running-config
privilege show level 3 mode exec command reload
privilege show level 3 mode exec command mode
privilege show level 3 mode exec command firewall
privilege show level 3 mode exec command interface
privilege show level 3 mode exec command clock
privilege show level 3 mode exec command dns-hosts
privilege show level 3 mode exec command access-list
privilege show level 3 mode exec command logging
privilege show level 3 mode exec command ip
privilege show level 3 mode exec command failover
privilege show level 3 mode exec command asdm
privilege show level 3 mode exec command arp
privilege show level 3 mode exec command route
privilege show level 3 mode exec command ospf
privilege show level 3 mode exec command aaa-server
privilege show level 3 mode exec command aaa
privilege show level 3 mode exec command crypto
privilege show level 3 mode exec command vpn-sessiondb
privilege show level 3 mode exec command ssh
privilege show level 3 mode exec command dhcpd
privilege show level 3 mode exec command vpn
privilege show level 3 mode exec command blocks
privilege show level 3 mode exec command uauth
privilege show level 3 mode configure command interface
privilege show level 3 mode configure command clock
privilege show level 3 mode configure command access-list
privilege show level 3 mode configure command logging
privilege show level 3 mode configure command ip
privilege show level 3 mode configure command failover
privilege show level 5 mode configure command asdm
privilege show level 3 mode configure command arp
privilege show level 3 mode configure command route
privilege show level 3 mode configure command aaa-server
privilege show level 3 mode configure command aaa
privilege show level 3 mode configure command crypto
privilege show level 3 mode configure command vpn-sessiondb
privilege show level 3 mode configure command ssh
privilege show level 3 mode configure command dhcpd
privilege show level 5 mode configure command privilege
privilege clear level 3 mode exec command dns-hosts
privilege clear level 3 mode exec command logging
privilege clear level 3 mode exec command arp
privilege clear level 3 mode exec command aaa-server
privilege clear level 3 mode exec command crypto
privilege cmd level 3 mode configure command failover
privilege clear level 3 mode configure command logging
privilege clear level 3 mode configure command arp
privilege clear level 3 mode configure command crypto
privilege clear level 3 mode configure command aaa-server
prompt hostname context
Cryptochecksum:d162474dc3de4349ec0f69cf0bb3efa1
: end
firewall#    

The reason I want to set it up this way is that I have a 192.168.1.0/24 LAN which conflicts with many home users' default networks.  I have to walk them through fixing their home networks until I can get us onto a new scheme which requires changing all of my static IP's.  Please share your thoughts on whether disallowing split tunneling but allowing Interent traffic back to the user via the IPSec tunnel will work in resolving the 192.168.1.0 subnet issue.  It also seems more secure than split tunneling.

Thanks!
0
Comment
Question by:Sma11T0wnITGuy
  • 4
  • 4
  • 2
10 Comments
 
LVL 4

Expert Comment

by:pstrawser
ID: 19991784
you can log in to the cisco 5510 web interface?
0
 
LVL 4

Expert Comment

by:pstrawser
ID: 19991841
If you are able to log in to the web interface..   just go to      
Configuration > VPN > General > VPN System Options
select [ ]  Enable inbound IPSec sessions to bypass interface access lists.  Group policy and per-user authorization access lists still apply to the traffic.

to make sure it's working..   if you are in the client computer, go to the command prompt  Start > Run  and type  CMD

type.    ipconfig /all

on the  cisco ip, you will not see "Default Gateway"    so the user(client) can use their Internet instead of using yours...

Let me know if that help..
0
 
LVL 3

Accepted Solution

by:
theeter earned 500 total points
ID: 19992595
If I understood your question correctly, this is what you are looking for...

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00805734ae.shtml

same-security-traffic permit intra-interface
nat (outside) 192.168.2.0 255.255.255.0
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 

Author Comment

by:Sma11T0wnITGuy
ID: 19994321
Hi pstrawser and theeter,

Thanks for your responses.

I do not want VPN users to use their own gateways, or do split tunneling.  I think my solution will be along the lines of theeter's suggestion.  I want split tunneling disabled, so all user traffic traverses the ASA at the main site, but I want them to be able to browse the Interent via their IPSec tunnels.

theeter, any idea if there are any ASDM configuration examples for the Public Internet on a Stick configuration?
0
 
LVL 3

Expert Comment

by:theeter
ID: 19998174
You really only need the two commands I posted. The nat command would be on the config -> nat page. The other I believe is a checkbox somewhere which would say something about allowing traffic to enter and exit the same interface. If I get a chance I will look for it and post where it is.
0
 

Author Comment

by:Sma11T0wnITGuy
ID: 19998641
Thanks theeter,

I was just looking over the config again and thought there would only be a few parts I would need.

I'll give it a try and let you know!

Ted
0
 
LVL 3

Expert Comment

by:theeter
ID: 19998662
Config -> Interfaces -> Check "Enable traffic between two or more hosts connected to the same interface".

Config -> NAT -> Add

Real address
Interface Outside
Ip address = vpn client pool network

Dynamic Translation
Interface Outside
Select and address Pool ID
0
 

Author Comment

by:Sma11T0wnITGuy
ID: 19998760
Thanks theeter,

I'm ok with command line unless it gets complicated, like setting up VPN groups, maps, crypto, etc.  Then I use ASDM.

I put the commands you recommended in, but I had to add a 1 after nat (outside) for the nat id:

firewall(config)# same-security-traffic permit intra-interface
firewall(config)# nat (outside) 192.168.2.0 255.255.255.0
                                   ^
ERROR: % Invalid input detected at '^' marker.
firewall(config)# nat (outside) ?

configure mode commands/options:
  <0-2147483647>  The <nat_id> of this group of hosts/networks. This <nat_id>
                  will be referenced by the global command to associate a
                  global pool with the local IP address. <nat_id> '0' is used
                  to indicate no address translation for local IP. The limit is
                  65535 with access-lists
firewall(config)# nat (Outside) 192.168.2.0 255.255.255.0
                                                       ^
ERROR: % Invalid input detected at '^' marker.
firewall(config)# nat (Outside) 1 192.168.2.0 255.255.255.0
firewall(config)#
firewall# wr
Building configuration...
Cryptochecksum: 46ab5346 e32f0af6 0c9391e5 1db65adf

8305 bytes copied in 3.830 secs (2768 bytes/sec)
[OK]
firewall#

I won't be able to test until at least lunch time, possibly after work or tomorrow.

I really appreciate the help!

Ted
0
 
LVL 3

Expert Comment

by:theeter
ID: 19998901
Oops, I missed the 1, but you got it.
0
 

Author Comment

by:Sma11T0wnITGuy
ID: 20006068
Tested and working great!  Thanks theeter.

Ted
0

Featured Post

The IT Degree for Career Advancement

Earn your B.S. in Network Operations and Security and become a network and IT security expert. This WGU degree program curriculum was designed with tech-savvy, self-motivated students in mind – allowing you to use your technical expertise, to address real-world business problems.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When speed and performance are vital to revenue, companies must have complete confidence in their cloud environment.
Will you be ready when the clock on GDPR compliance runs out? Is GDPR even something you need to worry about? Find out more about the upcoming regulation changes and download our comprehensive GDPR checklist today !
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question