New SBS Install: Exchange over HTTP doesn't work.

New SBS R1 installation, but Exchange over HTTP doesn't work. Here is what we know so far:

1. Ports are forwarded properly.
2. Port Query tool says they are open and listening.
3. Webmail works internally as well as externally.
4. When you setup a profile, the connecting to server.domain.local dialog comes up and does ask for a username and password, but then says "The action could not be completed. The connection to the Microsoft Exchange Server is unavailable. Outlook must be online or connected to complete this action."
5. Outlook.exe /rpcdiag give me the following information:

First it asks for a user/pass (http://gogetmyfiles.com/ss1.png) for which I provide a valid user / pass and recieve: a disconnected message: http://gogetmyfiles.com/ss2.png, and the ultimate error: http://gogetmyfiles.com/ss3.png

Lastly, it kills my inner child by giving me this prompt for the 100th time:

http://gogetmyfiles.com/ss4.png

So if you hit check name, you get http://gogetmyfiles.com/ss3.png again.

How do we get Exchange over HTTP to work? What am I missing here?

LVL 32
DrDamnitAsked:
Who is Participating?
 
SLafferty1983Commented:
Do you have a valid trusted SSL certificate installed that matched the name you are going after?
0
 
DrDamnitAuthor Commented:
The SSL Cert if for mail.customerdomain.com, which is the address we are using everywhere.

I went to https://mail.customerdomain.com/exchange/ and did a view certificate > install certificate after you posted your reply, but we are still getting the same error.

We also deleted the old certificate out of the trusted root store on the client machine.
0
 
SLafferty1983Commented:
On SBS you have to allow Outlook via the internet in the Internet Configuration Wizard, which I am assuming you have done. Also are you using basic authentication on the clients?

0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
DrDamnitAuthor Commented:
RE:SLafferty1983:

Yes and yes.
0
 
SLafferty1983Commented:
All that is required on SBS is to allow it through the wizard and have a certificate setup correctly. Do you get any certificate warning popups when visiting the website? If so, follow this article: http://support.microsoft.com/kb/555261. Here are a few other websites to look over and verify all your settings with.

http://www.petri.co.il/configure_rpc_over_https_on_a_single_server.htm
http://www.amset.info/exchange/rpc-http-tips.asp
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
the problem is that you aren't supposed to click the "check name" botton when creating the profile.  Please open your Remote Web Workplace main menu to access your customized step-by-step instructions to set up "Outlook via the Internet".

Jeff
TechSoEasy
0
 
DrDamnitAuthor Commented:
Simplest answer is usually the right one. We re-did the certificate and everything worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.