• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1475
  • Last Modified:

GAL not showing updates on Client workastation

The Global Address List isnt updating on Client machines. I noticed that this problem started after I went into active directory and checked the box in the users account to hide address from GAL. I also recently update our SSL certificate for our OWA. We have a few new people join our company and the new accounts do not show up in the Address Book. I went into Default Global Address List in ESM and right clicked it and selected propertied. I then selected preview. Everyone that is suppose to be on the list is listed in that window, including the new accounts. I have selected Re-build for the GAL.

I went into the Client's machine and forced the Offline Address book update by going into Tools>Send/Recieve and update Address Book-- still doesnt work.

One thing I have noticed that was strange was on a new Outlook setup. I had the machine join the domain and then configured Outlook for the Exchange server. After the setup was finished I started Outlook and the Address book displayed the correct people. However, once I did a restart on the machine it went back to the same list that everyone else is seeing.

If I cant get any fixes from here, I think my last option is to restart the exchange server or maybe the exchange services.
0
stevensims
Asked:
stevensims
  • 6
  • 4
  • 3
  • +1
1 Solution
 
Brian PiercePhotographerCommented:
the GAL will only update whrn the Recipient Update Service runs - if you are using an offline address book then it could be a further 24 hrs

http://www.windowsitpro.com/Article/ArticleID/49805/49805.html
0
 
pstrawserCommented:
ok from what i know about this GAL thing is that it update 1once a day by default..    

this is how to fix this man..  

Exchange System Manager
expand Recipients
expand Offline Address List
right clict the "Default Offline Address List" and hit rebuild


you can hit properties to create a customer schedule

Hey.. hope this help you man...
0
 
tigermattCommented:
If you login to OWA, do you see the updates to your GAL there? OWA uses a live version of the GAL and therefore any updates you make will be instantly ready to view in OWA's facility.

If that doesn't help, then often deleting the cached OST file and every other file in C:\Documents and Settings\<user>\Local Settings\Application Data\Microsoft\Outlook and then opening Outlook again often fixes this - if something has become corrupted then this will redownload the address book.

-tigermatt
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
tigermattCommented:
Just FYI, the author actually says that he has manually rebuilt the address book and redownloaded it with no effect.

-tigermatt
0
 
pstrawserCommented:
deleting .oab fix this problem on one computer.  but read my previous comment.. try this first and see if it fix it.. if it does.. then follow my initial comment..  previous comment!!
0
 
stevensimsAuthor Commented:
I went into OWA and created new email. Clicked the To button and typed in the first name and then find. I did this for multiple users and all were found.

Just FYI. I have had this problem for a few weeks now. Our server updates the GAL every morning at 5 AM. This is my first chance I have had at resolving the issue.
0
 
tigermattCommented:
Have you tried clearing out the C:\Documents and Settings\<user>\Local Settings\Application Data\Microsoft\Outlook directory? Make sure you have Outlook closed, then delete everything inside that folder and open Outlook again. (Make sure you backup any extra PST files your client may have as they will probably be in that place) It will need to recache emails again but it should also sort out if the OAB is corrupted.
0
 
pstrawserCommented:
dude, i have the same problem the other day..   what i did to test it is remove all the .oab  or copy it to somewhere.. then open outlook and it loaded all new email address..  that is how i know to go to the offline address list.     or if you want, just creat a new schedule and rebuild.. so that it rebuild on the time you say so.. instead of waiting the next morning......
0
 
stevensimsAuthor Commented:
I set up a new user on my machine. After Outlook did the intial setup (Intials and email update) I went ahead and created a new email. Clicked the To button and all users that were suppose to be in the OAB were there-- this is great!. I then went ahead and logged off and then back on. Created a new email and clicked the To button. This time the OAB went back to what everyone else is seeing, missing a couple of users. The account that I am using wasnt even listed in the OAB.

It seems to me that Windows 2003 may have two lists for the GAL-- local and external. When doing the intial setup Outlook uses the primary GAL. However, once the setup part is finished and the user restarts Outlook, Outlook reverts back to using the secondary list. Does anyone know if Exchange works this way were it has a primary list that is internal to Exchange and duplicates the information to a secondary list that is used for external connections?

I am thinking maybe a restart will fix this problem?
0
 
stevensimsAuthor Commented:
Update. I went into Event Viewer and found this error: Microsoft Exchange System Attendant reported an error '0x80072030' when setting DS notification.  I back tracked to the very first time this error was reported-- this was around the same time the problem started. So now how do I fix this problem since this may be part of the cause?
0
 
tigermattCommented:
I've never had that specific error before, but from what I've found on the internet it sounds as though there is an issue between Active Directory and the Exchange server. This page (which describes this error) also says updates to the GAL aren't appearing, so looks like this could be the cause: http://www.webservertalk.com/archive128-2006-4-1484534.html

Try running dcdiag on the server(s) and see what errors, if any, it turns up and we can take it from there. Also I assume your RUS is set to always run? (Should be by default unless you changed it)

-tigermatt
0
 
stevensimsAuthor Commented:
I looked at the DCDiag. What command should I run?

Thinking back, I think right before this issue started I was backing up previous employee's emails. After the backup I deleted the user and mailbox from our server.
0
 
stevensimsAuthor Commented:
Ran DCDiag.
Server1---Server 2000/DC/ File Server
Server3-- Server 2003/DC/Exchange 2003

Results

C:\Documents and Settings\Administrator>dcdiag

Domain Controller Diagnosis

Performing initial setup:
   Done gathering initial info.

Doing initial required tests

   Testing server: Default-First-Site-Name\Server3
      Starting test: Connectivity
         ......................... Server3 passed test Connectivity

Doing primary tests

   Testing server: Default-First-Site-Name\Server3
      Starting test: Replications
         ......................... Server3 passed test Replications
      Starting test: NCSecDesc
         ......................... Server3 passed test NCSecDesc
      Starting test: NetLogons
         Unable to connect to the NETLOGON share! (\\Server3\netlogon)
         [Server3] An net use or LsaPolicy operation failed with error 1203, No n
etwork provider accepted the given network path..
         ......................... Server3 failed test NetLogons
      Starting test: Advertising
         Warning: DsGetDcName returned information for \\Server1.Domain.us, w
hen we were trying to reach Server3.
         Server is not responding or is not considered suitable.
         ......................... Server3 failed test Advertising
      Starting test: KnowsOfRoleHolders
         ......................... Server3 passed test KnowsOfRoleHolders
      Starting test: RidManager
         ......................... Server3 passed test RidManager
      Starting test: MachineAccount
         ......................... Server3 passed test MachineAccount
      Starting test: Services
         ......................... Server3 passed test Services
      Starting test: ObjectsReplicated
         ......................... Server3 passed test ObjectsReplicated
      Starting test: frssysvol
         ......................... Server3 passed test frssysvol
      Starting test: frsevent
         ......................... Server3 passed test frsevent
      Starting test: kccevent
         ......................... Server3 passed test kccevent
      Starting test: systemlog
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   08:48:56
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   08:49:55
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   08:49:55
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   08:51:07
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   08:53:43
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   08:54:25
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   08:54:34
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   08:55:24
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:09:35
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:09:56
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:11:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:12:32
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:12:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:13:03
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:15:25
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:16:18
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:17:48
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:17:58
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:18:00
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:18:38
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:20:49
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:25:10
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:25:54
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:26:20
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:26:30
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:28:01
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:28:59
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:30:02
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:30:09
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:31:28
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:33:03
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:34:54
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:35:02
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:35:03
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:35:05
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:35:41
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:38:07
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:39:15
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC0002714
            Time Generated: 10/09/2007   09:43:40
            (Event String could not be retrieved)
         ......................... Server3 failed test systemlog
      Starting test: VerifyReferences
         ......................... Server3 passed test VerifyReferences

   Running partition tests on : ForestDnsZones
      Starting test: CrossRefValidation
         ......................... ForestDnsZones passed test CrossRefValidation

      Starting test: CheckSDRefDom
         ......................... ForestDnsZones passed test CheckSDRefDom

   Running partition tests on : DomainDnsZones
      Starting test: CrossRefValidation
         ......................... DomainDnsZones passed test CrossRefValidation

      Starting test: CheckSDRefDom
         ......................... DomainDnsZones passed test CheckSDRefDom

   Running partition tests on : Schema
      Starting test: CrossRefValidation
         ......................... Schema passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... Schema passed test CheckSDRefDom

   Running partition tests on : Configuration
      Starting test: CrossRefValidation
         ......................... Configuration passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... Configuration passed test CheckSDRefDom

   Running partition tests on : Domain
      Starting test: CrossRefValidation
         ......................... Domain passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... Domain passed test CheckSDRefDom

   Running enterprise tests on : Domain.us
      Starting test: Intersite
         ......................... Domain.us passed test Intersite
      Starting test: FsmoCheck
         ......................... Domain.us passed test FsmoCheck

C:\Documents and Settings\Administrator>
0
 
stevensimsAuthor Commented:
I did a restart and the problem went away. I believe that an update and or configuration change may have prevented the GAL from updating.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 6
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now