We help IT Professionals succeed at work.

Unable to connect error when using WSDL.EXE

1,002 Views
Last Modified: 2013-11-19
I have setup a web service and need to generate the source code from the proxy.  I can access the web service just fine from the browser (set up in IIS), but get an error through WSDL.EXE.  The error I get is:

C:\Documents and Settings\Stew>wsdl http://localhost/Service/Service.asmx?WSDL
Microsoft (R) Web Services Description Language Utility
[Microsoft (R) .NET Framework, Version 2.0.50727.42]
Copyright (C) Microsoft Corporation. All rights reserved.
Error: There was an error processing 'http://localhost/Service/Service.asmx?WSDL'.
  - There was an error downloading 'http://localhost/Service/Service.asmx?WSDL'.
  - Unable to connect to the remote server
  - No connection could be made because the target machine actively refused it

As I mentioned, I can access the same URL above on the same machine just fine.

Any ideas?
Comment
Watch Question

The error is saying that there is no server listening on port 80.  To be clear, you say you can see the WSDL by entering the URL "http://localhost/Service/Service.asmx?WSDL" in your browser on the same machine on which you are running the WSDL utility?

Author

Commented:
Yes, I can see the WSDL by entering http://localhost/Service/Service.asmx?WSDL in the URL in the browser; exactly the same URL I am trying to access from the WSDL utility.  I can also access the web service fine from the browser without the WSDL parameter.  IIS is setup to listen on port 80 for the default web site.
Have you tried the WSDL utility from another machine (not the one with the server)?  That way you could 1) see if it is a local problem and 2) monitor the network traffc and see what request is being made.

Author

Commented:
Wow, what a great thought!  I executed the WSDL utility from another machine and it worked!  So what's the deal with that?  I tried rebooting but to no avail
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
The firewall was the problem.  I use ZoneAlarm and as soon as I disabled it, everything was fine.  This was actually not the first time I've had trouble with ZoneAlarm interference.

Thanks very much for your help!
You're welcome.  And happy coding...

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.