Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

RDP into the network

Posted on 2007-10-01
3
Medium Priority
?
1,058 Views
Last Modified: 2008-01-09
I am attempting to setup a Cisco ASA 5505.

For security I am using 4.2.2.2 as the outside IP instead of the actual IP.

Internet <------> (eth0/0 - 4.2.2.2) ASA5505 <---(eth0/1 - 192.168.0.3) ---> PC

I have a single IP address from my ISP.

I can successfully access the internet from inside the network.
I can ping 4.2.2.2 from an outside address. (I get replies and I can see the traffic in the logs)

Issue:  I cannot RDP from an outside IP address into the PC which has an IP of 192.168.0.3; I do not even see log entries on the ASA of any attempt to connect from the outside IP to the ASA for tcp/3389 or any other port for that matter.

Here is the config:


asdm image disk0:/asdm521.bin
no asdm history enable
: Saved
:
ASA Version 7.2(1)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password ***************** encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
 mac-address 000f.b5bd.5ea9 standby 000f.b5bd.5ea8
 nameif outside
 security-level 0
 ip address 4.2.2.2 255.255.252.0
!
interface Ethernet0/0
 switchport access vlan 2
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/1
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/2
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/4
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/5
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/6
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/7
 no nameif
 no security-level
 no ip address
!
passwd ************ encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit tcp any eq 3389 host 4.2.2.2 eq 3389 log
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp permit any outside
asdm image disk0:/asdm521.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 192.168.0.0 255.255.255.0
static (inside,outside) 4.2.2.2 192.168.0.3 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 70.176.72.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.0.2-192.168.0.254 inside
dhcpd dns 192.168.0.1 interface inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:87d072955a34ed6aa15f1c74efecea5f
: end
0
Comment
Question by:gratiot
3 Comments
 
LVL 33

Expert Comment

by:MikeKane
ID: 19996113
IIRC, You can't assign the external IP address on ETH 0/0 to a statically assigned internal address.  You'll need another IP address or you can do port forwarding to the 192 host.
0
 
LVL 5

Expert Comment

by:kmotaweh
ID: 19996426
static (inside,outside) 4.2.2.2 your pc ip  netmask 255.255.255.255 3389
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 19997350
Remove the existing static:
  no static (inside,outside) 4.2.2.2 192.168.0.3 netmask 255.255.255.255
  clear xlate

Remove the existing Acl:
  no access-list outside_access_in extended permit tcp any eq 3389 host 4.2.2.2 eq 3389 log
  no access-group outside_access_in in interface outside

Replace both, using port redirect and "interface"
 static (inside,outside) tcp interface 3389 192.168.0.3 3389 netmask 255.255.255.255
 access-list outside_access_in permit tcp any interface outside eq 3389 log
 access-group outside_access_in in interface outside
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question