Networking Problem between computers. Cannot connect to a PC (Win Xp, Win 2000)

Hi Guys,

I've been trying to create a connection between PC's. ( PC01 & PC02 Win XP Pro, PC03 Win

2000)

The following are the steps i do, but they do not always work (All PCS are under the same Workgroup):

PC01 a) I untick 'Use simple file sharing (recommended)' under Folder Options.
PC01 b) Right Click my Local Hard Disk and under 'Sharing' and 'Security' i allow everyone full access.
PC01 c) Do i HAVE to create a password for the current user?

PC02 a) Same 3 steps as above

PC03 a) Same 3 steps as above

Problem:

a) PC03(win 2000) can connect to the HDs of PC01 but when i try to connect to PC02 it tells
me 'user account restriction' even though i am logged as administrator

b) When i load PC03 it always asks me for the password of PC01, (it tells me that 'the
password was incorrect' when trying to connect automatically on its own) then i type in the
password, and i manage to connect to PC01. Why is it always asking me to type in the
password, why can't it remember it?

c) Can i connect to other PC if the users dont have a password. On the PC03 (Win 2000) i
dont have one and i can still manage to connect to other PC's but the Other PC's with Win XP, they wont let me connect if i dont have a password.

c) I have another PC with Win XP Home on it and was thinking of installing it to the same
workgroup. How will i manage to connect to the other PC's since it doesn't have 'Use simple
file sharing (recommended)' that i can untick.

Thanks in advance,

Dave
 
KenshiroMAsked:
Who is Participating?
 
jvuzConnect With a Mentor Commented:
I suppose it is a workgroup?

Then every pc needs to have the same usernames AND passwords if you want them to be able to access the other pc. So for the administrator, do they all have the same password?
0
 
nicusorConnect With a Mentor Commented:
You should have password for users on windows xp computers. if there is no password windows xp denies access from network

Other thing you can check is the network access: Sharing and security model for local accounts from local security settings set to classic .. it should be classic
0
 
KenshiroMAuthor Commented:
I understand that there should be a password for WIN XP, but do they have to be all the same? doesn't make sense.

What about questiions a,c,d?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Gary CaseRetiredCommented:
First, you DO want to  'Use simple file sharing ..." ==> it's makes things much easier on a simple workgroup setup like you've described.   Is there a specific reason you unchecked this?

To resolve your access issue, you can now do either of the following:

I.  Be sure the username/password is the same on all three systems.

OR (this is easier) ...

II.  Enable the guest account on each system as follows:

     (a)  Right-click on My Computer and select Manage
     (b)  Look for Local Users and Groups under System Tools (on the left side), and expand it to show the two folders, Users and Groups.
     (c)  Highlight the Users folder, and then you'll see the Administrator and Guest account.
     (d)  Highlight the Guest account, and click on Action. Go down to properties, and on the General Tab for Guest Properties, you'll see the box checked for Account is Disabled. Uncheck it, and you should be good to go.

As for adding your XP Home system ...  XP Home uses Simple File Sharing by default ... and will work just fine on this workgroup if you do as I've noted above.
0
 
Gary CaseConnect With a Mentor RetiredCommented:
... Note:  If you DO want to apply permissions that Simple File Sharing doesn't allow, you CAN disable it on XP Home by booting to Safe Mode and changing access the properties on a folder-by-folder basis.   You have to log in as Administrator in Safe Mode to do this.

0
 
matt_pownallConnect With a Mentor Commented:
When connecting to other PCs in a workgroup you must ensure that each PC has the SAME usernames and password on it.

For example, if you are logged in to PC01 as "Dave", and are trying to connect to a shared folder on PC02, if you create a "Dave" account on PC02 with the SAME password as the "Dave" account on PC01, then when you try to access the share it should let you straigh in without asking you for your password, as long as the shared folder has the correct security permissions to allow the "Dave" account access.

a) You say you are trying to connect to a share on PC02 from PC03, and are logged in as Administrator. Are the administrator passwords on both machines the same? If so, it should let you in.

b) When you load PC03 it asks you for the password of PC01. I'm not 100% clear on this, but it sounds as though you have a mapped drive to PC01 that PC03 automatically reconnects to at logon. If you create user accounts the same on each machine it should stop asking you this. Another solution is to click the "Connect using a different user name" option when you map the network drive. This will allow you to use a user name other than the one you are logging on to PC03 with (this username must be one that exists on PC01).

c) As far as I am aware, Windows XP will not allow blank passwords on network connections. This is just a basic security feature, as if it allowed blank password then anyone could get in.

d) Windows XP Home can be a little awkward when it comes to sharing files. You should be able to access files shared on other PCs in the workgroup, as long as the user accounts that have permission to access the files also exist on the XP Home machine. You should only need to worry about unticking the "Simple File Sharing" box on PCs that are actually sharing files and folders. If the XP Home PC is just connecting to shared folders, not actually sharing any itself, then it shouldn't be a problem.

I have had great problems with this sort of thing myself in the past, and after many frustrating hours it turned out to be as simple as making sure the same user accounts exist on each PC, so I hope this helps you solve your problem :)
0
 
KenshiroMAuthor Commented:
Thanks Guys, Will get to you when ill have time to make the above mentioned changes.
0
All Courses

From novice to tech pro — start learning today.