Weird problems with Drive Mappings getting Access denied

Posted on 2007-10-02
Last Modified: 2010-05-18
This morning I came into work and had about a dozen calls right off the bat with people either not getting their drive mappings or getting Access denied.

We have 2 DCs in a single domain, each DC is in a separate building. We use a KIX script for drive mappings.

I sat down at DC1 logged in with the domain admin account and also got Access Denied to the Network Drives which are shares located on a NAS.

I remote logged into DC2 with the same Domain Admin account and had no problems at all. I logged on to my PC and had no problems.... Only a small number of users actually had problems.

I restarted DC1 and still got the Access Denied. I then called one of the users having the problem, and had them log on to their computer with a test account.

When they logged in with the test account they got all the mappings and they were able to get into everything. I had them log out of the test account and log back into their account and it was now working perfectly.

So, I went to DC1, logged off, logged on with another account, everything worked, so I logged off and logged back on with the Domain Admin account again and everything worked.

I checked event logs on the DCs and a couple of the problem PCs and there was nothing out of the ordinary at all.

The problem is gone for the moment, but I don't know what caused it, so I don't know if we have a potentially bigger problem. Any Ideas?
Question by:Luke92881
    LVL 23

    Expert Comment

    It is common that client(s) sometimes lose connection to mapped drive. It has no particular pattern and it only happens to selective (random) clients. Once restarting the machine the mapped drive should reconnect themselves.
    LVL 22

    Accepted Solution

    Access denied indicates a straight permissions problem.
    My GUESS is that you had a date on something expire and renew over-night.
    This would explain the symptoms and the fix.
    To explain .. .
    Newer versions of the MS operating system cache the login information so that you can log in to the machine before everything is completely up and running.
    So, if something expired on the network/server side of the house then the users would still log in using the old information.  When they went to utilize a network resource they would then pass the "expired" object and get an access denied.
    Now, after the user has logged in, they will get an updated copy of what ever has automatically "newed".  So, by logging out and then in again they now have the updated object and do not experience the problem again.

    If this is the case, then any user experiencing this problem should just be able to log out of the machine and then back in again with the same account to rectify the problem.

    That said, I don't think this is a sign of a bigger problem.
    You probably should look into it and see if you can find out what is causing it though, it SHOULDN'T do this to you.

    Any one else out there experience anything like this and can confirm this?  And for that matter, know where to look to find what is causing it?
    LVL 3

    Author Comment

    The only thing that bothered me is that even after restarting PCs this was still going on... Worse yet it was happening on one of the DCs.

    The solution as I said was to log in as a different user first on the affected PC and then log back in as the original user of that PC.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Windows 7 does not have the best desktop search built in. This is something Windows 7 users have struggled with. You type something in, and your search results don’t always match what you are looking for, or it doesn’t actually work at all. There ar…
    A quick step-by-step overview of installing and configuring Carbonite Server Backup.
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now