?
Solved

Can't get tunnels up between DMVPN spokes Cisco 1841

Posted on 2007-10-02
4
Medium Priority
?
965 Views
Last Modified: 2012-08-13
Hi,

I have  a routerCisco 1841 that's attached to an ADSL modem so it's double natted its connecting fine to the mail DMVPN hubs but isnt picking up tunnels to other DMVPN spoke sites.

heres the config.. all help appreciated
Current configuration : 9123 bytes
!
! Last configuration change at 14:47:52 UTC Tue Oct 2 2007
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ank1-n-1841
!
boot-start-marker
boot system flash:c1841-advsecurityk9-mz.124-16a.bin
boot-end-marker
!

!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.201.1 192.168.201.100
!
ip dhcp pool default
   network 192.168.201.0 255.255.255.0

   netbios-name-server 195.163.13.186
   default-router 192.168.201.1
   dns-server 192.168.201.8 195.163.13.186 192.168.168.8
!
!
no ip domain lookup
ip domain name xxxxxxxx
ip host trinity.xxxxxxx 157.208.235.25
!
!
crypto pki trustpoint MYCA
 enrollment mode ra
 enrollment url xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
 revocation-check crl none
!
!
crypto pki certificate chain MYCA
 certificate 139800110000000000BE
  308204FD 308203E5 A0030201 02020A13 98001100 00000000 BE300D06 092A8648
  86F70D01 01050500 303E3112 3010060A 09922689 93F22C64 01191602 64733116
  3014060A 09922689 93F22C64 01191606 6D617472 69783110 300E0603 55040313
  07747269 6E697479 301E170D 30373033 31363133 35393339 5A170D32 37303331
    quit
 certificate ca 398B5D96C713EFA84B355CB151E7CC50
  30820452 3082033A A0030201 02021039 8B5D96C7 13EFA84B 355CB151 E7CC5030
  0D06092A 864886F7 0D010105 0500303E 31123010 060A0992 268993F2 2C640119
  16026473 31163014 060A0992 268993F2 2C640119 16066D61 74726978 3110300E
  06035504 03130774 72696E69 7479301E 170D3035 30393230 32313235 32395A17
  0D333030 39323032 31333530 305A303E 31123010 060A0992 268993F2 2C640119
  16026473 31163014 060A0992 268993F2 2C640119 16066D61 74726978 3110300E
  06035504 03130774 72696E69 74793082 0122300D 06092A86 4886F70D 01010105
    35600CB8 C5648402 87A375B5 D363E6D4 48CB61BA A4EA
  quit
!
!
!
!
crypto isakmp policy 10
 encr 3des
crypto isakmp keepalive 10
!
!
crypto ipsec transform-set trans1 esp-3des esp-sha-hmac
 mode transport
!
crypto ipsec profile golderwan
 set transform-set trans1
!
!
!
!
interface Tunnel0
 bandwidth 2048
 ip address 172.16.9.14 255.255.240.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication tank
 ip nhrp map 172.16.11.1 157.208.238.1
 ip nhrp map multicast 157.208.238.1
 ip nhrp map 172.16.7.1 64.42.200.140
 ip nhrp map multicast 64.42.200.140
 ip nhrp network-id 100
 ip nhrp nhs 172.16.11.1
 ip nhrp nhs 172.16.7.1
 ip nhrp registration timeout 30
 ip nhrp cache non-authoritative
 ip tcp adjust-mss 1360
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 100
 tunnel protection ipsec profile golderwan
!
interface FastEthernet0/0
 description ADSL 2Mbps/512Kbps
 ip address 192.168.2.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description 192.168.201.0/24
 ip address 192.168.201.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1360
 duplex auto
 speed auto
!
router eigrp 1
 network 172.16.0.0 0.0.15.255
 network 192.168.201.0
 no auto-summary
 eigrp stub connected static
!
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
ip http server
no ip http secure-server
ip nat inside source list acl_nat interface FastEthernet0/0 overload
!
ip access-list extended acl_nat
 permit ip 192.168.201.0 0.0.0.255 any
!

!
!
control-plane
!
call admission limit 75


!
scheduler allocate 20000 1000
ntp clock-period 17178510
ntp update-calendar
ntp server 157.208.255.6
end

ank1-n-1841#
0
Comment
Question by:peter_sutton
3 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 20002151
> it's double natted
>tunnel mode gre multipoint

GRE hates nat, even once, and I don't think that Multipoint GRE will ever work behind a nat device. I wish I had better news for you.

All of the Cisco examples for DMVPN show public IP addresses for the WAN facing interface. Yes, I know some show 172.16.x.x, but this is for example purposes only.
0
 
LVL 15

Expert Comment

by:wingatesl
ID: 20145274
The NAT is definitely the problem, you can get GRE(IPsec) out through NAT to a hub -actually you can NAT it a couple of times. The remote sites will never talk to each other properly. We thought we were close once... once
0
 

Expert Comment

by:Douglas_Fagerstrom
ID: 21623852
is this question resolved?  I am facing a similar problem.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

755 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question