[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Remote Web Workplace / IIS problems in SBS 2003

Posted on 2007-10-02
16
Medium Priority
?
873 Views
Last Modified: 2012-05-05
I have a client that is continually have a connection issue with RWW.

Randomly access to this site will be lost, this includes https://server/exchange and http://server/remote.
I have read that .NET 2.0 may cause this problem and i have uninstalled that.  I tried restarting all websites listed in IIS with not luck.  I also tried restarting the IIS admin service and its dependants also with no luck.

I also tried creating a virtual directory in the default website but could not browse to that either which leads me to believe it is an IIS issue but i am unsure of what is cuasing it.  These sites cannot be browsed internally or externally, all that is displayed is a "Page cannot be displayed" error and the generic information asscociated with it.

One thing that does resolve this issue is a server reboot.  However this only resolves the problem for a few days maybe a week at best.

Any insight or troubleshooting steps regarding this would be much appreciated.
0
Comment
Question by:kitechgroup
  • 5
  • 4
  • 3
  • +2
14 Comments
 
LVL 15

Expert Comment

by:Dave_AND
ID: 20006920
As its SBS box, did you do the simple thing of running the Internet Connection Wizard? and did you check that the IIS is using for its default website IP Addressed (all unasigned) and TCP port 80 with SSL 443?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 20010750
I'd suspect that the error displayed when access is lost to RWW is a VBScript Error.

If so, it may be related to having the new Terminal Services Client v6 installed on both the Server and/or remote workstation.  So far, I've not seen a fix for this issue other than uninstalling that update (http://support.microsoft.com/kb/925876) and reverting back to the v5 RDP Client.

Jeff
TechSoEasy
0
 

Author Comment

by:kitechgroup
ID: 20021174
I have ran all the wizards and checked everything during the time of failure.  Nothing but a reboot seemed to resolve the issue.  After a reboot all is well for up to a week the next failure could be from a few hours to a few days away.

As far a being a VBScript error i am not sure you may be right  will check in to that and report back with whatever I find.  Will also try removing that patch.
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 

Author Comment

by:kitechgroup
ID: 20233657
Still having the problem and there is nothing in the logs that say there is anything wrong.  It is not a vbscript error and the patch is not the problem.

Like I said earlier OWA stops, companyweb stops, and so does RWW.  There are no errors indicating IIS has had a problem and all appears to be running fine.

Any further suggestions would help tremendously.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 20247509
If you had .NET 2.0 installed and uninstalled it, you also need to make sure that .NET 1.1 is properly applying itself to each virtual directory.

To do this, please delete all the files in C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files

Then run the following command at a CMD prompt:
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i

Jeff
TechSoEasy
0
 
LVL 1

Expert Comment

by:GGUser
ID: 20433516
I have had this exact same problem on my own SBS server and have just started getting the problem on a clients server. The problem occured on our server every 8 days and 2 hours exactly and everything powered by IIS would stop working although IIS appeared to be fine when you looked at the admin panel. There were no errors in the event logs and nothing wrong to a trained eye but IIS would not display any web pages; just the standard "Page cannot be displayed" error.

I tried EVERYTHING to solve this issue. I got several other IT people to take a look with no luck and even got Microsoft on the case (who were useless). In the end I had to re-install the server from scratch which obviously solved the issue.

The problem is I now have the same problem on a clients server and I don't want to have to rebuild that from scratch.  I have posted on several forums and have spoken to few others with the problem but so far have found no fix. MS recomended re-installing IIS but with SBS this is so integrated with Exchange and the OS I felt it was just as easy to start from scratch which is what I did. Currently I am just re-booting my clients server every Saturday which solves the problem temporerily but obviously this is not a long term fix.

What 3rd party software are you using btw (Virus, backup etc). I'd like to build a picture of the similarities/differeneces between our systems.
0
 
LVL 1

Expert Comment

by:GGUser
ID: 20433565
Applogies if I overstepped the bounds of EE. The reason for posting in this topic was not to 'piggyback' someone elses question (Because I wasn't actually asking for help if you re-read my post) but to ask kitechgroup what 3rd party programs he was using and to let him know that others out there also have seen this issue and are working on a resolution. In my travels I have only found 4 other people with the exact same issue and so I wanted to take the opportunity to see what 3rd party programs he was using in an atrempt to correlate some similarities and potentially help the originator of this topic in the process.

I do understand that the question was perhaps older than would have been ideal but as the question was asked directly to the originator of the topic and not to other experts on the board I didn't see this as a problem. Obviously I was wrong and I applogise for that!
0
 
LVL 1

Expert Comment

by:GGUser
ID: 20433727
Good points... I will follow your advice and structure a detailed question for the correct zones!
0
 

Author Comment

by:kitechgroup
ID: 20441273
I did get Microsoft involved as well and this was their resolution.

"created disabletaskoffload dword value =1 on the following path
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
On the same location set the value for EnableRSS to 0
Disable offloading features from the network card.
Rebooted the server."

It worked for 3 weeks after this but the problem eventually reoccured.  I am not sure if it was a legitimate server problem this time but I will keep watching it.

I will try registering ASP and see if that helps as well.  Sorry for the delayed response but things have been hectic here!
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 20452495
There's actually a patch available for this situation if you've installed Windows Server 2003 SP2
http://support.microsoft.com/kb/936594

Jeff
TechSoEasy
0
 
LVL 1

Expert Comment

by:GGUser
ID: 20452593
Thanks for that link. I shall give that a go and report back!

It takes about a week before the problem occurs and I want to wait until it occurs again before I patch so it may well be several weeks before I can give a yes or no on this one.
0
 
LVL 1

Expert Comment

by:GGUser
ID: 20561118
Just to confirm. The above patch (936594) did not resolve the issue I am having.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 20561544
Then, this is exactly why you should post your own question.

Jeff
TechSoEasy
0
 
LVL 1

Accepted Solution

by:
John_Seele earned 2000 total points
ID: 21910285
This worked for me!!!!!!!!!!!!!!!!!!!!!!
http://support.microsoft.com/kb/934878
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lync server 2013 or Skype for business Backup Service Error ID 4049 – After File Share Migration
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question